newbie member/ elec.issue - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-18-2012, 07:38 AM Thread Starter
Junior Member
Points: 4, Level: 1 Points: 4, Level: 1 Points: 4, Level: 1
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Posts: 1
newbie member/ elec.issue

Hi. New here. Own '06 commander, 4wd 3.7 130k. Dash lights have always flickered a bit, dimming in and out while running. No Biggie. But this morning, stopped at a light and all of the dash lights illuminated brightly and the blower motor flickered (It stopped, then resumed). I appeared as though the car stalled, which it didn't. I drove a bit and it happened again. I turned off the car, sat for 15 minutes, then drove 20 miles home and it didn't happen again. Battery terminals were cleaned about a month ago. Anything I can do/test? 1000 mile trip coming up Wednesday for thanksgiving with family. Thanks, Joe
fogelsvillejoe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-19-2012, 09:46 AM
Senior Member
Points: 6,458, Level: 52 Points: 6,458, Level: 52 Points: 6,458, Level: 52
Level up: 54% Level up: 54% Level up: 54%
Activity: 4% Activity: 4% Activity: 4%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Posts: 498
There have been electrical problems related to the wiring connections, especially the starter, located near the drivers side front wheel. Its tough to get to but if your able to remove the wires and brush the connections and maybe put a light coat of dielectric grease and reattach. Clean all the connections at battery, starter and your grounds. Its a start....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
post #3 of 3 (permalink) Old 11-20-2012, 09:20 AM
Senior Member
Points: 4,379, Level: 42 Points: 4,379, Level: 42 Points: 4,379, Level: 42
Level up: 15% Level up: 15% Level up: 15%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2008
Location: West Palm Beach, Florida
Posts: 329
Check and test your alternator. It could be dying.

2007 Jeep Commander 4X4, 4.7, Steel Blue
2003 Ford Thunderbird, White, Black Top w/ Port Holes
BADOS is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome