really bad fuel economy - Page 4 - Jeep Commander Forums: Jeep Commander Forum
General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

Reply
 
LinkBack Thread Tools Display Modes
post #31 of 38 (permalink) Old 01-11-2013, 08:44 PM
Senior Member
Points: 3,326, Level: 35 Points: 3,326, Level: 35 Points: 3,326, Level: 35
Level up: 84% Level up: 84% Level up: 84%
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jan 2013
Location: New Jersey
Posts: 201
Not a Problem Martin haha just glad you got it all fixed. Did corporate ever help you? So was it just not burning the fuel in those cylinder?

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on factory exhaust pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear. Black on Brown.
06hemixk is offline  
Sponsored Links
Advertisement
 
post #32 of 38 (permalink) Old 01-11-2013, 09:45 PM
Member
Points: 2,073, Level: 27 Points: 2,073, Level: 27 Points: 2,073, Level: 27
Level up: 49% Level up: 49% Level up: 49%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2010
Location: Brigantine, NJ
Posts: 98
Send a message via Yahoo to JBenn911
Good news !!!

2007 Hemi Limited Silver
2011 Ford Raptor
2008 Chevy 2500 Suburban (Work truck)
JBenn911 is offline  
post #33 of 38 (permalink) Old 01-13-2013, 12:26 PM Thread Starter
Junior Member
Points: 136, Level: 2 Points: 136, Level: 2 Points: 136, Level: 2
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Posts: 15
not burning fuel in the last two cylenders at all just pooling and dumping. corporate called and they basically said they could offer me emplyee pricing if i wanted to buy a new jeep dodge etc... lol i just bought the xk
martin.steve is offline  
post #34 of 38 (permalink) Old 01-14-2013, 10:55 AM
Junior Member
Points: 3,836, Level: 39 Points: 3,836, Level: 39 Points: 3,836, Level: 39
Level up: 24% Level up: 24% Level up: 24%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2009
Location: Caracas, Venezuela
Posts: 10
Hi Steve, how did you get to this diagnosis? what kind of tests did you perform to realize that? I'm having same issue with my 2007 hemi. Also noticed you said you just changed the oil, are you sure it had 5w20 oil? I read if oil is not 5w20 MDS won't activate. Thanks for you sharings.

Last edited by JeepVen; 02-02-2013 at 07:28 AM.
JeepVen is offline  
post #35 of 38 (permalink) Old 02-01-2013, 12:12 PM
Senior Member
Points: 3,326, Level: 35 Points: 3,326, Level: 35 Points: 3,326, Level: 35
Level up: 84% Level up: 84% Level up: 84%
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jan 2013
Location: New Jersey
Posts: 201
I feel like even with out MDS i still get atleast 14mpg highway.. i get 18.2 with it on.. Employee pricing aint bad, what did the repairs cost you from the stealership ?

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on factory exhaust pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear. Black on Brown.
06hemixk is offline  
post #36 of 38 (permalink) Old 02-04-2013, 11:29 PM Thread Starter
Junior Member
Points: 136, Level: 2 Points: 136, Level: 2 Points: 136, Level: 2
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Posts: 15
i dont know what the cost of the repair was because the dealership paid for the repairs since i just bought it. Unforunatley it didnt compleatly solve my fuel issues. now that ive driven it a couple weeks after getting the work dont its riding around 22ltrs/100km's im just gonna start switching out the usual culprits, ir maf, pcv valve, o2 sensors. from what ive read these sensors can be off quite a bit without tripping a code and ive done everything else we can think of so... heres hoping it gets better
martin.steve is offline  
post #37 of 38 (permalink) Old 02-25-2013, 02:51 PM
Senior Member
Points: 3,326, Level: 35 Points: 3,326, Level: 35 Points: 3,326, Level: 35
Level up: 84% Level up: 84% Level up: 84%
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jan 2013
Location: New Jersey
Posts: 201
Any luck thus far Martin? This seems like a silly question, but do you know if its going to closed loop?

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on factory exhaust pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear. Black on Brown.
06hemixk is offline  
post #38 of 38 (permalink) Old 04-09-2013, 07:21 AM
Member
Points: 1,767, Level: 24 Points: 1,767, Level: 24 Points: 1,767, Level: 24
Level up: 67% Level up: 67% Level up: 67%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Posts: 37
I've got bad news about cleaning your maf sensor.....none of us have one. Try sparkplugs, injector cleaner, maybe seafoam.

Sent from AutoGuide.com App
Centcomm87 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome