08 Commander Cruise Control Wont Work - Jeep Commander Forums: Jeep Commander Forum
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-12-2012, 06:33 PM Thread Starter
Junior Member
Points: 4, Level: 1 Points: 4, Level: 1 Points: 4, Level: 1
Level up: 7% Level up: 7% Level up: 7%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2012
Posts: 1
08 Commander Cruise Control Wont Work

Hey i have a 2008 Jeep commander got it from the dealership and the cruise control does not turn on didnt notice it when i took a test drive would love to fix ASAP any suggestions i checked all the fuses they are fine.
Eskimo253 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-12-2012, 07:26 PM
Senior Member
Points: 11,816, Level: 71 Points: 11,816, Level: 71 Points: 11,816, Level: 71
Level up: 42% Level up: 42% Level up: 42%
Activity: 0% Activity: 0% Activity: 0%
 
robby's Avatar
 
Join Date: Jun 2008
Location: Desplaines IL.
Posts: 3,262
The 08 Commanders, regardless of engine, have electronic throttle control (no cable).

There are no cut and dried suggestions I can make.....the cruise is controlled by computer.
Could be something as simple as the on/off switch in the steering wheel, to a bad brake light switch (shuts cruise off) to a full blown computer problem.

You'll likely need the Jeep dealer for this one.

Rob
robby is offline  
post #3 of 3 (permalink) Old 02-21-2016, 07:54 AM
Senior Member
Points: 2,240, Level: 28 Points: 2,240, Level: 28 Points: 2,240, Level: 28
Level up: 60% Level up: 60% Level up: 60%
Activity: 18% Activity: 18% Activity: 18%
 
Join Date: Mar 2014
Posts: 164
Cruise Control

Quote:
Originally Posted by Eskimo253 View Post
Hey i have a 2008 Jeep commander got it from the dealership and the cruise control does not turn on didnt notice it when i took a test drive would love to fix ASAP any suggestions i checked all the fuses they are fine.
Did you ever get this fixed? What was the solution?

08, Commander, Overland, 5.7L HEMI, QD-II
vjsimone is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome