06' 5.7 won't lock or unlock with button on key - Jeep Commander Forums: Jeep Commander Forum
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-07-2012, 04:31 PM Thread Starter
Junior Member
Points: 1,168, Level: 18 Points: 1,168, Level: 18 Points: 1,168, Level: 18
Level up: 68% Level up: 68% Level up: 68%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2010
Posts: 12
06' 5.7 won't lock or unlock with button on key

So, two days ago I got out of my Jeep and pushed the lock button on the key and nothing happened. I tried it a couple more times and nothing. It was during the day and in a pretty nice neighborhood so I decided to leave it unlocked. Later that night I got home and it wouldn't lock again so I locked it manually by pushing the lock button on the door. The next morning I go outside to go to work and the Jeep won't unlock. So I decide to go the old fashioned route and stick the key in the door and unlock it and open the door. This triggered the alarm to go off. I have a 160 decibel train horn which was installed about 6 months ago on my Jeep. Due to my shock that the alarm was going off I tried pushing buttons on the key with no luck and it took me a good 10 seconds to jump in and start the Jeep causing the alarm to turn off. In that 10 second period I'm fairly certain that my Jeep woke up everyone in my neighborhood and probably the next town over.

So, I decided that I better get this issue resolved. I drove to Walgreens to buy a new battery for the key. When I get to Walgreens I get out of the Jeep hit the lock button on the key and it locks. It also unlocked when I got back outside. I changed the battery in the key anyways. Drove to work and it successfully locked using the button on the key on my way in. When I came back outside around lunch time it wouldn't unlock. This time I was prepared and the alarm only sounded for a couple seconds before I got it started. When I got home I tried the spare key to lock the Jeep. No luck.

So, it isn't the battery in the key because that's brand new. It isn't the wiring in the key because both keys are having the same issue. Does anyone have any idea what could be the issue? I have searched the forums and have not seen anyone else with the same problem I am having.
Krussdog46 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 06-07-2012, 10:29 PM
Senior Member
Points: 6,167, Level: 51 Points: 6,167, Level: 51 Points: 6,167, Level: 51
Level up: 9% Level up: 9% Level up: 9%
Activity: 25% Activity: 25% Activity: 25%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Posts: 491
The harness that holds the battery in place has 3 points of contact-if one of those are loose, or broken, it will intermittenly work. If your keys hit the ground, this could happen. I unscrewed and popped the key fob open, remove the battery and had to solder the harness back to the board. A very tedious job, but it worked. This metal bracket should be soldered left, right and center. If any of these are not tightly connected in place, there's your answer.


2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome