Service 4WD System - Jeep Commander Forums: Jeep Commander Forum
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 10-26-2012, 03:00 PM Thread Starter
Member
Points: 3,216, Level: 35 Points: 3,216, Level: 35 Points: 3,216, Level: 35
Level up: 11% Level up: 11% Level up: 11%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2010
Location: Little Hocking, Ohio
Posts: 31
Exclamation Service 4WD System

Maybe I missed anything pertaining to this but here goes. My "Service 4WD System" message on the dash comes on about every 30 seconds. You can reset it and 30 seconds later it comes back on. I have no noises, grinding or jerking that I can detect. I tried to engage the 4WD system by pulling up on the "T" bar on the console and immediately the "Service 4WD System" message comes on. There is also no noises, grinding or jerking when the "T"bar is lifted. I crawled underneath and removed the electrical plug and it looked clean and shinny on the contacts. All the fuses check out ok. I have a 2006 Commander Limited, 4.7V8, Quadratrac. Any help would be appreciated. Thanks in advance and may God bless.
FiremanJim is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 10-26-2012, 03:04 PM
Senior Member
Points: 52,702, Level: 100 Points: 52,702, Level: 100 Points: 52,702, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 52% Activity: 52% Activity: 52%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Posts: 14,505
http://www.jeepcommander.com/forums/showthread.php?t=1164&page=21

.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #3 of 9 (permalink) Old 10-26-2012, 04:22 PM
Senior Member
Points: 13,398, Level: 75 Points: 13,398, Level: 75 Points: 13,398, Level: 75
Level up: 37% Level up: 37% Level up: 37%
Activity: 4% Activity: 4% Activity: 4%
 
lekmedm's Avatar
 
Join Date: Mar 2008
Location: Annandale, NJ
Posts: 926
See if you can pull any codes and post back.

Sent from my SAMSUNG-SGH-I727 using AutoGuide.Com Free App

2007 Jeep Commander Overland - Steel Blue
5.7L Hemi + QDII
4" SuperLift
Rusty's adjustable rear UCAs
Caroline Driveline front drive shaft
285/70/17 Cooper Discoverer ST Maxx
Activated: DRLs + Tilting Mirrors
Autolite Iridiums
Cobra LX 29 LE CB with Firestik antenna
Rear fog lights
Mopar Grille Guard with Rugged Ridge HID driving lights
Sylvania Silverstars Ultra hi/low


"4 wheel drive does not mean 4 wheel stop!" -Lee Goldberg, WABC TV weatherman
lekmedm is offline  
post #4 of 9 (permalink) Old 10-28-2012, 10:59 AM
Senior Member
Points: 2,282, Level: 28 Points: 2,282, Level: 28 Points: 2,282, Level: 28
Level up: 88% Level up: 88% Level up: 88%
Activity: 0% Activity: 0% Activity: 0%
 
XKDRIVER's Avatar
 
Join Date: Oct 2010
Location: South Texas
Posts: 263
Along with doing a key dance, you could cross check any codes you get against the code readers most parts stores will do for free.
XKDRIVER is offline  
post #5 of 9 (permalink) Old 10-29-2012, 09:05 AM Thread Starter
Member
Points: 3,216, Level: 35 Points: 3,216, Level: 35 Points: 3,216, Level: 35
Level up: 11% Level up: 11% Level up: 11%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2010
Location: Little Hocking, Ohio
Posts: 31
The only code that's coming up is "Camshaft Position Sensor". I will be replacing that today but I don't feel that it and the 4WD system would be interconnected.
FiremanJim is offline  
post #6 of 9 (permalink) Old 11-13-2012, 07:04 PM
Senior Member
Points: 4,556, Level: 43 Points: 4,556, Level: 43 Points: 4,556, Level: 43
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
H311B0Y's Avatar
 
Join Date: Sep 2010
Location: Quebec,Canada
Posts: 123
u will not get any codes from the key dance on that issue! u need a good scanner or go to the dealer for tranny and 4x4 system

2006 commander limited 5.7 hemi silver loaded and now with hid's hi low and fogs,now with viper 5901 alarm starter combo and idatalink ads al ca ch5,yokohama geolandar I/T GO72
H311B0Y is offline  
post #7 of 9 (permalink) Old 11-14-2012, 12:20 PM
Member
Points: 2,970, Level: 33 Points: 2,970, Level: 33 Points: 2,970, Level: 33
Level up: 47% Level up: 47% Level up: 47%
Activity: 0% Activity: 0% Activity: 0%
 
JeepDog's Avatar
 
Join Date: Dec 2008
Location: ma
Posts: 30
I brought my 08 overland to a more local dealer this morning @ 9 am to find out what's up with my "service 4wd system" indicator and the grinding noise when i turn the wheel. twice now, while the fobik was in the on position, a loud clank could be heard just about where the transfer case is located. i'm no mechanic, but i'd probably start there. after the "clank", the transmission seems to be fine. now wouldn't you know that right when the dealer's mech got in, CLANK and it was running fine for his test drive. ah well... he agrees that there should be some code for what is happening so we'll go from there. the bummer was that i was told i might have to pay for two diagnostic tests at $120 a pop if this isn't covered under my unlimited powertrain warranty and they are keeping my XK until they can figure out what's up. i have 29,600 and change on her. the reason for this post is that i can't find anything that states exactly what was the problem and what was done to correct the problem and this is way beyond something i would attemp myself, even though there is exceptional information on this site (although it could be because i'm growing impatient with the search) i'll continue as i find out more. hoping to see the old girl soon or at least hear from the shop...

'08 overland red rock w/ chrome, 5.7 hemi, quadra drive II. me likey
JeepDog is offline  
post #8 of 9 (permalink) Old 11-15-2012, 07:19 AM
Member
Points: 2,970, Level: 33 Points: 2,970, Level: 33 Points: 2,970, Level: 33
Level up: 47% Level up: 47% Level up: 47%
Activity: 0% Activity: 0% Activity: 0%
 
JeepDog's Avatar
 
Join Date: Dec 2008
Location: ma
Posts: 30
Here we are, day two. last night i got a phone call from the dealer. why do they always have women call when they have bad news? they inform me that the mech will be taking my XK home so he "can test it further" even though he said "i wouldn't feel safe letting you drive this in this condition". i said hell no, i'll come when my wife gets home to pick it up. i was told they had no difinitive answer that the codes were "stored". does anyone know what that means? they said it means they cannot continue to look for any issues. so, the mech heard the clank, felt the clank, sees codes referring to the clank, but will not look for the cause because he "won't get paid for it". "i can't put an $800 transfer case in just assuming it will make everything better", was the manager's reply. i left my vehicle there over night, after speaking to the manager, matt. he asked that they have a bit more time. i can understand that, but there's one thing i can't understand: he said i would have to pay for the diagnostic ($120) because they can't pin the test to any powertrain issue.
so if i want to pick my rig up i'll have to pay them. but if i leave it over night they may have some time to discover a problem, basically holding her for ransom. what is the point of having a warranty if the dealer is just going to nickle and dime you claiming they can't match codes to covered components? this entire experience has left me what a, well, bad taste in my mouth. there are no good dealers in the western massachusetts area. i have no idea what has happened to people's desire to fix things. my collar is about as blue as they come, i troubleshoot, but i don't know much about auto mechanics so i won't attemp anything of this magnitude.
i would like to know what the problem is, nevermind fixing the damn thing just tell me what is wrong. i'm going to check the new legislation in ma, the right to repair, to see if my mech can try to give it a shot under warranty. they dealer should call back today so i'll be bringing her home in one condition or another. there will be more to post i'm sure of it...

'08 overland red rock w/ chrome, 5.7 hemi, quadra drive II. me likey
JeepDog is offline  
post #9 of 9 (permalink) Old 11-16-2012, 07:01 AM
Member
Points: 2,970, Level: 33 Points: 2,970, Level: 33 Points: 2,970, Level: 33
Level up: 47% Level up: 47% Level up: 47%
Activity: 0% Activity: 0% Activity: 0%
 
JeepDog's Avatar
 
Join Date: Dec 2008
Location: ma
Posts: 30
got my jeep back yesterday afternoon. the service 4wd light is off, that's good, no more symptoms of a problem, that's cool, but nobody actually did anything major. i guess that's ok if there was not a problem. i was basically told to drive the thing and wait for the worst. i can't wait until my wife and i are in the 3' snows of vermont when my 4wd craps out on me. ah, good times we'll be havin! maybe we can just ski home. service "professionals" bound by a guideline, written by a guy wearing a tie, who probably never trouble-shot a damn thing in his life. in my best gump voice, that's all i have to say about that

'08 overland red rock w/ chrome, 5.7 hemi, quadra drive II. me likey
JeepDog is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome