'06 Commander Transmission Problem Need Help - Jeep Commander Forums: Jeep Commander Forum
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-15-2012, 06:30 PM Thread Starter
Junior Member
Points: 2,126, Level: 27 Points: 2,126, Level: 27 Points: 2,126, Level: 27
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2012
Posts: 16
'06 Commander Transmission Problem Need Help

So on Sunday, we drove our commander and it worked great. It sat in the driveway for a few days and the other day my wife got in it and now it's having an issue. We have a 2006 Commander Limited 5.7 Hemi Duratrac with 125K and no engine lights are showing

Problem:
It starts up with no problems. The gear shifter will move freely and the dashboard reflects the gear changes on the panel. However, it does not seem to engaging the gears and will not move forward, reverse or go into neutral. Usually you can feel it go into gear but there is no sensation of it going into gear as you move the shifter around.

So our commander is sitting still and unable to move it.

I've heard it maybe a tranny solenoid or the PCM.

Can anyone help diagnosis this problem a little better.

Last edited by outdoorpodcast; 12-15-2012 at 06:38 PM.
outdoorpodcast is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-16-2012, 05:19 PM
Senior Member
Points: 4,329, Level: 41 Points: 4,329, Level: 41 Points: 4,329, Level: 41
Level up: 90% Level up: 90% Level up: 90%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Location: ontario, canada
Posts: 120
mine was getting slow to engage then i changed BOTH tranny filters and the problem went away. BTW get them from the dealership don't buy aftermarket ones.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

06 Limited 5.7 HEMI QD2
4xGuard Belly Guard
k&n intake
Magnaflow catback
Kicker Speaker Upgrade
2" RC lift
Bilstein front shocks
F150 rear load levelers
Rola roof rack
255/75/17 BF Goodrich M/T KM
Spidertrax 1.25 spacers
jthurstonjr is offline  
post #3 of 10 (permalink) Old 12-22-2012, 05:40 PM Thread Starter
Junior Member
Points: 2,126, Level: 27 Points: 2,126, Level: 27 Points: 2,126, Level: 27
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2012
Posts: 16
Posting Follow-up

My mechanic brother finally came today and got the Commander back on the road, so I thought I'd post a follow-up in case anyone else has a similar problem.

He replaced the TCM and it solved the issue. It engages the gears perfectly now and drives just fine.
outdoorpodcast is offline  
post #4 of 10 (permalink) Old 12-22-2012, 08:33 PM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,317
How much did the TCM cost??

2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
post #5 of 10 (permalink) Old 12-23-2012, 08:07 AM Thread Starter
Junior Member
Points: 2,126, Level: 27 Points: 2,126, Level: 27 Points: 2,126, Level: 27
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2012
Posts: 16
IT was $327 from the local dealership but they gave me a business discount o it was $250 for the part.
outdoorpodcast is offline  
post #6 of 10 (permalink) Old 12-23-2012, 08:09 AM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,317
That's not bad. Well if my jeep ever does this I now know how to fix it

2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
post #7 of 10 (permalink) Old 01-07-2013, 09:14 AM
Senior Member
Points: 5,906, Level: 49 Points: 5,906, Level: 49 Points: 5,906, Level: 49
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
XKTX's Avatar
 
Join Date: Jun 2007
Location: San Antonio, Texas
Posts: 269
Quote:
Originally Posted by outdoorpodcast View Post
My mechanic brother finally came today and got the Commander back on the road, so I thought I'd post a follow-up in case anyone else has a similar problem.

He replaced the TCM and it solved the issue. It engages the gears perfectly now and drives just fine.
I am having the same problem this morning, do you know where is the TCM Located? I appreciate your help. Thanks!

06' Black Limited QDII HEMI - 2" Revtek Lift 245/75/17 Goodyear Duratrac -Monroe Sensa Trac Struts and Sensa Trac Load Adjusting Shocks.
XKTX is offline  
post #8 of 10 (permalink) Old 01-07-2013, 10:21 PM
Senior Member
Points: 7,761, Level: 59 Points: 7,761, Level: 59 Points: 7,761, Level: 59
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
USMCMP's Avatar
 
Join Date: Nov 2008
Location: Wisconsin
Posts: 697
When my TCM was replaced at the dealership it cost double that. The Jeep would go into gear but only third gear and reverse. Instead of going to "D" the dash would say "3" like when using the autostick. Wouldnt shift up or down just 3 the whole way

'06 HEMI LIMITED LOADED QDII DE-BADGED, TINT, SILVERSTAR ULTRAS, LED TAILS, R/C LIFT, BILSTEINS, KMC XD HOSS WHEELS, DURATRACS, MAGNAFLOW, K&N CAI and OIL FILTER, ROYAL PURPLE, HAWK HPS PADS, RED CALIPERS, LEDs BEHIND GRILLE

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
USMCMP is offline  
post #9 of 10 (permalink) Old 01-18-2013, 10:33 PM
Senior Member
Points: 5,906, Level: 49 Points: 5,906, Level: 49 Points: 5,906, Level: 49
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
XKTX's Avatar
 
Join Date: Jun 2007
Location: San Antonio, Texas
Posts: 269
Today I got my Jeep back from the dealership and the transmission was rebuilt. The lifetime powertrain warranty covered it my deductible was $100.00 dollars which covered the towing, 5 day car rental and parts and labor.

06' Black Limited QDII HEMI - 2" Revtek Lift 245/75/17 Goodyear Duratrac -Monroe Sensa Trac Struts and Sensa Trac Load Adjusting Shocks.
XKTX is offline  
post #10 of 10 (permalink) Old 01-30-2013, 11:55 AM
Senior Member
Points: 4,967, Level: 45 Points: 4,967, Level: 45 Points: 4,967, Level: 45
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
rjhj's Avatar
 
Join Date: Oct 2011
Location: Toronto, Ontario.
Posts: 473
What could cause my jeep to clunk into 1st gear from 2nd upon deceleration and only while I apply the break. Just had the transmission solenoid pack replaced then transmission rebuilt and serviced and got it back last night.

Just hoping for a little insight before I call the shop back and hear what they have to say.

Thanks in advance anyone who can contribute some wisdom.


Sent from AutoGuide.com App
rjhj is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome