Stalling!!! - Page 3 - Jeep Commander Forums: Jeep Commander Forum
Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

Reply
 
LinkBack Thread Tools Display Modes
post #21 of 31 (permalink) Old 01-18-2013, 11:16 AM
Senior Member
Points: 6,458, Level: 52 Points: 6,458, Level: 52 Points: 6,458, Level: 52
Level up: 54% Level up: 54% Level up: 54%
Activity: 3% Activity: 3% Activity: 3%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Posts: 498
This goes for oxygen sensors also, it'll throw codes and run like **** til its warmed up. Only use Mopar


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
Sponsored Links
Advertisement
 
post #22 of 31 (permalink) Old 01-18-2013, 02:34 PM
Senior Member
Points: 3,326, Level: 35 Points: 3,326, Level: 35 Points: 3,326, Level: 35
Level up: 84% Level up: 84% Level up: 84%
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jan 2013
Location: New Jersey
Posts: 201
Yea i have heard that about the o2 sensors, that can be a pain. , Good word Karmatt.

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on factory exhaust pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear. Black on Brown.
06hemixk is offline  
post #23 of 31 (permalink) Old 01-20-2013, 02:20 AM
Junior Member
Points: 1,360, Level: 20 Points: 1,360, Level: 20 Points: 1,360, Level: 20
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2011
Location: Dubai, UAE
Posts: 3
My Jeep was very rough at idle and would stall. Had it at the dealer 3 times. No help. Did a quick search here on the forum. TPS sensor was a common problem. Cheap fix and easy to install yourself. No problems since.

Jeep 4.7L '07 XH.
klavoll is offline  
post #24 of 31 (permalink) Old 01-22-2013, 11:15 PM
Senior Member
Points: 6,355, Level: 52 Points: 6,355, Level: 52 Points: 6,355, Level: 52
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
Hemi-Overland's Avatar
 
Join Date: Aug 2007
Location: GA
Posts: 258
'07 hemi

Stalling started this past summer '12. Only occurs at idle...stopped or slow speeds while slowing. Dash does not light up, power is not interrupted. She just quits. If I just try to start it...it'll catch for a second then die. I have to turn the key all the way off then it'll start just fine. On my 3rd set of plugs...latest set has been in for over a year....stalling started fairly recently.

2007 Overland, HEMI 4x4, QD II, rear DVD, Light Greystone Pearl, Wrangler SilentArmor 245/65R17

2011 Grand Cherokee Overland Summit, HEMI 4x2
Hemi-Overland is offline  
post #25 of 31 (permalink) Old 01-24-2013, 12:17 AM
Senior Member
Points: 3,326, Level: 35 Points: 3,326, Level: 35 Points: 3,326, Level: 35
Level up: 84% Level up: 84% Level up: 84%
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jan 2013
Location: New Jersey
Posts: 201
Crank position sensor? or cam position sensor. If it stalls all the time when stopping , Try putting the tranny in neutral as you come to a stop. If it still dies, that rules out any tranny sensors that could cause the engine to die. It could also be a main harness that when you stop, it moves forward disrupting the signal to the engine.

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on factory exhaust pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear. Black on Brown.
06hemixk is offline  
post #26 of 31 (permalink) Old 01-24-2013, 11:50 AM
Senior Member
Points: 6,458, Level: 52 Points: 6,458, Level: 52 Points: 6,458, Level: 52
Level up: 54% Level up: 54% Level up: 54%
Activity: 3% Activity: 3% Activity: 3%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Posts: 498
Good advice on the crank and cam positioning sensors. For the cost of them and ease of acess, I'm gonna change mine out once this winter freeze is over, although i'm not having any issues, just a little pm


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
post #27 of 31 (permalink) Old 01-24-2013, 03:52 PM
Senior Member
Points: 3,326, Level: 35 Points: 3,326, Level: 35 Points: 3,326, Level: 35
Level up: 84% Level up: 84% Level up: 84%
Activity: 33% Activity: 33% Activity: 33%
 
Join Date: Jan 2013
Location: New Jersey
Posts: 201
Exactly, on my old zj 4.0 i was lucky it threw a light, 25 dollar part and some arm scratches it was all set. Overland any update? Pm is the way to go, saves headaches but sometimes things go bad you would expect to last the life of the vehicle.

06 Commander Limited HEMI. k&n drop in with air raid M.I.T . Aeroturbine 3030xl on factory exhaust pipe . Superchips tuned 93. Bilstein 5100 front @1.5 and 5100 on rear. Black on Brown.
06hemixk is offline  
post #28 of 31 (permalink) Old 11-12-2013, 11:27 PM
Senior Member
Points: 5,139, Level: 45 Points: 5,139, Level: 45 Points: 5,139, Level: 45
Level up: 95% Level up: 95% Level up: 95%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2009
Posts: 103
Quote:
Originally Posted by karmatt View Post

OK! So the plugs that they sell at parts stores and at mopar have the same part number. However they ARE different. The mopar plugs have a coated contact and the element is about 1/8" longer. Who wouldve thought right? Swapped the plugs and ran for about 30 minutes. So far so good.
There is a STAR case out about it and any dealership has access to it. apparently something about the plug differences (or coils being bad) causes voltage feedback to the PCM which confuses it and results in a "loss of conscience" situation in the pcm in turn tripping the ASD relay.
Dont run out and spend $80 on plugs just yet though, I will drive it for a day or two and let you know if the problem is solved....



Did you replace the coil packs or just the plugs? If just the plugs, has the stalling problem went away?
Askbob is offline  
post #29 of 31 (permalink) Old 11-13-2013, 06:54 PM
Senior Member
Points: 5,139, Level: 45 Points: 5,139, Level: 45 Points: 5,139, Level: 45
Level up: 95% Level up: 95% Level up: 95%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2009
Posts: 103
Quote:
Originally Posted by karmatt View Post
OK! So the plugs that they sell at parts stores and at mopar have the same part number. However they ARE different. The mopar plugs have a coated contact and the element is about 1/8" longer. Who wouldve thought right? Swapped the plugs and ran for about 30 minutes. So far so good.


Out of curiousity since I recently changed my plugs with Champions from OReillys, so today I went and purchased another one as well as one from the Jeep dealer. Exactly the same... well except for the price! $1.99 vs $5.09...





Askbob is offline  
post #30 of 31 (permalink) Old 11-14-2013, 12:41 PM
Member
Points: 2,737, Level: 31 Points: 2,737, Level: 31 Points: 2,737, Level: 31
Level up: 92% Level up: 92% Level up: 92%
Activity: 0% Activity: 0% Activity: 0%
 
joshmantesso13's Avatar
 
Join Date: Jul 2013
Location: Niagara Falls, Ontario, Canada
Posts: 63
I have found that if i put it in neutral when stopped or coming to a stop it wont stall. weird hmmm?
joshmantesso13 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome