'06 Commander Transmission Problem Need Help - Jeep Commander Forums: Jeep Commander Forum
Jeep Commander Jeep Commander Header Right
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
Wheel & Tire Center

» Sponsor Links
Go Back   Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service

Problems / Dealer Service Having a problem with your vehicle? Were you treated fairly or poorly at a dealer? Warranty issues? Let us know.

JeepCommander.com is the premier Jeep Commander Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 12-15-2012, 06:30 PM
outdoorpodcast outdoorpodcast is offline
Junior Member
Points: 2,126, Level: 27 Points: 2,126, Level: 27 Points: 2,126, Level: 27
Level up: 84% Level up: 84% Level up: 84%
Activity: 11% Activity: 11% Activity: 11%
 
Join Date: Mar 2012
Posts: 16
'06 Commander Transmission Problem Need Help

So on Sunday, we drove our commander and it worked great. It sat in the driveway for a few days and the other day my wife got in it and now it's having an issue. We have a 2006 Commander Limited 5.7 Hemi Duratrac with 125K and no engine lights are showing

Problem:
It starts up with no problems. The gear shifter will move freely and the dashboard reflects the gear changes on the panel. However, it does not seem to engaging the gears and will not move forward, reverse or go into neutral. Usually you can feel it go into gear but there is no sensation of it going into gear as you move the shifter around.

So our commander is sitting still and unable to move it.

I've heard it maybe a tranny solenoid or the PCM.

Can anyone help diagnosis this problem a little better.

Last edited by outdoorpodcast; 12-15-2012 at 06:38 PM.
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-16-2012, 05:19 PM
jthurstonjr jthurstonjr is offline
Senior Member
Points: 2,791, Level: 32 Points: 2,791, Level: 32 Points: 2,791, Level: 32
Level up: 28% Level up: 28% Level up: 28%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Location: ontario, canada
Posts: 104
mine was getting slow to engage then i changed BOTH tranny filters and the problem went away. BTW get them from the dealership don't buy aftermarket ones.
__________________

06 Limited 5.7 HEMI QD2
4xGuard Belly Guard
k&n intake
Magnaflow catback
Kicker Speaker Upgrade
2" RC lift
Bilstein front shocks
F150 rear load levelers
Rola roof rack
255/75/17 BF Goodrich M/T KM
Spidertrax 1.25 spacers
Reply With Quote
  #3  
Old 12-22-2012, 05:40 PM
outdoorpodcast outdoorpodcast is offline
Junior Member
Points: 2,126, Level: 27 Points: 2,126, Level: 27 Points: 2,126, Level: 27
Level up: 84% Level up: 84% Level up: 84%
Activity: 11% Activity: 11% Activity: 11%
 
Join Date: Mar 2012
Posts: 16
Posting Follow-up

My mechanic brother finally came today and got the Commander back on the road, so I thought I'd post a follow-up in case anyone else has a similar problem.

He replaced the TCM and it solved the issue. It engages the gears perfectly now and drives just fine.
Reply With Quote
  #4  
Old 12-22-2012, 08:33 PM
07JeepXK's Avatar
07JeepXK 07JeepXK is offline
Senior Member
Points: 25,611, Level: 96 Points: 25,611, Level: 96 Points: 25,611, Level: 96
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2007
Location: East Aurora, NY
Posts: 6,316
How much did the TCM cost??
__________________
2007 4.7 Liter XK | Front OME HD Lift | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock Series 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 50 Series SUV Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front Electronic Locker | Rear Heat/AC Delete
Reply With Quote
  #5  
Old 12-23-2012, 08:07 AM
outdoorpodcast outdoorpodcast is offline
Junior Member
Points: 2,126, Level: 27 Points: 2,126, Level: 27 Points: 2,126, Level: 27
Level up: 84% Level up: 84% Level up: 84%
Activity: 11% Activity: 11% Activity: 11%
 
Join Date: Mar 2012
Posts: 16
IT was $327 from the local dealership but they gave me a business discount o it was $250 for the part.
Reply With Quote
  #6  
Old 12-23-2012, 08:09 AM
07JeepXK's Avatar
07JeepXK 07JeepXK is offline
Senior Member
Points: 25,611, Level: 96 Points: 25,611, Level: 96 Points: 25,611, Level: 96
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2007
Location: East Aurora, NY
Posts: 6,316
That's not bad. Well if my jeep ever does this I now know how to fix it
__________________
2007 4.7 Liter XK | Front OME HD Lift | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock Series 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 50 Series SUV Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front Electronic Locker | Rear Heat/AC Delete
Reply With Quote
  #7  
Old 01-07-2013, 09:14 AM
XKTX's Avatar
XKTX XKTX is offline
Senior Member
Points: 5,906, Level: 49 Points: 5,906, Level: 49 Points: 5,906, Level: 49
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2007
Location: San Antonio, Texas
Posts: 269
Quote:
Originally Posted by outdoorpodcast View Post
My mechanic brother finally came today and got the Commander back on the road, so I thought I'd post a follow-up in case anyone else has a similar problem.

He replaced the TCM and it solved the issue. It engages the gears perfectly now and drives just fine.
I am having the same problem this morning, do you know where is the TCM Located? I appreciate your help. Thanks!
__________________
06' Black Limited QDII HEMI - 2" Revtek Lift 245/75/17 Goodyear Duratrac -Monroe Sensa Trac Struts and Sensa Trac Load Adjusting Shocks.
Reply With Quote
  #8  
Old 01-07-2013, 10:21 PM
USMCMP's Avatar
USMCMP USMCMP is offline
Senior Member
Points: 7,761, Level: 59 Points: 7,761, Level: 59 Points: 7,761, Level: 59
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2008
Location: Wisconsin
Posts: 697
When my TCM was replaced at the dealership it cost double that. The Jeep would go into gear but only third gear and reverse. Instead of going to "D" the dash would say "3" like when using the autostick. Wouldnt shift up or down just 3 the whole way
__________________
'06 HEMI LIMITED LOADED QDII DE-BADGED, TINT, SILVERSTAR ULTRAS, LED TAILS, R/C LIFT, BILSTEINS, KMC XD HOSS WHEELS, DURATRACS, MAGNAFLOW, K&N CAI and OIL FILTER, ROYAL PURPLE, HAWK HPS PADS, RED CALIPERS, LEDs BEHIND GRILLE
Reply With Quote
  #9  
Old 01-18-2013, 10:33 PM
XKTX's Avatar
XKTX XKTX is offline
Senior Member
Points: 5,906, Level: 49 Points: 5,906, Level: 49 Points: 5,906, Level: 49
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2007
Location: San Antonio, Texas
Posts: 269
Today I got my Jeep back from the dealership and the transmission was rebuilt. The lifetime powertrain warranty covered it my deductible was $100.00 dollars which covered the towing, 5 day car rental and parts and labor.
__________________
06' Black Limited QDII HEMI - 2" Revtek Lift 245/75/17 Goodyear Duratrac -Monroe Sensa Trac Struts and Sensa Trac Load Adjusting Shocks.
Reply With Quote
  #10  
Old 01-30-2013, 11:55 AM
rjhj's Avatar
rjhj rjhj is offline
Senior Member
Points: 3,613, Level: 37 Points: 3,613, Level: 37 Points: 3,613, Level: 37
Level up: 76% Level up: 76% Level up: 76%
Activity: 2% Activity: 2% Activity: 2%
 
Join Date: Oct 2011
Location: Toronto, Ontario.
Posts: 454
What could cause my jeep to clunk into 1st gear from 2nd upon deceleration and only while I apply the break. Just had the transmission solenoid pack replaced then transmission rebuilt and serviced and got it back last night.

Just hoping for a little insight before I call the shop back and hear what they have to say.

Thanks in advance anyone who can contribute some wisdom.


Sent from AutoGuide.com App
Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Problems / Dealer Service


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:43 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.