really bad fuel economy - Page 4 - Jeep Commander Forums: Jeep Commander Forum
Jeep Commander Jeep Commander Header Right
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
Wheel & Tire Center

» Sponsor Links
Go Back   Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

JeepCommander.com is the premier Jeep Commander Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #31  
Old 01-11-2013, 07:44 PM
06hemixk 06hemixk is offline
Senior Member
Points: 1,519, Level: 22 Points: 1,519, Level: 22 Points: 1,519, Level: 22
Level up: 19% Level up: 19% Level up: 19%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Location: Bx, NY
Posts: 149
Not a Problem Martin haha just glad you got it all fixed. Did corporate ever help you? So was it just not burning the fuel in those cylinder?
__________________
06 Commander Limited HEMI. k&n drop in. Aeroturbine 3030xl on factory exhaust pipe . air raid M.I.T
More to come.
Reply With Quote
Sponsored Links
Advertisement
 
  #32  
Old 01-11-2013, 08:45 PM
JBenn911 JBenn911 is offline
Member
Points: 2,073, Level: 27 Points: 2,073, Level: 27 Points: 2,073, Level: 27
Level up: 49% Level up: 49% Level up: 49%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2010
Location: Brigantine, NJ
Posts: 98
Send a message via Yahoo to JBenn911
Good news !!!
__________________
2007 Hemi Limited Silver
2011 Ford Raptor
2008 Chevy 2500 Suburban (Work truck)
Reply With Quote
  #33  
Old 01-13-2013, 11:26 AM
martin.steve martin.steve is offline
Junior Member
Points: 136, Level: 2 Points: 136, Level: 2 Points: 136, Level: 2
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Posts: 15
not burning fuel in the last two cylenders at all just pooling and dumping. corporate called and they basically said they could offer me emplyee pricing if i wanted to buy a new jeep dodge etc... lol i just bought the xk
Reply With Quote
  #34  
Old 01-14-2013, 09:55 AM
JeepVen JeepVen is offline
Junior Member
Points: 3,836, Level: 39 Points: 3,836, Level: 39 Points: 3,836, Level: 39
Level up: 24% Level up: 24% Level up: 24%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2009
Location: Caracas, Venezuela
Posts: 10
Hi Steve, how did you get to this diagnosis? what kind of tests did you perform to realize that? I'm having same issue with my 2007 hemi. Also noticed you said you just changed the oil, are you sure it had 5w20 oil? I read if oil is not 5w20 MDS won't activate. Thanks for you sharings.

Last edited by JeepVen; 02-02-2013 at 06:28 AM.
Reply With Quote
  #35  
Old 02-01-2013, 11:12 AM
06hemixk 06hemixk is offline
Senior Member
Points: 1,519, Level: 22 Points: 1,519, Level: 22 Points: 1,519, Level: 22
Level up: 19% Level up: 19% Level up: 19%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Location: Bx, NY
Posts: 149
I feel like even with out MDS i still get atleast 14mpg highway.. i get 18.2 with it on.. Employee pricing aint bad, what did the repairs cost you from the stealership ?
__________________
06 Commander Limited HEMI. k&n drop in. Aeroturbine 3030xl on factory exhaust pipe . air raid M.I.T
More to come.
Reply With Quote
  #36  
Old 02-04-2013, 10:29 PM
martin.steve martin.steve is offline
Junior Member
Points: 136, Level: 2 Points: 136, Level: 2 Points: 136, Level: 2
Level up: 72% Level up: 72% Level up: 72%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Posts: 15
i dont know what the cost of the repair was because the dealership paid for the repairs since i just bought it. Unforunatley it didnt compleatly solve my fuel issues. now that ive driven it a couple weeks after getting the work dont its riding around 22ltrs/100km's im just gonna start switching out the usual culprits, ir maf, pcv valve, o2 sensors. from what ive read these sensors can be off quite a bit without tripping a code and ive done everything else we can think of so... heres hoping it gets better
Reply With Quote
  #37  
Old 02-25-2013, 01:51 PM
06hemixk 06hemixk is offline
Senior Member
Points: 1,519, Level: 22 Points: 1,519, Level: 22 Points: 1,519, Level: 22
Level up: 19% Level up: 19% Level up: 19%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2013
Location: Bx, NY
Posts: 149
Any luck thus far Martin? This seems like a silly question, but do you know if its going to closed loop?
__________________
06 Commander Limited HEMI. k&n drop in. Aeroturbine 3030xl on factory exhaust pipe . air raid M.I.T
More to come.
Reply With Quote
  #38  
Old 04-09-2013, 06:21 AM
Centcomm87 Centcomm87 is offline
Member
Points: 471, Level: 9 Points: 471, Level: 9 Points: 471, Level: 9
Level up: 43% Level up: 43% Level up: 43%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2012
Posts: 36
I've got bad news about cleaning your maf sensor.....none of us have one. Try sparkplugs, injector cleaner, maybe seafoam.

Sent from AutoGuide.com App
Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:26 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.