Stalling Issues with 06 5.7 Hemi Commander - Page 3 - Jeep Commander Forums: Jeep Commander Forum
Jeep Commander Jeep Commander Header Right
HomeForumGalleryClassifiedsAbout UsAdvertiseContact Us

» Auto Insurance
» Featured Product
Wheel & Tire Center

» Sponsor Links
Go Back   Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion

General Commander Discussion General Discussion involving the Jeep Commander goes here. If it does not fit into a more specific category below, post it here.

JeepCommander.com is the premier Jeep Commander Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #21  
Old 03-10-2011, 03:10 PM
JBenn911 JBenn911 is offline
Member
Points: 2,073, Level: 27 Points: 2,073, Level: 27 Points: 2,073, Level: 27
Level up: 49% Level up: 49% Level up: 49%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2010
Location: Brigantine, NJ
Posts: 98
Send a message via Yahoo to JBenn911
Don't know if it would apply with the Jeeps, but... In my racing days, a common cause of stalling(when coming to a stop) in the Grand National's was the torque converter locking and failing to unlock. In the GN's it was discovered by doing a test drive with a Modis or some other good scanner connected. It would show the status of the TC solenoid and whether it was locked or unlocked. Perhaps the dealer can hook up the Star Scan or whatever they use and do a diagnostic run.. Hope it helps..

J
__________________
2007 Hemi Limited Silver
2011 Ford Raptor
2008 Chevy 2500 Suburban (Work truck)
Reply With Quote
Sponsored Links
Advertisement
 
  #22  
Old 11-10-2011, 11:15 AM
Ronzo Ronzo is offline
Junior Member
Points: 3,614, Level: 37 Points: 3,614, Level: 37 Points: 3,614, Level: 37
Level up: 76% Level up: 76% Level up: 76%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2007
Posts: 26
Lucky me ... my 2007 4.7 with 49k miles stalled on the highway. After doing some research online learned of a recall, which my car doesn't fall under. Chrysler advises me to bring the car into the dealer for a diagnostic test $105 to see whats wrong.

Receive a phone call from my local dealer, good news. Nothing is wrong with your car. My response is thats actually bad news as there is something wrong with the car as it shouldn't be stalling on the highway. Dealers suggests changing plugs and belts - almost laughable.

Chrysler financial opened a case ,,, oh boy. Anyone want to buy a Commander LOL.
Reply With Quote
  #23  
Old 02-24-2013, 04:26 PM
critch1285 critch1285 is offline
Junior Member
Points: 2, Level: 1 Points: 2, Level: 1 Points: 2, Level: 1
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2013
Location: Michigan
Posts: 1
2007 Hemi Engine Stalls

Engine began stalling about 4 months ago after installing platinum plugs. Found that was a no no. Put OEM plugs in. Stalling continues sporadically. Will be driving at 70 and engine just quits. Turn off ignition, something appears to reset and the engine starts and runs fine. Sometimes will stall for a few seconds and re-catch. Sometimes, quits at stop light/sign and I have to turn key off and will restart. Occasionally the accelerated will just increase RPM from idle to 1500 while stopped. CEL never comes on in any situation. I am seeing there doesn't appear to be a solution after all the posts I am reading.
Reply With Quote
  #24  
Old 02-25-2013, 10:03 AM
M3racer's Avatar
M3racer M3racer is offline
Member
Points: 5,350, Level: 46 Points: 5,350, Level: 46 Points: 5,350, Level: 46
Level up: 50% Level up: 50% Level up: 50%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2008
Location: Delaware
Posts: 52
I have the same issue. I can't believe there are that many of us that have the same problem yet the dealers never heard of it. It's an extremely dangerous situation and a recall should be issued.
__________________
2013 Fiat Abarth
2007 Jeep Commander Overland
1991 BMW M3
Reply With Quote
  #25  
Old 09-24-2013, 10:41 AM
Player101 Player101 is offline
Junior Member
Points: 2, Level: 1 Points: 2, Level: 1 Points: 2, Level: 1
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2013
Posts: 1
Quote:
Originally Posted by critch1285 View Post
Engine began stalling about 4 months ago after installing platinum plugs. Found that was a no no. Put OEM plugs in. Stalling continues sporadically. Will be driving at 70 and engine just quits. Turn off ignition, something appears to reset and the engine starts and runs fine. Sometimes will stall for a few seconds and re-catch. Sometimes, quits at stop light/sign and I have to turn key off and will restart. Occasionally the accelerated will just increase RPM from idle to 1500 while stopped. CEL never comes on in any situation. I am seeing there doesn't appear to be a solution after all the posts I am reading.
I have the exact same problem.

2007 Commander with Hemi
Babied, always maintained correctly. Everything has been by the book. I have done all the oil changes, it has never seen anything but 5w-20 full synthetic.

-Started stalling randomly at stop lights. Maybe once a week.
-Changed plugs, which were OEM, to new OEM plugs. Stalling seemed to get better
-6 months later stalling is back. It stalled on the Interstate on my wife and she nearly crashed.
-Has stalled out at stop lights like 20 times overall. Am friends with Jeep dealer mechanic. He wants me to change plugs (again) because apparently there are two different OEM plugs of the same part number. One has a black top, the other has a silver top. I am not sure which ones I have but will update when I pull one this weeked. I believe (there is a technical service bulletin) that the black tops are the correct OEM plugs.......

If anyone gets a definitive solution to this I would be greatly appreciative. I am out of warranty and cannot afford to get swindled at the dealership.
Reply With Quote
  #26  
Old 11-04-2013, 12:04 AM
RescueAngel's Avatar
RescueAngel RescueAngel is offline
Junior Member
Points: 858, Level: 15 Points: 858, Level: 15 Points: 858, Level: 15
Level up: 58% Level up: 58% Level up: 58%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2012
Posts: 3
Jeep installing

I seen that many are having or have had issues with stalling out. Has anyone found a true fix?
Dealer mechanics are telling me that they need to drive it all day to give me an answer.....not interested in replacing a lot of "maybe" parts.

2007 HEMI 5.7
Stalls when coming to a stop and at 65mph.

Any thoughts?
I've seen the recalls for 06.
Reply With Quote
  #27  
Old 11-05-2013, 01:14 PM
Eric S Eric S is offline
Senior Member
Points: 2,230, Level: 28 Points: 2,230, Level: 28 Points: 2,230, Level: 28
Level up: 54% Level up: 54% Level up: 54%
Activity: 7% Activity: 7% Activity: 7%
 
Join Date: Jun 2012
Location: Vancouver Island, BC, Canada
Posts: 114
FYI Mine stalls randomly too. Most often when cold and when stopped in drive or coming to a stop. Changed the ignition switch to fix another issue, I think is stalls less now but not yet fixed. Suspect it's the transmission/computer for it. I have two new filters and am going to change the fluid see if it makes a difference.
__________________
06 Hemi
Reply With Quote
  #28  
Old 11-06-2013, 06:51 PM
Comm Comm is offline
Junior Member
Points: 896, Level: 15 Points: 896, Level: 15 Points: 896, Level: 15
Level up: 96% Level up: 96% Level up: 96%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2013
Posts: 26
Check your lower ckp ( crank position sensor ) hard starting,stalling randomly can be cause from improper circuit at monitoring ignition point cylinder 1 . Should be easy to locate remove and replace your stalling issues should be fixed. Has to do something with sending fuel timing ect. Based on the location of the part it's really subject to rain salt snow mid whatever terrain your driving.Do little bit of research on that. Should be a minor fox seeing these modules last about 50k roughly. A sotimes It may or may not give a code or light. Often without warning. Have you yet used any diagnostic ?

Last edited by Comm; 11-06-2013 at 07:05 PM.
Reply With Quote
  #29  
Old 11-06-2013, 10:15 PM
joshmantesso13's Avatar
joshmantesso13 joshmantesso13 is online now
Member
Points: 1,863, Level: 25 Points: 1,863, Level: 25 Points: 1,863, Level: 25
Level up: 63% Level up: 63% Level up: 63%
Activity: 11% Activity: 11% Activity: 11%
 
Join Date: Jul 2013
Location: Niagara Falls, Ontario, Canada
Posts: 60
I have this problem to. 07 hemi, when coming to a stop, i will be waiting at a red light then the engine stalls, also will stall when driving at low speeds like in a parking lot and also sometimes when I'm reversing. as you can tell I'm a daily staller. at least once a day if not more. It throws a p0884 code. can't seem to find much info on it? any help is appreciated.
Reply With Quote
  #30  
Old 11-12-2013, 11:11 PM
Askbob Askbob is offline
Member
Points: 4,159, Level: 41 Points: 4,159, Level: 41 Points: 4,159, Level: 41
Level up: 5% Level up: 5% Level up: 5%
Activity: 3% Activity: 3% Activity: 3%
 
Join Date: Dec 2009
Posts: 98
Quote:
Originally Posted by joshmantesso13 View Post
I have this problem to. 07 hemi, when coming to a stop, i will be waiting at a red light then the engine stalls, also will stall when driving at low speeds like in a parking lot and also sometimes when I'm reversing. as you can tell I'm a daily staller. at least once a day if not more. It throws a p0884 code. can't seem to find much info on it? any help is appreciated.

Same here a week or so after I changed plugs(copper Champions). Trying to deduce this problem before I have to take it to a dang dealer...
Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > General Commander Discussion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 01:14 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.