'08 cruise control not working... - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 12-14-2009, 12:49 PM Thread Starter
Senior Member
Points: 7,723, Level: 58 Points: 7,723, Level: 58 Points: 7,723, Level: 58
Level up: 87% Level up: 87% Level up: 87%
Activity: 0% Activity: 0% Activity: 0%
 
Askbob's Avatar
 
Join Date: Dec 2009
Location: Shelbyville, KY
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 207800
Posts: 103
Garage
'08 cruise control not working...

Hello all! I have an '08 commander 4.7 that the cruise control stopped working. The 'cruise' green light will still come on in the instrument cluster whenever you push the cruise on/off button on the steering wheel stalk. When you try to set it, nothing happens. Anything to look for before I get ramrodded by a dealer!!??
Askbob is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-14-2009, 01:51 PM
Moderator
Points: 41,300, Level: 100 Points: 41,300, Level: 100 Points: 41,300, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 4% Activity: 4% Activity: 4%
 
HueyPilotVN's Avatar
 
Join Date: Mar 2007
Location: Lake Havasu City, Arizona
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
4WD
If 4WD - system: QD-II
Current Mileage: HueyPilotVN
Posts: 2,248
If it is under warranty take it in. I have found that cruise control problems are often associated with a vacuum leak. Most cruise controls use the manifold vacuum as a signal to control the accelerator. A loose vacuum hose or a leak may be the first place to start.

2007 Jeep Green Limited 4.7 Flex Fuel, RR 2.5" 4 inch Superlift coils on rear, 1.5" Spacers, Bridgestone 265/70/17, K&N CAI, Flowmaster, Diamond Plate Locking Trunk, Blue Ox Baseplate w/D-rings, "Get Lost 4X4" Front Bumper, T-Max 9000 winch, "Get Lost rear tire carrier, 30 gal second gas tank.
Second 2007 Jeep Green Limited Leather HEMI QDII VES Uconnect Flowmaster OEM Skids Tow Package

Maybe the two will meet up soon edit: they did , I now have 2,now gave 1 away...and got it back again.

Last edited by HueyPilotVN; 12-14-2009 at 01:53 PM.
HueyPilotVN is offline  
post #3 of 5 (permalink) Old 12-14-2009, 07:54 PM
Senior Member
Points: 11,816, Level: 71 Points: 11,816, Level: 71 Points: 11,816, Level: 71
Level up: 42% Level up: 42% Level up: 42%
Activity: 0% Activity: 0% Activity: 0%
 
robby's Avatar
 
Join Date: Jun 2008
Location: Desplaines IL.
Posts: 3,262
Verify the brake lights aren't staying on.
That circuit cancels the cruise.
After that, Dealer.
This cruise is fully electronic....maintains speed by operating the ETC.

Rob

Good point on the vacuum leak though....all the pre electronic systems would be inoperative if there was a vacuum disruption.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
robby is offline  
 
post #4 of 5 (permalink) Old 12-15-2009, 07:30 AM Thread Starter
Senior Member
Points: 7,723, Level: 58 Points: 7,723, Level: 58 Points: 7,723, Level: 58
Level up: 87% Level up: 87% Level up: 87%
Activity: 0% Activity: 0% Activity: 0%
 
Askbob's Avatar
 
Join Date: Dec 2009
Location: Shelbyville, KY
Own a Commander?: Yes
Model year: 2007
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 207800
Posts: 103
Garage
Thanks for the replies! No brake light problem. Definitely not a fuse problem. Out of warranty except for drivetrain. I guess the dealer will get in my wallet a little...
Askbob is offline  
post #5 of 5 (permalink) Old 02-21-2016, 07:56 AM
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
Quote:
Originally Posted by Askbob View Post
Hello all! I have an '08 commander 4.7 that the cruise control stopped working. The 'cruise' green light will still come on in the instrument cluster whenever you push the cruise on/off button on the steering wheel stalk. When you try to set it, nothing happens. Anything to look for before I get ramrodded by a dealer!!??
Did you ever get this fixed? What was the solution?

08, Commander, Overland, 5.7L HEMI, QD-II, Stock.
vjsimone is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome