I think my Amp is gone.... - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 04-17-2010, 12:00 PM Thread Starter
Junior Member
Points: 97, Level: 1 Points: 97, Level: 1 Points: 97, Level: 1
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2010
Posts: 3
I think my Amp is gone....

I am new to the forum so thanks for the help. I have been experiencing loss of all audio intermittantly over the last few months. Usually, i can disconnect the battery and everything resets. Well, now its been 3 days and multiple tries and I think my Amp may finally be toast. Fuses are all intact. THis used to only happen after it rained but now its just happening whenever. All advice will be appreciated.
-Josh
2006 Commander LTD 4x4 6 disc BA system. Rear DVD system.
girthquake is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-17-2010, 03:36 PM
Junior Member
Points: 1,137, Level: 18 Points: 1,137, Level: 18 Points: 1,137, Level: 18
Level up: 37% Level up: 37% Level up: 37%
Activity: 0% Activity: 0% Activity: 0%
 
JpXJJKWK's Avatar
 
Join Date: Mar 2009
Location: Northern Virginia
Posts: 10
Had a Grand Cherokee come into the shop one time and it was due to a water leak in the rear window that was dripping onto the amp inside the rear side panel, take a look at it, if there is rust you know your problem. Most likely the water over time is just doing more and more damage

Commander Sport 4.7L V8 Jeep Green
Current Mods...
-Installed factory fog lamps
-CB radio
-Rough Country 2" lift
-BFG Mud 255/75 r17
-Permanent CB antenna
-Mopar grill guard w/ lights
-Premium sound
-K&N intake
In the future
-Roof lights
-Metal skid plates
JpXJJKWK is offline  
post #3 of 8 (permalink) Old 04-18-2010, 12:14 AM
Senior Member
Points: 6,690, Level: 53 Points: 6,690, Level: 53 Points: 6,690, Level: 53
Level up: 70% Level up: 70% Level up: 70%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2009
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 3.7L V-6
2WD
If 4WD - system: QT-I
Current Mileage: 158,000
Posts: 129
Quote:
Originally Posted by JpXJJKWK View Post
Had a Grand Cherokee come into the shop one time and it was due to a water leak in the rear window that was dripping onto the amp inside the rear side panel, take a look at it, if there is rust you know your problem. Most likely the water over time is just doing more and more damage
This same situation happened in my commander as well. However i was still under warranty. If it has been intermittent i don't think it would be a water issue.
CKB3 is offline  
 
post #4 of 8 (permalink) Old 04-21-2010, 06:48 PM Thread Starter
Junior Member
Points: 97, Level: 1 Points: 97, Level: 1 Points: 97, Level: 1
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2010
Posts: 3
Yeah, I am well out of warranty. I guess the next step is a new amp. Should I consider a factory replacement or an aftermarket one? I assume an aftermarket one will require splicing wires...?
girthquake is offline  
post #5 of 8 (permalink) Old 05-24-2010, 10:21 PM
Junior Member
Points: 304, Level: 6 Points: 304, Level: 6 Points: 304, Level: 6
Level up: 8% Level up: 8% Level up: 8%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 6
Quote:
Originally Posted by girthquake View Post
Yeah, I am well out of warranty. I guess the next step is a new amp. Should I consider a factory replacement or an aftermarket one? I assume an aftermarket one will require splicing wires...?
where would you find the amp in a 2007 Commander? I have the same issue. Have power to my NAV unit but no sound at all.

Thanks.
choconstruction is offline  
post #6 of 8 (permalink) Old 05-24-2010, 11:03 PM
Senior Member
Points: 14,892, Level: 79 Points: 14,892, Level: 79 Points: 14,892, Level: 79
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
GPintheMitten's Avatar
 
Join Date: Nov 2008
Location: Flushing, Michigan
Posts: 2,406
Quote:
Originally Posted by choconstruction View Post
where would you find the amp in a 2007 Commander? I have the same issue. Have power to my NAV unit but no sound at all.

Thanks.
Jeep5253 answered that question for you on your other thread.

2007 XK Limited, 5.7L Hemi, QDII, Rusty's 2" lift, Spidertrax 1.5 inch wheel spacers, GetLost4x4's front hitch mount for portable winch.GY Duratracs 265/70R17s , Rola Roof Rack, diy built spare tire mount for the roof rack.
GPintheMitten is offline  
post #7 of 8 (permalink) Old 05-25-2010, 08:44 AM
Junior Member
Points: 304, Level: 6 Points: 304, Level: 6 Points: 304, Level: 6
Level up: 8% Level up: 8% Level up: 8%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 6
Quote:
Originally Posted by GPintheMitten View Post
Jeep5253 answered that question for you on your other thread.
Yup. Under rear panel cup holders. Thanks
choconstruction is offline  
post #8 of 8 (permalink) Old 05-29-2010, 09:32 AM Thread Starter
Junior Member
Points: 97, Level: 1 Points: 97, Level: 1 Points: 97, Level: 1
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2010
Posts: 3
FYI update on my original post..... Found someone selling a facory BA amp on ebay for 18 bucks!.. I bought it and plugged it in and bingo, it worked so my original amp was in fact toast. The amp practically looks like its sealed so I cant see how it went bad. Either way, its fixed.
girthquake is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome