IPod Hook Up for 2009/2010 Limiteds... - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-17-2010, 03:00 PM Thread Starter
Banned
Points: 356, Level: 7 Points: 356, Level: 7 Points: 356, Level: 7
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 139
IPod Hook Up for 2009/2010 Limiteds...

So I have a 2010 Limited which came with the iPod hook up in the glove compartment. Probably the same for 2009 Limiteds. I assume this is the same connection offered by Mopar as an aftermarket accessory.

Is it just me or is it extremely difficult to connect the cable (supplied by Jeep) to the “hook up” that is attached to the back of the glove box? The way it is installed from the factory makes for an extremely close fit.

There is an “insert” in the “hook up” that I was able to remove. Looks like a cap or plug of some sort. I just can’t physically plug the cable in.

I honestly cannot do it. Feels like I will break it if I force it.

Anyone else have these issues?

Any tips or suggestions?

Somebody help me! Meatball, Sausage, Braciole! Anybody!


Last edited by Swadehead; 11-17-2010 at 03:07 PM.
Swadehead is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-28-2010, 09:47 AM
Junior Member
Points: 131, Level: 2 Points: 131, Level: 2 Points: 131, Level: 2
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2010
Posts: 1
I am looking for the same thing as well if anyone can help. I have a 2010 as well that came with a plug in the glove box and a maybe 8 inch pigtail that fits my Ipod but cannot get that pigtail into that plug. It looks like it should just wont go. Am I missing a piece or what??? Thanks.
USNBIP is offline  
post #3 of 3 (permalink) Old 11-29-2010, 10:09 AM
Junior Member
Points: 259, Level: 5 Points: 259, Level: 5 Points: 259, Level: 5
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 9
I have the same connection in my 2010. It had a cap on the end of the ipod connection cord which I removed and then plugged into the other cord already in the glove box. I had no problem installing it other than my large hands getting in the way.
soup is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome