Kenwood KVT-617DVD any experience with this? - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 01-05-2007, 03:26 PM Thread Starter
Points: 3,952, Level: 40 Points: 3,952, Level: 40 Points: 3,952, Level: 40
Level up: 1% Level up: 1% Level up: 1%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2006
Posts: 541
Question Kenwood KVT-617DVD any experience with this?

I was browsing crutchfield.com and ran into this unit with seems to have very good reviews. Honestly any update over factory audio (the ghetto OEM radio) will make me happy.



The only warning I get during a "fake" check out is the following:

The harness does not have an accessory power connection, so you will need to connect your new receiver's accessory power wire to a source of accessory power in your vehicle.

What I understand from this is that I would have to power up the unit from the car directly, no idea in the world how to do that.

I like the fact that you can add Navigation, etc.

Can you give me some advice on this unit, istallation. Is there a work around to make this unit play DVD's while driving? I would like to use my aftermarket rear monitor with this unit as well (has additional a/v inputs).

Comments are welcome...

Last edited by Dabitz; 01-05-2007 at 03:48 PM.
Dabitz is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 01-05-2007, 04:19 PM
Points: 1,495, Level: 21 Points: 1,495, Level: 21 Points: 1,495, Level: 21
Level up: 95% Level up: 95% Level up: 95%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2006
Posts: 20
Re: Kenwood KVT-617DVD any experience with this?

This just means that if you added an accessory such as a navigation unit that it would not be able to run off the head unit's power. The power for the actual head unit is the same as any other. As for playing a dvd while driving, you have to bypass the parking brake requirement. You have a wire that goes from the unit to the brake wire and lets the unit know when the brake is engaged. Instead of tapping this wire into the brake wire, tap into another wire that has a constant signal such as the power wire. That's how I bypassed it. Most installers know how to do it, but they usually won't do it for you.
Bobby is offline  
post #3 of 10 (permalink) Old 01-05-2007, 05:34 PM Thread Starter
Points: 3,952, Level: 40 Points: 3,952, Level: 40 Points: 3,952, Level: 40
Level up: 1% Level up: 1% Level up: 1%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2006
Posts: 541
Re: Kenwood KVT-617DVD any experience with this?

Bare with my lack of knowledge here. So if I were to install myself all I have to do basically is cut the cables from the existing factory connection and match them to the wire harness that comes with the radio (crutfieled) plus the antenna adapter? That doesn't sound so complicated.

If I read you correctly, I don't have to worry about that power warning only until I add an accessory such as navigation?

For this particular unit, I don't need the bezel for the navigation right? The one that came with my commander base model should do it right?

It sounds like if I could identify what the parking cable is, I could cut let the one coming from the car "hanging", and then connect the radio one to the power cable? I hope that won't fry it...

Last edited by Dabitz; 01-05-2007 at 05:48 PM.
Dabitz is offline  
 
post #4 of 10 (permalink) Old 01-08-2007, 08:44 PM Thread Starter
Points: 3,952, Level: 40 Points: 3,952, Level: 40 Points: 3,952, Level: 40
Level up: 1% Level up: 1% Level up: 1%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2006
Posts: 541
Re: Kenwood KVT-617DVD any experience with this?

Does anyone have any advice on this? I am very tempted to go this route... Thanks in advance...
Dabitz is offline  
post #5 of 10 (permalink) Old 01-09-2007, 12:32 PM
Member
Points: 1,804, Level: 25 Points: 1,804, Level: 25 Points: 1,804, Level: 25
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2006
Location: Christiansburg, VA
Posts: 43
Re: Kenwood KVT-617DVD any experience with this?

D, you shouldn't have to cut anything. You have an adapter going into the back of your current headunit. Crutchfield is very good about sending you everything you need. It will have an adapter that will plug into your existing wiring and plug into the back of the new headunit. They will also send you detailed instructions on how to install the unit. I may be wrong, but I'm reading that 'accessory power' differently. I think what it is basically saying is that you will need to run a wire over to your fuse box and tie it in with a fuse that runs on 'accessory' so you can turn the unit on when the key is turned to accessory. Could be way off on this.....but I recall the old school method of hooking up headunits and having to run the wire to the fuse box. Nowadays, most of the adapters prevent that. Good luck!
hokiehi is offline  
post #6 of 10 (permalink) Old 01-09-2007, 01:01 PM Thread Starter
Points: 3,952, Level: 40 Points: 3,952, Level: 40 Points: 3,952, Level: 40
Level up: 1% Level up: 1% Level up: 1%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2006
Posts: 541
Re: Kenwood KVT-617DVD any experience with this?

I did an online chat with Crutchfield... this is their response:

Your vehicle does not have a 12 volt accessory wire for power (the wire the turns on the system when the vehicle starts up). So, you will need to hard wire the connection. You might want to get some 16 gauge wire for this. We do have technical support that will be able to help you find the place to make the connection in the vehicle. This support comes free with your purchase of the equipment. The stock system rigged the connection. It is not a true switched power lead.

I think that blows the chance of me installing the unit by myself. I was looking into the package that comes with the navigation. At least the guy I talked to recommended Kenwood's system over Eclipse. I really didn't want to pay for installation, but I guess I'll have no choice. I also wanted to keep it easy to switch back to stock unit in case I exchange my lease for a newer model in 2 yrs.

I guess I might end up spending my bonus check on those boots my wife wanted.

Last edited by Dabitz; 01-09-2007 at 02:03 PM.
Dabitz is offline  
post #7 of 10 (permalink) Old 01-09-2007, 02:17 PM
Senior Member
Points: 13,860, Level: 76 Points: 13,860, Level: 76 Points: 13,860, Level: 76
Level up: 53% Level up: 53% Level up: 53%
Activity: 0% Activity: 0% Activity: 0%
 
rubicontrail.net's Avatar
 
Join Date: Oct 2005
Location: Chandler, AZ
Posts: 2,473
Re: Kenwood KVT-617DVD any experience with this?

If you need to wire in additional circuits look at a Painless auxillary fuse block. I did this on my Cherokee to power the CB, etc.

2007 Jeep Commander Limited, 1998 Jeep Wrangler Sahara, 1955 Willys Jeep Pickup (Restoration Project), 2011 Subaru Outback 2.5i Limited:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rubicontrail.net is offline  
post #8 of 10 (permalink) Old 01-09-2007, 02:29 PM Thread Starter
Points: 3,952, Level: 40 Points: 3,952, Level: 40 Points: 3,952, Level: 40
Level up: 1% Level up: 1% Level up: 1%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Aug 2006
Posts: 541
Re: Kenwood KVT-617DVD any experience with this?

I just thought I have an aftermarket under driver's seat dvd player and ceiling monitor. I will try to trace where these are being powered from. I have done live sound, dj stuff back in the day, but I don't know crap about car electric systems. So this is a welcome adventure for me.
Dabitz is offline  
post #9 of 10 (permalink) Old 01-09-2007, 02:37 PM
Senior Member
Points: 13,860, Level: 76 Points: 13,860, Level: 76 Points: 13,860, Level: 76
Level up: 53% Level up: 53% Level up: 53%
Activity: 0% Activity: 0% Activity: 0%
 
rubicontrail.net's Avatar
 
Join Date: Oct 2005
Location: Chandler, AZ
Posts: 2,473
Re: Kenwood KVT-617DVD any experience with this?

This is the Painless block I used on my Cherokee. It took a couple of hours to get it all in there and lined up nice. The biggest problem was finding a place to route the lines to the inside of the passenger compartment. I ended up drilling a hole in the firewall but you might not want to do that on a new Commander. :-)

http://www.amazon.com/Painless-Wirin...8&s=automotive

2007 Jeep Commander Limited, 1998 Jeep Wrangler Sahara, 1955 Willys Jeep Pickup (Restoration Project), 2011 Subaru Outback 2.5i Limited:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by rubicontrail.net; 01-09-2007 at 02:41 PM.
rubicontrail.net is offline  
post #10 of 10 (permalink) Old 01-09-2007, 05:54 PM
Member
Points: 1,804, Level: 25 Points: 1,804, Level: 25 Points: 1,804, Level: 25
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2006
Location: Christiansburg, VA
Posts: 43
Re: Kenwood KVT-617DVD any experience with this?

Dabitz, I sent you a pm in regards to this.
hokiehi is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome