Nav screen randomly goes black?? - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 02-16-2011, 05:30 PM Thread Starter
Junior Member
Points: 43, Level: 1 Points: 43, Level: 1 Points: 43, Level: 1
Level up: 86% Level up: 86% Level up: 86%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2011
Location: Chattanooga, TN
Posts: 4
Nav screen randomly goes black??

I have an '06 Commander Limited which I just bought. I've been having trouble with the Nav screen just randomly not coming on when I start the car and randomly going blank when i'm driving down the road. It will also randomly come back on. I'm not sure if there's some secret button to push to get it to come back on, or it needs an update, or it has a short..There's no pattern as to when it goes out..Anyone else ever had this problem?? HELP!
carriebp is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 02-16-2011, 05:59 PM
Banned
Points: 6,103, Level: 50 Points: 6,103, Level: 50 Points: 6,103, Level: 50
Level up: 77% Level up: 77% Level up: 77%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Location: Ft. Wayne, Indiana
Posts: 1,406
I had the same problem with my Sony TV - shot, and out of warranty. Picture, no picture, but I always had sound. Random - no rhyme or reason to it. So I bought a Panasonic Plasma.
dhh3 is offline  
post #3 of 25 (permalink) Old 02-16-2011, 07:03 PM
Junior Member
Points: 124, Level: 2 Points: 124, Level: 2 Points: 124, Level: 2
Level up: 48% Level up: 48% Level up: 48%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2011
Location: Townsville, Australia
Posts: 17
I, too, had the same problem. Would go off and on constantly. Was so irritating (particularly at night) that I stuck my cap over it. Turned out to be an internal connection. Fortunately, it happened less than 10K km from new and the whole unit was replaced under warranty.
Boydie is offline  
 
post #4 of 25 (permalink) Old 02-16-2011, 07:33 PM Thread Starter
Junior Member
Points: 43, Level: 1 Points: 43, Level: 1 Points: 43, Level: 1
Level up: 86% Level up: 86% Level up: 86%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2011
Location: Chattanooga, TN
Posts: 4
Quote:
Originally Posted by Boydie View Post
I, too, had the same problem. Would go off and on constantly. Was so irritating (particularly at night) that I stuck my cap over it. Turned out to be an internal connection. Fortunately, it happened less than 10K km from new and the whole unit was replaced under warranty.
it pisses me off just because there is no reason and it is totally random. sometimes some of my buttons don't work but i have audio all day long. it will eject cds but not switch from cd to fm/am. its not under warranty so it's looking like im going to have to take it to the dealership and throw out 100 bucks just for them to look at it
carriebp is offline  
post #5 of 25 (permalink) Old 02-16-2011, 08:54 PM
Super Moderator
Points: 59,263, Level: 100 Points: 59,263, Level: 100 Points: 59,263, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,875
Quote:
Originally Posted by carriebp View Post
it pisses me off just because there is no reason and it is totally random. sometimes some of my buttons don't work but i have audio all day long. it will eject cds but not switch from cd to fm/am. its not under warranty so it's looking like im going to have to take it to the dealership and throw out 100 bucks just for them to look at it
They will tell you they don't fix them, they only replace them...about $2,000 (that's 2 thousand).

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S

Last edited by jeep5253; 02-16-2011 at 08:57 PM.
jeep5253 is offline  
post #6 of 25 (permalink) Old 02-16-2011, 09:57 PM Thread Starter
Junior Member
Points: 43, Level: 1 Points: 43, Level: 1 Points: 43, Level: 1
Level up: 86% Level up: 86% Level up: 86%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2011
Location: Chattanooga, TN
Posts: 4
Quote:
Originally Posted by jeep5253 View Post
They will tell you they don't fix them, they only replace them...about $2,000 (that's 2 thousand).
i will be telling them before i take it, that if thats the case i wont be bringing it
carriebp is offline  
post #7 of 25 (permalink) Old 02-17-2011, 04:56 PM
Senior Member
Points: 6,156, Level: 51 Points: 6,156, Level: 51 Points: 6,156, Level: 51
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
JJSEBASTIAN's Avatar
 
Join Date: Apr 2007
Location: Syracuse, NY
Posts: 451
Mine is doing the same thing. Some info in this forum points toward an internal connector in the unit. I am going to take ir our of the dash and take it apart and look around in it an wiggle/take apart everything and put ti all together again. I just need to get some time. I'll let you know hoe it turns out. If you get to it first let us know!
Oh and Some of my buttons on the bottom of the unit also quit when the screen goes black...

Black 2006 Limited 5.7
Rocky Road 2.25" Lift,
Spidertrax 1.5" Wheel Spacers,
265/70R17 Bridgestone Dueler A/T RH-S
Gibson 3" SS Exhaust
JJSEBASTIAN is offline  
post #8 of 25 (permalink) Old 02-17-2011, 05:44 PM
Senior Member
Points: 16,175, Level: 81 Points: 16,175, Level: 81 Points: 16,175, Level: 81
Level up: 65% Level up: 65% Level up: 65%
Activity: 18% Activity: 18% Activity: 18%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,472
I also have an 06 mine did this for awhile and then stopped. Not sure why, but it has not happened in over a year. Like a computer, disconnect the + side of your battery and then reboot see if this helps. Beats 2K.
Creek is offline  
post #9 of 25 (permalink) Old 02-18-2011, 08:11 AM
Senior Member
Points: 6,156, Level: 51 Points: 6,156, Level: 51 Points: 6,156, Level: 51
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
JJSEBASTIAN's Avatar
 
Join Date: Apr 2007
Location: Syracuse, NY
Posts: 451
Creek Good idea. I'll try that first. Sometimes its easy to overlook the simple things!

Black 2006 Limited 5.7
Rocky Road 2.25" Lift,
Spidertrax 1.5" Wheel Spacers,
265/70R17 Bridgestone Dueler A/T RH-S
Gibson 3" SS Exhaust
JJSEBASTIAN is offline  
post #10 of 25 (permalink) Old 02-18-2011, 09:41 AM
Senior Member
Points: 34,360, Level: 100 Points: 34,360, Level: 100 Points: 34,360, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
cico7's Avatar
 
Join Date: Sep 2007
Location: mid ohio
Posts: 5,612
Garage
Send a message via MSN to cico7 Send a message via Skype™ to cico7
Sounds like a loose connection to me. Check the fuse and fuse holder as well.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benjamin Davis Pirtle
1990-2015
cico7 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Tags
nav screen disapper

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome