HVAC controls, backlighting out? - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-29-2011, 05:10 AM Thread Starter
Junior Member
Points: 347, Level: 6 Points: 347, Level: 6 Points: 347, Level: 6
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
smokeybrown's Avatar
 
Join Date: Feb 2011
Location: Wentzville, Mo
Posts: 9
HVAC controls, backlighting out?

New guy w/ a question here! I searched but couldn't find anything.

I have 2006 Commander, 4.7L, sport model. My HVAC controls function fine, but they are not backlit. They are the only thing on the dash that is out. I looked in the owner's manual, looking for a possible blown fuse, but it is not obvious which one it may be.

Any ideas/help would be much appreciated.

Thanks

Smokey


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 Commander 4.7L
2009 Grand Cherokee 3.7L (wife's)
2006 GTO 6.0L
smokeybrown is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-29-2011, 07:31 AM
Banned
Points: 6,103, Level: 50 Points: 6,103, Level: 50 Points: 6,103, Level: 50
Level up: 77% Level up: 77% Level up: 77%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Location: Ft. Wayne, Indiana
Posts: 1,406
There are 3 lamps soldered onto a circuit board. You have to replace the whole panel, which includes the circuit board - around $100 +. Or, try this:

https://www.jeepcommander.com/forums/...hlight=finally


Good luck. I had mine replaced under warranty. I am patiently waiting for them to burn out again so I can go out and actually buy one next time.
dhh3 is offline  
post #3 of 3 (permalink) Old 03-29-2011, 11:52 AM Thread Starter
Junior Member
Points: 347, Level: 6 Points: 347, Level: 6 Points: 347, Level: 6
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
smokeybrown's Avatar
 
Join Date: Feb 2011
Location: Wentzville, Mo
Posts: 9
Thanks for your help, just finished fix it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 Commander 4.7L
2009 Grand Cherokee 3.7L (wife's)
2006 GTO 6.0L
smokeybrown is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome