Electrical Problems??Engine management light? - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 05-07-2011, 12:25 PM Thread Starter
Junior Member
Points: 2,795, Level: 32 Points: 2,795, Level: 32 Points: 2,795, Level: 32
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2010
Posts: 10
Unhappy Electrical Problems??Engine management light?

Hi all,
I have a 2007 Jeep Commander 3.0L oil burner- receintly broke down in a multi-story car park(all the dashboard lights illuminated and the stereo kept on turning itself off-also esp/brake warning lights illuminated when I touched the brakes previous to parking up)When I returned to the truck it was as if the battery had died-turning the ignition key and just the starter soleniod clicked I managed to get it started by obtaining a Jump start from a friend.
Putting a meter on the battery- it showed 12.4V with engine off,dropping to 11.3V with engine on??-suspect Alternator??-but driving home with everything switched off seemed to work, as for the next couple of days it started/ran fine-until towing my caravan it just died(stalled) and the engine management light came on.It would turn over but not start(like fuel starvation)until we left it a while, then it started????-ever since I've had random lights generated(even the interior lights coming on and off!!!),
now, the engine management light has come on once again with a flashing red throttle sensor???and there seems to be power loss on acceleration-but the manual says it's on 5.7 petrol engines only??-any help would be apprieciated-Thanks.
Fallen Angel is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-07-2011, 12:40 PM
Super Moderator
Points: 59,277, Level: 100 Points: 59,277, Level: 100 Points: 59,277, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,877
Get a new battery.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is online now  
post #3 of 5 (permalink) Old 05-12-2011, 09:13 AM
Junior Member
Points: 8, Level: 1 Points: 8, Level: 1 Points: 8, Level: 1
Level up: 15% Level up: 15% Level up: 15%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: May 2011
Posts: 2
06 Command w/ Hemi

I too have been having trouble with my radio cutting on and off while driving. I just had the battery replaced and it did not fix the problem. I believe the problem drains the battery as this is my 2nd battery in 6 months (thank God for warranty on the part).

Check out the "Problems / Dealer" Discussion and read the
"Electrical hiccup?? Help" thread. I think you may find some help there.

Hope it helps. Please let me know if you find anything out.
Mr.MeDoesIt is offline  
 
post #4 of 5 (permalink) Old 05-12-2011, 11:05 AM
Super Moderator
Points: 59,277, Level: 100 Points: 59,277, Level: 100 Points: 59,277, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,877
Quote:
Originally Posted by Mr.MeDoesIt View Post
I too have been having trouble with my radio cutting on and off while driving. I just had the battery replaced and it did not fix the problem. I believe the problem drains the battery as this is my 2nd battery in 6 months (thank God for warranty on the part).

Check out the "Problems / Dealer" Discussion and read the
"Electrical hiccup?? Help" thread. I think you may find some help there.

Hope it helps. Please let me know if you find anything out.
He is having more problems than just the radio. That is why I suggested getting a new battery. The symptoms he describes match the symptoms others have had that were fixed when they replaced the battery. And the battery can be bad even though it checks out OK.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is online now  
post #5 of 5 (permalink) Old 05-30-2011, 08:16 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Semi-Conductors go nuts and react in all sorts of unpredictable ways when voltage drops below a certain level. The battery, which is a huge load to charge, can drop the voltage after start on vehicles despite having a good alternator.

Although there could be other causes for these symptoms a bad battery is a likely one.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome