Electronic Throttle Control Problems - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 08-03-2011, 01:03 PM Thread Starter
Member
Points: 1,759, Level: 24 Points: 1,759, Level: 24 Points: 1,759, Level: 24
Level up: 59% Level up: 59% Level up: 59%
Activity: 0% Activity: 0% Activity: 0%
 
cav.turbo's Avatar
 
Join Date: Aug 2011
Location: Nottingham UK
Posts: 59
Send a message via MSN to cav.turbo
Electronic Throttle Control Problems

I'm new to owning a Commander. I just purchsed a 06 Commander at the weekend, and it has a few gremlins which i'm hoping people can help me sort.

When driving sometimes the ETC (Electronic Throttle Control) light is flashing on the dash, but at the same time it starts flashing there is a whining coming from under the jeep. I thought it was the fuel pump at first in the tank, but i replaced that for a new one and it's still there. The engine management light is also on all the time.

I also have a flat spare tyre and a message on the screen shows its got low pressure all the time. Is it possible to just put a standard valve in the spare or will it show that the spare is then missing?? The valve has been snapped off so i can't re-inflate it.
cav.turbo is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 08-03-2011, 04:36 PM
Senior Member
Points: 34,360, Level: 100 Points: 34,360, Level: 100 Points: 34,360, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
cico7's Avatar
 
Join Date: Sep 2007
Location: mid ohio
Posts: 5,612
Garage
Send a message via MSN to cico7 Send a message via Skype™ to cico7
hello and welcome. your entire issue could be related to the TPMS.
The system is looking for input and cant find it.

Or it could be a wheel speed sensor.

Quote:
Originally Posted by cav.turbo View Post
I'm new to owning a Commander. I just purchsed a 06 Commander at the weekend, and it has a few gremlins which i'm hoping people can help me sort.

When driving sometimes the ETC (Electronic Throttle Control) light is flashing on the dash, but at the same time it starts flashing there is a whining coming from under the jeep. I thought it was the fuel pump at first in the tank, but i replaced that for a new one and it's still there. The engine management light is also on all the time.

I also have a flat spare tyre and a message on the screen shows its got low pressure all the time. Is it possible to just put a standard valve in the spare or will it show that the spare is then missing?? The valve has been snapped off so i can't re-inflate it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Benjamin Davis Pirtle
1990-2015
cico7 is offline  
post #3 of 3 (permalink) Old 08-04-2011, 06:59 AM
Senior Member
Points: 2,282, Level: 28 Points: 2,282, Level: 28 Points: 2,282, Level: 28
Level up: 88% Level up: 88% Level up: 88%
Activity: 0% Activity: 0% Activity: 0%
 
XKDRIVER's Avatar
 
Join Date: Oct 2010
Location: South Texas
Posts: 263
https://www.jeepcommander.com/forums/...ead.php?t=4245 Hope this helps on your valve stem problem.
XKDRIVER is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome