Confused: Which (if any) PAC models do I need to install aftermarket nav unit? - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-11-2011, 07:06 PM Thread Starter
Senior Member
Points: 6,977, Level: 55 Points: 6,977, Level: 55 Points: 6,977, Level: 55
Level up: 14% Level up: 14% Level up: 14%
Activity: 0% Activity: 0% Activity: 0%
 
JoeTampa's Avatar
 
Join Date: Feb 2006
Posts: 200
Confused: Which (if any) PAC models do I need to install aftermarket nav unit?

Hi all.

I have an 06 Limited with the Boston Acoustics package and the REC 6-disk Nav system. I intend to replace it with a Valor DDN-868W unit but am unsure which PAC units I will need -- if any. Does anyone have any guidance?
JoeTampa is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-12-2011, 07:51 AM
Junior Member
Points: 4,145, Level: 40 Points: 4,145, Level: 40 Points: 4,145, Level: 40
Level up: 98% Level up: 98% Level up: 98%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2010
Posts: 25
C2R-CHY4

Product Description
Provides navigation trigger wires and timed accessory output for replacing the factory radio and retains the factory installed amplified audio system. Use with a steering wheel interface module to retain function of all factory controls.


Product Features
Keeps Data-Bus Intact for Vehicle Service & Emissions Testing
Built in SWI-CAN
Data controlled RAP accessory output wire
Data controlled parking brake wire
Data controlled reverse trigger
Data controlled vehicle speed sense wire
Data controlled illumination output
Retains factory-installed amplified audio system
nserafini is offline  
post #3 of 8 (permalink) Old 09-12-2011, 01:49 PM Thread Starter
Senior Member
Points: 6,977, Level: 55 Points: 6,977, Level: 55 Points: 6,977, Level: 55
Level up: 14% Level up: 14% Level up: 14%
Activity: 0% Activity: 0% Activity: 0%
 
JoeTampa's Avatar
 
Join Date: Feb 2006
Posts: 200
Thanks. I was also a little confused as to which steering wheel module I would need, a call to PAC confirmed that with that module, you use the SWI-PS. Ordered!
JoeTampa is offline  
 
post #4 of 8 (permalink) Old 09-22-2011, 08:44 PM Thread Starter
Senior Member
Points: 6,977, Level: 55 Points: 6,977, Level: 55 Points: 6,977, Level: 55
Level up: 14% Level up: 14% Level up: 14%
Activity: 0% Activity: 0% Activity: 0%
 
JoeTampa's Avatar
 
Join Date: Feb 2006
Posts: 200
OK.. Tons of misinformation out there.. Between numerous phone calls between Valor and PAC, I've figured out a few things. Hopefully this helps someone else out.

So the interface was 100% correct - the C2R-CHY4 works, but the SWI-PS is ONLY for Pioneer and Sony head units that have a 1/8" steering wheel control jack on the radio. The Valor has 3 leads for steering wheel control - ground and 2 control data leads. After much wailing and knashing of teeth, I figured out that I didn't need a steering wheel interface module at all -- the steering wheel control leads from the C2R-CHY4 go directly to the DDN-868W's leads. HOWEVER, the first tech told me that I was to wire all three from the C2R-CHY4 to all three from the Valor -- not so much. One of the C2R-CHY4 wires (red) is constantly 12v, and that will let smoke out. I wound up wiring the grounds together and running the green/white lead from the C2R-CHY4 to the brown control lead. It doesn't work terribly well, but that may be a programming issue that I need to resolve.

The other thing to keep in mind that is probably well known to many of you but I did not know/fully appreciate is that the CAN bus actually commands the stock radio and amplifier to turn on and off. The C2R-CHY4 interprets these commands and provides/cuts power to the head unit (which obviously does not speak the CAN lingo!). So I had an issue where the radio remained on even after I turned the vehicle off and opened the door. The amplifier turned off, the lights turned on, but the radio did not shut off. And, the entire time, 12v was available on the radio connector. Drove me nuts until I realized that there would always BE 12v coming in, the C2R-CHY4 unit kills the power to the radio.
JoeTampa is offline  
post #5 of 8 (permalink) Old 09-28-2011, 12:08 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Quote:
Originally Posted by JoeTampa View Post
...The Valor has 3 leads for steering wheel control - ground and 2 control data leads...

...I wound up wiring the grounds together and running the green/white lead from the C2R-CHY4 to the brown control lead. It doesn't work terribly well, but that may be a programming issue that I need to resolve.
I suspect your problem may be from wiring the negative data lead to ground. I really don't know for sure, but when it comes to data circuits, I don't think you can always trust that one side is just ground, you really need to connect it like designed. It could be introducing noise or failing to cancel noise, being grounded instead of part of dedicated data circuit, or the negative lead for data may be designed to be a different potential then ground. And sometimes, one wire can be transmitt and the other receive, so you might have turned your two way data path into a one way path.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
post #6 of 8 (permalink) Old 09-28-2011, 12:17 PM Thread Starter
Senior Member
Points: 6,977, Level: 55 Points: 6,977, Level: 55 Points: 6,977, Level: 55
Level up: 14% Level up: 14% Level up: 14%
Activity: 0% Activity: 0% Activity: 0%
 
JoeTampa's Avatar
 
Join Date: Feb 2006
Posts: 200
The Valor folks weren't too helpful on that score - the support tech I spoke to essentially said that the two SWC inputs were the same. I have yet to call them to see if it's a programming issue - to be honest, it's starting to get easier and easier to twiddle the knob.
JoeTampa is offline  
post #7 of 8 (permalink) Old 09-28-2011, 12:40 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
You've never said how many connectors or pin out on the Steering Column remote connector? Is it two or three? 1/8" jacks can have 2 or 3, 4 contacts is becoming common today, heck I've seen them with as many as 6.

Coming from a point of ignorance on the Radio here, but I would suspect the wiring before a programming problem in the translator/converter, especially since you described that you had to improvise with the wiring.

Data+ has to connect to Data+ and Data- has to connect to Data-, NOT ground. It might work grounding it, it might NOT work at all. If I understood you correctly, you connected the Data- to Ground, and it doesn't work well. That would be my first suspicion as to what is wrong, that Data- to Ground connection, if it isn't working right.

See what I'm getting at? You tried to squeeze a lot into a short post, so I might have misunderstood what you did.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Mongo; 09-28-2011 at 12:57 PM.
Mongo is offline  
post #8 of 8 (permalink) Old 09-30-2011, 10:18 AM Thread Starter
Senior Member
Points: 6,977, Level: 55 Points: 6,977, Level: 55 Points: 6,977, Level: 55
Level up: 14% Level up: 14% Level up: 14%
Activity: 0% Activity: 0% Activity: 0%
 
JoeTampa's Avatar
 
Join Date: Feb 2006
Posts: 200
OK, let me try to clarify.

The PAC module has three leads - one has constant 12v (why I don't know - maybe it's defective?), ground, and a data+ lead that varies voltage to different values with the different button presses. The Valor has three leads as well - two marked "data", that Valor says are functionally identical - not sure if I buy that - and a ground.

I wired the ground to the ground, and the data+ from the PAC module to one of the two data leads from the Valor.

When I go to program the radio, it sees the button presses - but not always, and not always right away.
JoeTampa is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome