06 Limited CD changer problems - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-24-2012, 12:24 AM Thread Starter
Junior Member
Points: 233, Level: 4 Points: 233, Level: 4 Points: 233, Level: 4
Level up: 66% Level up: 66% Level up: 66%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2011
Posts: 4
06 Limited CD changer problems

I have an 06 commander limited, and recently the cd changer has just started cycling while the vehicle is on and off which is killing my battery. Ive taken the dash apart and unplugged the unit.

has anyone had any similar problems?

I was thinking about replacing it anyways, but the next questions is, What's the best solution so I can still use the Uconnect, steering wheel controls and the VES?


thanks guys
Joelmd is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-24-2012, 10:03 AM
Senior Member
Points: 12,498, Level: 73 Points: 12,498, Level: 73 Points: 12,498, Level: 73
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
rwmorrisonjr's Avatar
 
Join Date: Mar 2007
Location: Alexandria, VA
Posts: 2,337
Send a message via AIM to rwmorrisonjr Send a message via MSN to rwmorrisonjr Send a message via Yahoo to rwmorrisonjr
Buy another stock unit if you want to maintain full functionality, especially with the UConnect and VES systems. You can find them at decent prices on Ebay, or from other used parts vendors on the web.

2006 XK Sport, 4.7l, QTII- many mods
----------------------------------------------------
'An armed society is a polite society. Manners are good when one may have to back up his acts with his life."- Robert A. Heinlein

"Men sleep peacefully in their beds at night because rough men stand ready to do violence on their behalf."- George Orwell



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rwmorrisonjr is offline  
post #3 of 6 (permalink) Old 02-24-2012, 12:19 PM Thread Starter
Junior Member
Points: 233, Level: 4 Points: 233, Level: 4 Points: 233, Level: 4
Level up: 66% Level up: 66% Level up: 66%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2011
Posts: 4
Thanks

do you know if the later models will work? 07 or 08? they have the aux plug which mine does not...
Joelmd is offline  
 
post #4 of 6 (permalink) Old 02-24-2012, 01:02 PM
Super Moderator
Points: 59,277, Level: 100 Points: 59,277, Level: 100 Points: 59,277, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,877
Quote:
Originally Posted by Joelmd View Post
Thanks

do you know if the later models will work? 07 or 08? they have the aux plug which mine does not...
'07 will be plug and play. '08 and up you will need a Lockpick adapter.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #5 of 6 (permalink) Old 02-24-2012, 05:09 PM Thread Starter
Junior Member
Points: 233, Level: 4 Points: 233, Level: 4 Points: 233, Level: 4
Level up: 66% Level up: 66% Level up: 66%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2011
Posts: 4
thanks for the help!
Joelmd is offline  
post #6 of 6 (permalink) Old 04-02-2012, 12:57 PM
Junior Member
Points: 4,572, Level: 43 Points: 4,572, Level: 43 Points: 4,572, Level: 43
Level up: 11% Level up: 11% Level up: 11%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 13
I just mailed mine to Jimmy Chen to repair the 6 disc changer. Apparently its a pretty common problem on the early REC units. I have an 06 as well. The manufacture date on the nav unit in mine was April 05. Here is his contact info. $150 to repair and you have to ship it to him.

Here is his paypal/email address
[email protected]


Here is his shipping address
ALPINE AUTO SOUND
140 HIRSCHFIELD PL
NEW MILFORD, NJ 07646


In my case I bought a used REC unit on ebay (it was 4 years newer) and just swapped them so I wouldn't have to go with a hole in the dash for 2 weeks. I plan on re-selling mine once I get it back. If you buy another one make sure it has the reverse camera port on the back. http://www.wkjeeps.com/wk_nav.htm (scroll down to "radio removal" for pics of the back) This way you can add that option later if you chose. The early REC units don't have it. I ran everything this weekend for the reverse camera and even tapped into my factory VES so I can play the video on the Nav screen as well as the overhead screen. I plan on doing a write up once I have it complete. The lockpick is out for delivery today to complete the setup. I took pics of which wires to tap into on the DVD player since there wasn't anything out there I could find that was correct.
Markdonnell1975 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome