Replacing the AMP damage head unit - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-08-2012, 09:17 AM Thread Starter
Junior Member
Points: 579, Level: 11 Points: 579, Level: 11 Points: 579, Level: 11
Level up: 58% Level up: 58% Level up: 58%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Posts: 3
Replacing the AMP damage head unit

Greetings All

I just brought my jeep into the stealership to have the amp replaced. 4 hours of labour later I get the jeep back with the head unit not working.

First the screen is dark. All other functions work.

I bring it back and now I get one fuzzy station and no other function works.

Can an improperly installed amp damage the head unit?

Can an amp be improperly installed and still have sound.

Thanks All

Peter
Petermba is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-08-2012, 12:17 PM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
I dont have an answer for you but i would take it back to the dealer and have them fix it on their dime.




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
post #3 of 3 (permalink) Old 05-10-2012, 08:40 AM Thread Starter
Junior Member
Points: 579, Level: 11 Points: 579, Level: 11 Points: 579, Level: 11
Level up: 58% Level up: 58% Level up: 58%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jul 2011
Posts: 3
Thanks

I already brought it back to them and they say it is not their fault and refuse to fix on their dime.

I will be heading to court on this one.

Peter
Petermba is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome