Dead Factory Radio - Going on Vacation -Help! - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-08-2012, 11:51 PM Thread Starter
Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Herdfan's Avatar
 
Join Date: May 2007
Location: Huntington, WV
Posts: 46
Dead Factory Radio - Going on Vacation -Help!

I've been searching previous threads, but need some help.

I have a 2007 with stock BA system. A couple of days ago after a heavy rain, radio stopped working. I get no sound at all. The radio powers on and off, switches modes, discs, etc. just no sound. Checked fuses, and none that seem linked to radio or amp seem to have any issue.

I've seen that when the BA amp dies, you should at least get sound from the front dash speakers, but I'm getting nothing so I am leaning towards the head unit.

Does this sound like a bad head unit? If so, is this a REC, REQ, ?

Talked to two local car audio places and both said that they would have to start by replacing the factory head unit with aftermarket and then troubleshoot from there...

I'm trying to get into the dealer due to the short timeline, but I have to look at all options as I really don't want to take a 10 hour road trip with no radio. Any advice is greatly appreciated.
Herdfan is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-09-2012, 12:04 AM
Senior Member
Points: 59,678, Level: 100 Points: 59,678, Level: 100 Points: 59,678, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 50% Activity: 50% Activity: 50%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,912
Quote:
Originally Posted by Herdfan
...is this a REC, REQ, ?
Look just below the knob on the right hand side of the unit. That is where the letters are that designate the unit model.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is online now  
post #3 of 7 (permalink) Old 05-09-2012, 10:14 AM Thread Starter
Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Herdfan's Avatar
 
Join Date: May 2007
Location: Huntington, WV
Posts: 46
Well, I feel like an idiot. It is indeed a RAQ unit.

So, does this mean that if I want to replace with another factory unit my only option is another RAQ unit?
Herdfan is offline  
 
post #4 of 7 (permalink) Old 05-11-2012, 03:44 PM
Senior Member
Points: 14,892, Level: 79 Points: 14,892, Level: 79 Points: 14,892, Level: 79
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
GPintheMitten's Avatar
 
Join Date: Nov 2008
Location: Flushing, Michigan
Posts: 2,405
Quote:
Originally Posted by Herdfan View Post
Well, I feel like an idiot. It is indeed a RAQ unit.

So, does this mean that if I want to replace with another factory unit my only option is another RAQ unit?

I don't know but the dealer service manager might know.
GPintheMitten is offline  
post #5 of 7 (permalink) Old 05-14-2012, 10:10 AM Thread Starter
Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Herdfan's Avatar
 
Join Date: May 2007
Location: Huntington, WV
Posts: 46
Well, replaced the factory head unit with a direct replacement. Issues remain the same, so going to look to swap the factory amp now. Hopefully that's the root cause.

We've have extremely heavy rain and I left the car outside to test for moisture around the AMP. Dry as can be, so if it is the AMP, I don't think it's related to moisture from clogged drain tubes.
Herdfan is offline  
post #6 of 7 (permalink) Old 05-14-2012, 08:13 PM Thread Starter
Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Herdfan's Avatar
 
Join Date: May 2007
Location: Huntington, WV
Posts: 46
So, AMP appears to have a failure of some sort. Discoloration and what appears could be water related damage in the larger of the two connectors.

Hopefully just blew the AMP and not the whole harness. There does appear to be some mild discoloration on the connectors. Odd that it did not take out a fuse at the same time.

I have a used AMP on the way, so we'll see if it works.
Herdfan is offline  
post #7 of 7 (permalink) Old 05-16-2012, 11:47 PM Thread Starter
Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
Herdfan's Avatar
 
Join Date: May 2007
Location: Huntington, WV
Posts: 46
Well. It was the AMP. Eff me.

Is there anyway to delete this thread? It was pretty much a gigantic waste of my time and of anyone who bothered to read it.
Herdfan is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome