Fuel gauge is messed up - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-06-2014, 08:18 PM Thread Starter
Junior Member
Points: 28, Level: 1 Points: 28, Level: 1 Points: 28, Level: 1
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2014
Location: Iowa
Posts: 3
Fuel gauge is messed up

I just recently bought a 2006 Commander and the fuel gauge is all screwed up!!! I have replaced the fuel sender unit, tried a different gauge cluster and had the dealer test the wiring. P0463 code is the only code, the jeep is still in the shop as they delve in deeper!!!! $$$$ I am wondering if anyone else has seen this issue????
rk40008 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-07-2014, 08:03 AM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
How did you replace the fuel sender unit? I "think" it only comes as part of the fuel pump? Did you replace the whole fuel pump? If you did, what brand was the new (or was it rebuilt) fuel pump?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
post #3 of 4 (permalink) Old 10-07-2014, 06:58 PM Thread Starter
Junior Member
Points: 28, Level: 1 Points: 28, Level: 1 Points: 28, Level: 1
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2014
Location: Iowa
Posts: 3
I took it to the jeep dealership and they replaced just the sender unit itself, with an lem Mopar part, they said there the only ones who offer it that way. I checked with autozone and they said that I would have to buy a fuel pump assembly from them, which included the pump and sender as one.
rk40008 is offline  
 
post #4 of 4 (permalink) Old 10-09-2014, 07:54 PM Thread Starter
Junior Member
Points: 28, Level: 1 Points: 28, Level: 1 Points: 28, Level: 1
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2014
Location: Iowa
Posts: 3
Update!!! Its finally fixed!!! After endless searching and testing, the dealer finally found a broken wire in the loom, they were able to solder it back together and put heat shrink tubing over the repair.
rk40008 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome