About to have my Nav switched out of my old truck - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 01-06-2008, 07:49 PM Thread Starter
Member
Points: 4,215, Level: 41 Points: 4,215, Level: 41 Points: 4,215, Level: 41
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
Doobyshire's Avatar
 
Join Date: Nov 2007
Location: Overland Park, KS
Posts: 45
Send a message via AIM to Doobyshire
About to have my Nav switched out of my old truck

Hey guys, sometime this week I'm hoping to have my double din Nav/Dvd switched out of my old truck and into my commander. I know that first off i need the navigation bezel from jeep. Is there anything else that you guys have had problems with the installer having on hand that is needed for the install?

Also, I see the bezel on the web is about 120, is it much cheaper from jeep?

Thanks guys

07 Limited 4x4 5.7l RedRock
E&G Grill, Debadged, Pioneer Avic-Z1 nav/dvd
JL Audio 13w7 with JL 1000/1v2
12000k HID's
Tinted Lights
Doobyshire is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 01-06-2008, 10:27 PM
Senior Member
Points: 3,133, Level: 34 Points: 3,133, Level: 34 Points: 3,133, Level: 34
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
ldc2335's Avatar
 
Join Date: Aug 2007
Posts: 343
seems i have an install thread for every question ya got.....look a little harder..the answers are here and i wanna see pics of your system when its done, including sub

https://www.jeepcommander.com/forums/...ead.php?t=3370


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by ldc2335; 01-06-2008 at 10:30 PM.
ldc2335 is offline  
post #3 of 8 (permalink) Old 01-07-2008, 10:12 AM Thread Starter
Member
Points: 4,215, Level: 41 Points: 4,215, Level: 41 Points: 4,215, Level: 41
Level up: 33% Level up: 33% Level up: 33%
Activity: 0% Activity: 0% Activity: 0%
 
Doobyshire's Avatar
 
Join Date: Nov 2007
Location: Overland Park, KS
Posts: 45
Send a message via AIM to Doobyshire
Thanks alot again ldc! ha, I have another question,

I bought the CHTO-01 so that I can keep using the Boston sound system, Just making sure that this will work with an aftermarket Amp and Sub?

07 Limited 4x4 5.7l RedRock
E&G Grill, Debadged, Pioneer Avic-Z1 nav/dvd
JL Audio 13w7 with JL 1000/1v2
12000k HID's
Tinted Lights
Doobyshire is offline  
 
post #4 of 8 (permalink) Old 01-07-2008, 03:44 PM
Senior Member
Points: 3,133, Level: 34 Points: 3,133, Level: 34 Points: 3,133, Level: 34
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
ldc2335's Avatar
 
Join Date: Aug 2007
Posts: 343
it connects the factory harness to your new deck, then you run your amp outputs from your deck.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ldc2335 is offline  
post #5 of 8 (permalink) Old 01-07-2008, 04:28 PM
Points: 5,487, Level: 47 Points: 5,487, Level: 47 Points: 5,487, Level: 47
Level up: 69% Level up: 69% Level up: 69%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2007
Posts: 1,562
Quote:
Originally Posted by Doobyshire
Thanks alot again ldc! ha, I have another question,

I bought the CHTO-01 so that I can keep using the Boston sound system, Just making sure that this will work with an aftermarket Amp and Sub?
It will work, but make sure you have the battery disconnected when you install the Metra wiring harness. I didn't and now my airbag system shuts itself off.
RedCommander is offline  
post #6 of 8 (permalink) Old 01-07-2008, 08:55 PM
Senior Member
Points: 3,133, Level: 34 Points: 3,133, Level: 34 Points: 3,133, Level: 34
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
ldc2335's Avatar
 
Join Date: Aug 2007
Posts: 343
i think its so retarded to have audio controls running through your pcm's data system, i wish i could slap the crap outta that guy who decided that was a good idea..


the kit comes with instructions(READ THEM) they say to cycle your ignition twice...DO IT!!!! or your factory amp will somtimes not come on.....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ldc2335 is offline  
post #7 of 8 (permalink) Old 01-07-2008, 11:06 PM
Senior Member
Points: 13,860, Level: 76 Points: 13,860, Level: 76 Points: 13,860, Level: 76
Level up: 53% Level up: 53% Level up: 53%
Activity: 0% Activity: 0% Activity: 0%
 
rubicontrail.net's Avatar
 
Join Date: Oct 2005
Location: Chandler, AZ
Posts: 2,473
Quote:
Originally Posted by ldc2335
i think its so retarded to have audio controls running through your pcm's data system, i wish i could slap the crap outta that guy who decided that was a good idea..


the kit comes with instructions(READ THEM) they say to cycle your ignition twice...DO IT!!!! or your factory amp will somtimes not come on.....
Going through the PCM to be able to deal with other electronics in the car (Uconnect muting of audio on incoming call, etc.) as well as forthcoming technologies such as voice recognition.

2007 Jeep Commander Limited, 1998 Jeep Wrangler Sahara, 1955 Willys Jeep Pickup (Restoration Project), 2011 Subaru Outback 2.5i Limited:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rubicontrail.net is offline  
post #8 of 8 (permalink) Old 01-09-2008, 03:32 PM
Senior Member
Points: 3,133, Level: 34 Points: 3,133, Level: 34 Points: 3,133, Level: 34
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
ldc2335's Avatar
 
Join Date: Aug 2007
Posts: 343
yea i know the logic, its just way to complicated to change to aftermarket..lol


i miss buying a 10 dollar harness from walmart and that was it..


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ldc2335 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome