Brake lights not working - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-23-2014, 04:10 PM Thread Starter
Junior Member
Points: 1,420, Level: 21 Points: 1,420, Level: 21 Points: 1,420, Level: 21
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2013
Location: Calgary, Alberta
Posts: 23
Brake lights not working

Hi guys I have a 2006 commander Hemi. last night I noticed when I apply brakes, the tail lights do not come on! The clearance lights and turn signals do work. the flashers also work. the stop light bulb illuminates but doesn't light up when I apply brakes (both sides including upper third light). I checked the fuses with a test light and I had my 4-ways on as well. herd the relay clicking off on 4-ways and all fuses good!

any suggestions??? P.S could there be a fuse under the dash?? coz that's the only place I didn't check.
Canamander is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-23-2014, 07:33 PM
Senior Member
Points: 1,884, Level: 25 Points: 1,884, Level: 25 Points: 1,884, Level: 25
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Schlotzky's Avatar
 
Join Date: Aug 2014
Location: Auburn, WA
Posts: 180
You might check your brake light switch. There should be a box mounted by or on the brake pedal lever that controls the brake lights. It is possible that it has a bad connection, or is failing to actuate or has gone out of adjustment.


2007 Red Rock Crystal Pearl Overland
- 2" Daystar lift - 245/75/17 Revo 2s - 1.5" Spidertrax Spacers -
Schlotzky is offline  
post #3 of 7 (permalink) Old 11-23-2014, 09:55 PM Thread Starter
Junior Member
Points: 1,420, Level: 21 Points: 1,420, Level: 21 Points: 1,420, Level: 21
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2013
Location: Calgary, Alberta
Posts: 23
I did check it visually but will definitely check in detail tonight. Thanks a lot!!
any idea if its gone bad... replacement is easy or have to bust a knuckle??
Canamander is offline  
 
post #4 of 7 (permalink) Old 11-26-2014, 03:10 AM Thread Starter
Junior Member
Points: 1,420, Level: 21 Points: 1,420, Level: 21 Points: 1,420, Level: 21
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2013
Location: Calgary, Alberta
Posts: 23
Okey! Back to square one again. I changed the brake pedal switch still the same. Although, my third brake light works. I had the hood open and i heard the relay clicking off when i applied the brakes. Changed the relay around to find out if its bad or not but still clicking away. Could it be the bulbs gone bad?(coincidently both fused tohether) also rechecked the fuses still good!!!
Canamander is offline  
post #5 of 7 (permalink) Old 11-26-2014, 05:01 AM
Senior Member
Points: 31,568, Level: 100 Points: 31,568, Level: 100 Points: 31,568, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 27% Activity: 27% Activity: 27%
 
rblapham's Avatar
 
Join Date: May 2009
Location: Cleveland TN
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 103,000
Posts: 612
Garage
I had a friend that had both headlights out, he changed the high beam switch which took quite a while - found out both headlights were burned out. So Yes check the bulbs, it's easy and cheap. If you have a 12V tester or meter it will cost nothing.

06 Commander Limited Hemi - QDII,
Past -89 Comanche, 98 Grand Cherokee (2WD), 2000 Cherokee, 05 Grand Cherokee Limited 4.7
Had to replace the brakes - they opened more gas stations in town
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rblapham is offline  
post #6 of 7 (permalink) Old 11-26-2014, 05:09 AM
Junior Member
Points: 75, Level: 1 Points: 75, Level: 1 Points: 75, Level: 1
Level up: 50% Level up: 50% Level up: 50%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2014
Posts: 11
I agree if your tail gate brake light works now replace ur bulbs the brake light switch could have burnt that part of bulb
Daveandandria is offline  
post #7 of 7 (permalink) Old 12-07-2014, 10:17 PM Thread Starter
Junior Member
Points: 1,420, Level: 21 Points: 1,420, Level: 21 Points: 1,420, Level: 21
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2013
Location: Calgary, Alberta
Posts: 23
whoo hoo!!! changed the bulbs and it works!!
thanks a lot guys!
Canamander is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome