2006 NAV/stereo unit not keeping presets - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 01-27-2015, 12:23 PM Thread Starter
Member
Points: 2,250, Level: 28 Points: 2,250, Level: 28 Points: 2,250, Level: 28
Level up: 67% Level up: 67% Level up: 67%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2014
Location: Deland FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 45
2006 NAV/stereo unit not keeping presets

Aside from the obvious shortfalls of not having the touchscreen, no Bluetooth, and no iphone input, my newly acquired Limited has another issue. It randomly loses the presets. Then randomly they come back. No rhyme or reason as to why. Any ideas?

ALSO, I have searched and searched for an inexpensive plug and play alternative to add an iphone 5c input and have come up with nothing. Looks like all the add ons are for an ipod and the older style iphone. Is there a plug and play unit that will work? I dont want to break the bank on this, and do not want to give up my current stereo since the previous owner has paid for satellite radio for the next couple years. I do not have a rear entertainment center, so no worries there.
mnypitXK is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 01-27-2015, 05:26 PM
Senior Member
Points: 16,279, Level: 81 Points: 16,279, Level: 81 Points: 16,279, Level: 81
Level up: 86% Level up: 86% Level up: 86%
Activity: 13% Activity: 13% Activity: 13%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,476
Your 06 Limited should have U-connect which is their version of Bluetooth. I have been using it for years. If yours is not working, it my need to be reset.
Creek is offline  
post #3 of 12 (permalink) Old 01-27-2015, 06:42 PM Thread Starter
Member
Points: 2,250, Level: 28 Points: 2,250, Level: 28 Points: 2,250, Level: 28
Level up: 67% Level up: 67% Level up: 67%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2014
Location: Deland FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 45
Is there a button someplace that I am missing? There is nothing about it in the manual.
mnypitXK is offline  
 
post #4 of 12 (permalink) Old 01-27-2015, 07:57 PM
Senior Member
Points: 1,884, Level: 25 Points: 1,884, Level: 25 Points: 1,884, Level: 25
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Schlotzky's Avatar
 
Join Date: Aug 2014
Location: Auburn, WA
Posts: 180
I'm unsure whether or not Bluetooth was an option outside of the REC Navigation system, but the REC is fully compatible with bluetooth. UConnect will be the button on your rearview mirror. You can pair your phone and program in your contacts and all that through the voice prompts.


2007 Red Rock Crystal Pearl Overland
- 2" Daystar lift - 245/75/17 Revo 2s - 1.5" Spidertrax Spacers -
Schlotzky is offline  
post #5 of 12 (permalink) Old 01-27-2015, 10:30 PM
Senior Member
Points: 16,279, Level: 81 Points: 16,279, Level: 81 Points: 16,279, Level: 81
Level up: 86% Level up: 86% Level up: 86%
Activity: 13% Activity: 13% Activity: 13%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,476
[LEFT]Forgot to mention I have the REC Navigation system. Just assumed it was on all limiteds.
Creek is offline  
post #6 of 12 (permalink) Old 01-28-2015, 01:01 PM Thread Starter
Member
Points: 2,250, Level: 28 Points: 2,250, Level: 28 Points: 2,250, Level: 28
Level up: 67% Level up: 67% Level up: 67%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2014
Location: Deland FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 45
It may have it. I am out of town in my company car right now, so I cant look at the mirror. It does have this stereo on this link below. I dont see anyone really using Bluetooth, or Uconnect in this thing though. We do, however, listen to music off the iphone though.

http://www.ebay.com/itm/2007-2006-JE...-/140852447000
mnypitXK is offline  
post #7 of 12 (permalink) Old 01-29-2015, 06:04 AM
Senior Member
Points: 16,279, Level: 81 Points: 16,279, Level: 81 Points: 16,279, Level: 81
Level up: 86% Level up: 86% Level up: 86%
Activity: 13% Activity: 13% Activity: 13%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,476
Same as mine and I have u-connect.
Creek is offline  
post #8 of 12 (permalink) Old 01-29-2015, 08:08 AM
Member
Points: 2,173, Level: 28 Points: 2,173, Level: 28 Points: 2,173, Level: 28
Level up: 16% Level up: 16% Level up: 16%
Activity: 0% Activity: 0% Activity: 0%
 
wingdog's Avatar
 
Join Date: Jun 2014
Location: Henderson, nv
Posts: 65
I have REC and no u-connect. Wish it did.
wingdog is offline  
post #9 of 12 (permalink) Old 01-29-2015, 02:21 PM Thread Starter
Member
Points: 2,250, Level: 28 Points: 2,250, Level: 28 Points: 2,250, Level: 28
Level up: 67% Level up: 67% Level up: 67%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2014
Location: Deland FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 45
Yeah, I don't recall seeing it either, but when my wife gets home I will check. Either way, it still has the issue losing memory.
mnypitXK is offline  
post #10 of 12 (permalink) Old 01-29-2015, 05:02 PM
Senior Member
Points: 16,279, Level: 81 Points: 16,279, Level: 81 Points: 16,279, Level: 81
Level up: 86% Level up: 86% Level up: 86%
Activity: 13% Activity: 13% Activity: 13%
 
Join Date: May 2006
Location: Orlando, FL
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 4.7L V-8
4WD
If 4WD - system: QD-II
Current Mileage: 165,000
Posts: 1,476
To reset U-Connect, remove fuses 27&28 while engine is running. They are located in the fuse box under the hood and are blue and red. There is a little lever on each side that you lift up. Once you lift them up wait 10 seconds then turn off XK and reset the fuses. Start the car and hit U-Connect button and it should work. I would try this for reset buttons also.
Creek is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome