Master Ground Connection Location - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-10-2015, 07:31 PM Thread Starter
Junior Member
Points: 774, Level: 14 Points: 774, Level: 14 Points: 774, Level: 14
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2015
Posts: 12
Master Ground Connection Location

Hello. First time poster. I have a 2006 Commander. Does anyone know where the master ground connection is located? The reason I ask is that my interior lights flicker from time to time - bright to less bright. Also, when I turn on the cabin lights, sometimes they turn on, sometimes they don't, sometimes they turn on after a few seconds or minutes. Most everything I read is to first make sure the wiring harness ground is making good contact (i.e. check for loose connection).

Another reason I ask (although not sure if related) is that I just put in a new aftermarket DD Pioneer. I used the typical PAC harness (with SWC even though I don't have SWC) and everything works great except that I have this very faint hiss or white noise coming out of the speakers, even when the engine is off. You can't really hear it when driving or when the volume is up but it's one of those things where I know it's there. I'm hoping I can find a grounding problem that will solve all my issues.

Thanks,
tonyk is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-10-2015, 07:37 PM Thread Starter
Junior Member
Points: 774, Level: 14 Points: 774, Level: 14 Points: 774, Level: 14
Level up: 74% Level up: 74% Level up: 74%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2015
Posts: 12
Forgot to mention...

The ground connection I'm looking for is the one that feeds the interior lights and/or instrument cluster and/or radio harness. Perhaps that's obvious.
tonyk is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome