Multiple Issues all at once... - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-12-2016, 06:58 PM Thread Starter
Junior Member
 
Join Date: Apr 2016
Posts: 3
Multiple Issues all at once...

I have a 2006 JC limited 4.7. The jeep overheated because of a radiator leak. I replaced the entire cooling system. Then, discovered a cylinder head gasket leak due to the overheat. The engine still started and would run somewhat normal as I could still drive it to the machine shop and for emergency only until I could afford the head work. Now, the Battery and starter both had to be replaced, as well as the coolant hoses that tee off of the firewall. Now, it won't start at all. It gets fuel. I even replaced the crank position sensor by recommendation of a Chrysler mechanic. Still, nothing. I replaced the spark plugs and used the NGKs gasped at .44. I'm getting really frustrated now. I've taken really good care of this vehicle since 2009, and have never had a problem until now. Any suggestions are welcome with open arms.

Last edited by Mgromer; 04-12-2016 at 07:07 PM. Reason: Forgot the vehicle specs
Mgromer is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome