Gauges and turn signals defunct! - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 05-08-2017, 08:46 PM Thread Starter
Junior Member
Points: 616, Level: 12 Points: 616, Level: 12 Points: 616, Level: 12
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
Bigearl67's Avatar
 
Join Date: Jul 2016
Posts: 10
Gauges and turn signals defunct!

So I’m driving my 07 Commander and hear a “ding”, lost allmy dash gauges and turn signals. Anyone have any ideas on where to start troubleshooting?
Bigearl67 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 05-08-2017, 10:13 PM
Super Moderator
Points: 21,510, Level: 92 Points: 21,510, Level: 92 Points: 21,510, Level: 92
Level up: 16% Level up: 16% Level up: 16%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,194
Garage
Quote:
Originally Posted by Bigearl67 View Post
So I’m driving my 07 Commander and hear a “ding”, lost allmy dash gauges and turn signals. Anyone have any ideas on where to start troubleshooting?
Try disconnecting the battery (positive terminal) for a few minutes and re-connecting.

After that, check all your fuses.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #3 of 11 (permalink) Old 05-08-2017, 10:29 PM Thread Starter
Junior Member
Points: 616, Level: 12 Points: 616, Level: 12 Points: 616, Level: 12
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
Bigearl67's Avatar
 
Join Date: Jul 2016
Posts: 10
Quote:
Originally Posted by Big Blue View Post
Try disconnecting the battery (positive terminal) for a few minutes and re-connecting.

After that, check all your fuses.



I tried that, overnight. No dice. No fuses marked gauges or turn signals on either the blocks or in the manual.
Bigearl67 is offline  
 
post #4 of 11 (permalink) Old 05-08-2017, 10:48 PM
Super Moderator
Points: 21,510, Level: 92 Points: 21,510, Level: 92 Points: 21,510, Level: 92
Level up: 16% Level up: 16% Level up: 16%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,194
Garage
Quote:
Originally Posted by Bigearl67 View Post
I tried that, overnight. No dice. No fuses marked gauges or turn signals on either the blocks or in the manual.
Here are the results of the forum search I did for No gauges or turn signals;

Jeep Commander Forums: Jeep Commander Forum - Search Results

Take your time and read through the threads, lots of good info that should help you.

Here is one thing in particular that I pulled out;

Quote:
Closest I could find in the service manual is in the PDC (front box under hood) fuse 27 - 15A blue is for the stop and brake lights. But the turn signal circuit is a CAN buss function and very complicated. Diagnosis is done using the special scanner tool. You could just test all the fuses, use a 12V tester with a lamp on it. one side of the fuse should be 12V all the time - with ignition on. The other side of the fuse is 12V only if fuse good. So a fuse which has 12V on one side and not the other is bad.
It could also have something to do with a bad junction block.

I'm attaching a PDF that might help you if you want to try troubleshooting it on your own.

Here is an excellent post giving a lot of detailed information about the junction block in detail and what all it controls;

https://www.jeepcommander.com/forums/...explained.html

I hope this helps.
Attached Files
File Type: pdf Junction block remove.pdf (156.1 KB, 23 views)


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 05-08-2017 at 11:12 PM.
Big Blue is offline  
post #5 of 11 (permalink) Old 05-10-2017, 04:27 AM Thread Starter
Junior Member
Points: 616, Level: 12 Points: 616, Level: 12 Points: 616, Level: 12
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
Bigearl67's Avatar
 
Join Date: Jul 2016
Posts: 10
Thanks,. Weird, I used the link and got a "Sorry no Matches".
Bigearl67 is offline  
post #6 of 11 (permalink) Old 05-10-2017, 06:51 PM
Super Moderator
Points: 21,510, Level: 92 Points: 21,510, Level: 92 Points: 21,510, Level: 92
Level up: 16% Level up: 16% Level up: 16%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,194
Garage
Quote:
Originally Posted by Bigearl67 View Post
Thanks,. Weird, I used the link and got a "Sorry no Matches".
Which link are you talking about?

https://www.jeepcommander.com/forums/...explained.html

Here is another search; I just checked this one and it seems to work fine;

https://www.jeepcommander.com/forums/...rchid=10488146


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 05-11-2017 at 02:22 AM.
Big Blue is offline  
post #7 of 11 (permalink) Old 05-11-2017, 11:18 PM Thread Starter
Junior Member
Points: 616, Level: 12 Points: 616, Level: 12 Points: 616, Level: 12
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
Bigearl67's Avatar
 
Join Date: Jul 2016
Posts: 10
.The search link.
Bigearl67 is offline  
post #8 of 11 (permalink) Old 05-11-2017, 11:21 PM Thread Starter
Junior Member
Points: 616, Level: 12 Points: 616, Level: 12 Points: 616, Level: 12
Level up: 32% Level up: 32% Level up: 32%
Activity: 0% Activity: 0% Activity: 0%
 
Bigearl67's Avatar
 
Join Date: Jul 2016
Posts: 10
..........................
Bigearl67 is offline  
post #9 of 11 (permalink) Old 05-11-2017, 11:39 PM
Super Moderator
Points: 59,055, Level: 100 Points: 59,055, Level: 100 Points: 59,055, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,853
Quote:
Originally Posted by Bigearl67 View Post
Thanks,. Weird, I used the link and got a "Sorry no Matches".
Yeah, you can't post a link to search results. Well, you can but it won't work.
Bigearl67 likes this.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is online now  
post #10 of 11 (permalink) Old 05-11-2017, 11:44 PM
Super Moderator
Points: 59,055, Level: 100 Points: 59,055, Level: 100 Points: 59,055, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,853
Here is a list of the fuses---> http://jeepdex.com/Commander/DOCS1/FusePanel.pdf

.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is online now  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome