Nav radio breakage - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 1Likes
  • 1 Post By oleblu72
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-11-2017, 02:32 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Nav radio breakage

How wide spread is this problem with these radios? Is it something that Chrysler should address like with a recall has any one or group tried to get something started with the Chrysler its a pretty expensive radio to be hunk of junk? I see and hear a lot about this issue both here and on You Tube, I suppose to some this might sound like a stupid question but its a thought I have.

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-11-2017, 04:33 PM
Super Moderator
Points: 59,482, Level: 100 Points: 59,482, Level: 100 Points: 59,482, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 79% Activity: 79% Activity: 79%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,899
Recalls are only for safety issues.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #3 of 7 (permalink) Old 07-11-2017, 11:03 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
Quote:
Originally Posted by jeep5253 View Post
Recalls are only for safety issues.

Thanks for your reply Jeep5253.

Mark
jeep5253 likes this.

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
 
post #4 of 7 (permalink) Old 07-11-2017, 11:28 PM
Super Moderator
Points: 59,482, Level: 100 Points: 59,482, Level: 100 Points: 59,482, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 79% Activity: 79% Activity: 79%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,899
You're welcome.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #5 of 7 (permalink) Old 07-11-2017, 11:30 PM
Super Moderator
Points: 23,998, Level: 94 Points: 23,998, Level: 94 Points: 23,998, Level: 94
Level up: 65% Level up: 65% Level up: 65%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,499
Garage
Quote:
Originally Posted by oleblu72 View Post
How wide spread is this problem with these radios? Is it something that Chrysler should address like with a recall has any one or group tried to get something started with the Chrysler its a pretty expensive radio to be hunk of junk? I see and hear a lot about this issue both here and on You Tube, I suppose to some this might sound like a stupid question but its a thought I have.
Mark,

If there was anything for the radios from the dealership it would be a factory campaign and there are no campaigns for the radios that I know of.

The difference between a safety recall and a campaign is this; a safety recall pertains to a vehicle problem that is a safety concern; a campaign is a vehicle problem that is not a safety concern, but, pertains to customer satisfaction.

I don't have NAV on my radio (I have a separate GPS unit) but I still had an issue that required getting the entire radio replaced - twice.

The radio display for the back-up camera video, would not display usable video from the back-up camera while backing up. When I first bought my Commander it worked fine, but within a couple of days, my radio display would no longer show usable back-up camera video, it would display it extremely dimly, so dimly that the radio display almost looked completely black, as if it wasn't working at all. The radio display itself, for radio related functions, worked just fine.

When I first discovered this, it was an intermittent problem. Sometimes it would display back-up camera video - and sometimes it would not. As time wore on, the problem became more and more frequent to the point where it almost never worked - and when it did decide to work properly, it would be for very brief periods of time.

First, I replaced the back-up camera. This was the cheaper repair of the two repair options I had (replacing the radio was the other), and of course, it didn't solve the issue. Eventually I had to replace the entire radio - that solved the problem. A rebuilt/reconditioned MyGIG radio from the dealership (which is all you can get now - they no longer sell them brand new) is still almost $1000.00 by itself - 900 and change as I recall.

The 2nd time was free because the reconditioned radio I bought from the dealership and had installed by them had a faulty CD player, so, they had to replace it for free, as I reported the issue within 10 days of them installing it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 07-11-2017 at 11:41 PM.
Big Blue is offline  
post #6 of 7 (permalink) Old 07-12-2017, 11:10 AM
Senior Member
Points: 9,538, Level: 65 Points: 9,538, Level: 65 Points: 9,538, Level: 65
Level up: 63% Level up: 63% Level up: 63%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Dec 2010
Location: Lisle, IL
Own a Commander?: Yes
Model year: 2007
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 126000
Posts: 417
At this point, you either try to fix it yourself (it will surely have problems again) or you look for something aftermarket and modern that will go in with minimal fuss and keep all your functionality.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2007 Overland with all the options (including boulder-kissed bumper)
Bobula is offline  
post #7 of 7 (permalink) Old 07-12-2017, 02:13 PM Thread Starter
Senior Member
Points: 927, Level: 16 Points: 927, Level: 16 Points: 927, Level: 16
Level up: 27% Level up: 27% Level up: 27%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2017
Location: Fowler, Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 147,000
Posts: 100
What my Nav unit does or doesn't do is when the screen does work for the radio or the camera the graphics seems to be ok but sometimes when the radio display is on which is rare sometimes the soft touch keys won't work and sometimes they do. When the radio works which is not very often its usually without graphics. I was playing with the sync button one night the microphone was working and when you tell the computer what station you want it couldn't find it. Next time the radio is working I'll try the sync and see if it can find a station. I don't think changing the hard drive is going to help this radio it probably needs a new board but I think I'll pull the radio and take out the hard drive and see if the radio will work just for the sake of trying something.

Mark

08 Hemi Commander, QT2 diffs boo!, 2 inch lift, 265/70/17 Michelin donuts, and it even has the silent MYGIG radio option too this things almost loaded.
oleblu72 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome