Cruise control irregular operation - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 08-29-2017, 01:08 PM Thread Starter
Senior Member
Points: 10,140, Level: 67 Points: 10,140, Level: 67 Points: 10,140, Level: 67
Level up: 23% Level up: 23% Level up: 23%
Activity: 44% Activity: 44% Activity: 44%
 
Join Date: Mar 2009
Location: socal
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Current Mileage: 83k
Posts: 212
Cruise control irregular operation

My Commander is a 2006. Sometimes the cruise control will not come on. After a restart, or sitting, it works fine.
Any ideas? Steering wheel switch contacts?
johnc is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-29-2017, 10:25 PM
Member
Points: 1,338, Level: 20 Points: 1,338, Level: 20 Points: 1,338, Level: 20
Level up: 38% Level up: 38% Level up: 38%
Activity: 0% Activity: 0% Activity: 0%
 
Racer_X's Avatar
 
Join Date: Jun 2016
Posts: 96
Garage
Is the check engine light on? Any DTC's present?

For certain DTC's, the PCM will disable the cruise control entirely.

If there are no DTC's present, and the CEL is not lit, then possibly the clock spring has an issue, or possibly one of the connections is loose and/or corroded.

Racer_X

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

I'm not arguing, I'm just explaining why I'm correct.
Racer_X is offline  
post #3 of 6 (permalink) Old 08-31-2017, 11:52 AM Thread Starter
Senior Member
Points: 10,140, Level: 67 Points: 10,140, Level: 67 Points: 10,140, Level: 67
Level up: 23% Level up: 23% Level up: 23%
Activity: 44% Activity: 44% Activity: 44%
 
Join Date: Mar 2009
Location: socal
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Current Mileage: 83k
Posts: 212
No check engine light. I have a scanner and will check for any DTC's. What is the clock spring?
johnc is offline  
 
post #4 of 6 (permalink) Old 11-18-2017, 06:06 PM
Member
Points: 1,218, Level: 19 Points: 1,218, Level: 19 Points: 1,218, Level: 19
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
johnnymac2k6's Avatar
 
Join Date: Nov 2017
Location: Ohio
Own a Commander?: Yes
Model year: 2010
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-II
Current Mileage: 140000
Posts: 70
Garage
Quote:
Originally Posted by johnc View Post
No check engine light. I have a scanner and will check for any DTC's. What is the clock spring?
idk if you resolved this, but the ABS sensor wire located on one of the vehicles spindles will not throw codes, and it WILL kill your cruise control. Others claim brake light switch...but i have never seen that actually be the case.
johnnymac2k6 is offline  
post #5 of 6 (permalink) Old 11-19-2017, 10:58 PM Thread Starter
Senior Member
Points: 10,140, Level: 67 Points: 10,140, Level: 67 Points: 10,140, Level: 67
Level up: 23% Level up: 23% Level up: 23%
Activity: 44% Activity: 44% Activity: 44%
 
Join Date: Mar 2009
Location: socal
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Current Mileage: 83k
Posts: 212
I used the 3 key turn method to get a "loss of vacuum signal" readout. The commander has thrown CEL messages that were way off base before, so I am not sure if that is the real problem. Even though the code reader showed no codes, I was able to erase that message with it.
My high mounted brake light was out, and once I cleaned the contacts, the cruise has been working.
OBTW- I got an explanation of the clockspring off youtube. A great example of over engineering. Whatever happened to the old fashioned contact plate?

Last edited by johnc; 11-19-2017 at 11:08 PM.
johnc is offline  
post #6 of 6 (permalink) Old 11-25-2017, 10:16 PM Thread Starter
Senior Member
Points: 10,140, Level: 67 Points: 10,140, Level: 67 Points: 10,140, Level: 67
Level up: 23% Level up: 23% Level up: 23%
Activity: 44% Activity: 44% Activity: 44%
 
Join Date: Mar 2009
Location: socal
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-I
Current Mileage: 83k
Posts: 212
Regards the high mount brake light affecting the cruise control. I disconnected it for a couple days, and the cruise still worked.
johnc is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome