Radio on/off issues (powercycling) - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 05-08-2018, 08:27 PM Thread Starter
Banned
Points: 3,376, Level: 36 Points: 3,376, Level: 36 Points: 3,376, Level: 36
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2017
Location: Acworth GA
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 144k
Posts: 159
Radio on/off issues (powercycling)

Cousin got married this weekend and the xk got to play taxi cab. so after dropping people off and a 2 hour drive, and random stops at wendys and taco bell... I was about 10 minutes from my house and radio cuts off. for the next ten minutes it procedes to try and turn on but not quite make it and then repeat. Parked it over night thought maybe it jsut needed to rest but thats a no go. pulled the negative battery cable waited 10-15 minutes and still no good. Havent pulled it out yet, will do that tomorrow with some daylight hopefully, but figured I would double check first if yall had heard of something.

TLDR: So my 2008 stock radio (rer??? i think) keeps power-cycling on and off repeatedly, someone throw out some info if you have it.
heffercow is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 05-08-2018, 08:53 PM
Super Moderator
Points: 21,523, Level: 92 Points: 21,523, Level: 92 Points: 21,523, Level: 92
Level up: 18% Level up: 18% Level up: 18%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,198
Garage
Unhappy

Quote:
Originally Posted by heffercow View Post
Cousin got married this weekend and the xk got to play taxi cab. so after dropping people off and a 2 hour drive, and random stops at wendys and taco bell... I was about 10 minutes from my house and radio cuts off. for the next ten minutes it procedes to try and turn on but not quite make it and then repeat. Parked it over night thought maybe it jsut needed to rest but thats a no go. pulled the negative battery cable waited 10-15 minutes and still no good. Havent pulled it out yet, will do that tomorrow with some daylight hopefully, but figured I would double check first if yall had heard of something.

TLDR: So my 2008 stock radio (rer??? i think) keeps power-cycling on and off repeatedly, someone throw out some info if you have it.
Sounds like your amplifier could be on it's way out - if it's not the amp then it could be the head unit itself - but I'd put my money on your amp giving up the ghost.

Consider trying to bypass the amp if you can figure out a way to do it - and then see if you still have the same problem.

If bypassing the amp solves the issue then you have your culprit.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 05-08-2018 at 08:55 PM.
Big Blue is offline  
post #3 of 4 (permalink) Old 05-15-2018, 06:57 AM Thread Starter
Banned
Points: 3,376, Level: 36 Points: 3,376, Level: 36 Points: 3,376, Level: 36
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Oct 2017
Location: Acworth GA
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 144k
Posts: 159
So quick update, in order to troubleshoot I "borrowed" the rer unit it off my brothers wk. Pretty sure all the head units are the same regardless of whether the vehicle came with upgraded sound system or not. Figured if it was my amp then His Radio would powercycle once it was plugged into my vehicle. But that didn't happen... It worked fine. For the hell of it I plugged my radio into his Jeep, and it worked fine. His jeep does not have the factory amp.

So my radio works in his Jeep (no amp) but not mine (with amp), and his radio works in both. As far as I can tell this leads me to believe my amp is fine and my head unit is having trouble communicating with the amp??? Any Jeep engineers on here that want to weigh in?

I know the easy thing would be to swap with him, but he says no to that. So guess I gotta find a replacement rer it start investigating aftermarket.
heffercow is offline  
 
post #4 of 4 (permalink) Old 05-15-2018, 09:14 AM
Super Moderator
Points: 21,523, Level: 92 Points: 21,523, Level: 92 Points: 21,523, Level: 92
Level up: 18% Level up: 18% Level up: 18%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,198
Garage
Quote:
Originally Posted by heffercow View Post
So quick update, in order to troubleshoot I "borrowed" the rer unit it off my brothers wk. Pretty sure all the head units are the same regardless of whether the vehicle came with upgraded sound system or not. Figured if it was my amp then His Radio would powercycle once it was plugged into my vehicle. But that didn't happen... It worked fine. For the hell of it I plugged my radio into his Jeep, and it worked fine. His jeep does not have the factory amp.

So my radio works in his Jeep (no amp) but not mine (with amp), and his radio works in both. As far as I can tell this leads me to believe my amp is fine and my head unit is having trouble communicating with the amp??? Any Jeep engineers on here that want to weigh in?

I know the easy thing would be to swap with him, but he says no to that. So guess I gotta find a replacement rer it start investigating aftermarket.
Pretty interesting that his radio works with your amp but your radio does not; that's definitely points to a problem with your head unit imo.

The only thing I can tell you is there are plenty of Chrysler factory RER head units on e-bay or you could go aftermarket. After replacing my head unit 3 times, (once for back-up camera video display problems and once for a bad cd player, once for power on/off issues) I came to the realization that even new/reconditioned factory head units for our Commanders have been sitting around in the box for anywhere from 8-12 years or so and they do not have a long life expectancy from my experience with them.

So, rather than roll the dice for a 4th time, I went aftermarket with a Pioneer AVH-X490BS CD/DVD RDS AV head unit with Sirius XM Receiver.

One of the best Commander related decisions I've made.

Good luck.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 05-15-2018 at 09:21 AM.
Big Blue is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome