theory - crazy electrical issues - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-02-2018, 12:44 PM Thread Starter
Member
Points: 2,280, Level: 28 Points: 2,280, Level: 28 Points: 2,280, Level: 28
Level up: 87% Level up: 87% Level up: 87%
Activity: 26% Activity: 26% Activity: 26%
 
chaaz01's Avatar
 
Join Date: Jul 2017
Location: Berkley, Mi
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 79000
Posts: 54
Garage
Send a message via Skype™ to chaaz01
theory - crazy electrical issues

Crazy electrical issues with your XK?

I heard in a conversation with a Chrysler wiring engineer that there were certain locations in the car where water got in contact with inline electrical connectors:

Background:

1.) if an electrical connector is classified as an interior connector it can be cheaper because it doesn't have to be watertight
2.) if its an exterior grade connector it must be outfitted with gaskets and plugs to give it a weather seal

What you typically see inside the cabin of the vehicle are unsealed connectors

The "grey" area is where you have big inline connectors inside the body pillars (a-pillar , b-pillar etc.) that are technically interior of the body. No need for gaskets and seals.

If someone messed up in their interpretation of this classification, and the inner pillars of the car actually encounter water when you are fording or when your sunroof drains plug up and water goes running down through the a-pillar - - you have the perfect scenario for a multi cavity body inline electrical connector to get shorted circuits and wierd operation.

I suspect that the location of these in line harness connectors is the culprit.

Has anyone taken apart a vehicle and likes for the inline connectors?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chaaz01 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome