'09 Hemi Missing "Fuel Saver" Indicator - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-11-2018, 08:23 AM Thread Starter
Junior Member
Points: 756, Level: 14 Points: 756, Level: 14 Points: 756, Level: 14
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
webwzrd's Avatar
 
Join Date: Aug 2018
Location: St Cloud, MN
Own a Commander?: Yes
Model year: 2009
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 118k
Posts: 20
'09 Hemi Missing "Fuel Saver" Indicator

I've got one of those '09 Hemi models that gets occasionally mentioned here that came off the assembly line without the fuel saver or ECO indicator - completely missing from the Personal Settings. Seems to be true for a limited number of WK/XK's.

The threads I've read here that talk about it are fairly old and before I install an led indicator light myself, my question is did an ECU or EVIC flash ever become available that would correct this missing settings option?

Last edited by webwzrd; 11-11-2018 at 08:36 AM.
webwzrd is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 11-11-2018, 09:21 AM
Super Moderator
Points: 23,935, Level: 94 Points: 23,935, Level: 94 Points: 23,935, Level: 94
Level up: 59% Level up: 59% Level up: 59%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,482
Garage
Quote:
Originally Posted by webwzrd View Post
I've got one of those '09 Hemi models that gets occasionally mentioned here that came off the assembly line without the fuel saver or ECO indicator - completely missing from the Personal Settings. Seems to be true for a limited number of WK/XK's.

The threads I've read here that talk about it are fairly old and before I install an led indicator light myself, my question is did an ECU or EVIC flash ever become available that would correct this missing settings option?
@webwzrd;

If there is any kind of ECU or EVIC flash or reflash, you'd find it by following the instructions below. It would most likely be listed as a Campaign. Plug in your VIN and look under Campaigns, if it's not there, then it's safe to say, that one does not exist for your particular issue;

You can check to see if all of the factory recalls & campaigns have been completed for the Commander you're looking at (or for the Commander you have already bought) by clicking on the hyperlink below & plugging in the VIN;

https://www.mopar.com/en-us/my-vehic...ls/search.html

The difference between a safety recall and a campaign is this; a safety recall pertains to a vehicle problem that is a safety concern; a campaign is a vehicle problem that is not a safety concern, but, pertains to customer satisfaction.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 11-11-2018 at 09:25 AM.
Big Blue is offline  
post #3 of 4 (permalink) Old 11-11-2018, 05:41 PM Thread Starter
Junior Member
Points: 756, Level: 14 Points: 756, Level: 14 Points: 756, Level: 14
Level up: 56% Level up: 56% Level up: 56%
Activity: 0% Activity: 0% Activity: 0%
 
webwzrd's Avatar
 
Join Date: Aug 2018
Location: St Cloud, MN
Own a Commander?: Yes
Model year: 2009
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 118k
Posts: 20
Good tip there Big Blue, although not a lot to report. Just one recall and one campaign both pertaining to the FINAL DRIVE CONTROLLER MODULE. But that's the answer I needed.

Now I'll pursue installing the LED mod as my only option if I want a MDS indicator.

Thank you.
webwzrd is offline  
 
post #4 of 4 (permalink) Old 11-11-2018, 06:00 PM
Super Moderator
Points: 23,935, Level: 94 Points: 23,935, Level: 94 Points: 23,935, Level: 94
Level up: 59% Level up: 59% Level up: 59%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,482
Garage
Quote:
Originally Posted by webwzrd View Post
Good tip there Big Blue, although not a lot to report. Just one recall and one campaign both pertaining to the FINAL DRIVE CONTROLLER MODULE. But that's the answer I needed.

Now I'll pursue installing the LED mod as my only option if I want a MDS indicator.

Thank you.
Glad I could help.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome