Headunit Question - Jeep Commander Forums: Jeep Commander Forum
Electronics / NAV Discussion This section contains discussion about the electronics system and NAV system in the Jeep Commander.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-15-2009, 10:49 AM Thread Starter
Junior Member
Points: 791, Level: 14 Points: 791, Level: 14 Points: 791, Level: 14
Level up: 91% Level up: 91% Level up: 91%
Activity: 0% Activity: 0% Activity: 0%
 
jcsmith22's Avatar
 
Join Date: Jun 2009
Location: Greenville, SC
Posts: 20
Headunit Question

So I was wanting to get the MyGig and put it in along with some upgraded speakers and a JL W7. I had a couple of questions though, 1. would the MyGig still work with my steering wheel controls? 2. could I hook it up to the new amps/speakers/subs without needing any kind of adapter? Also, Pioneer has a dvd/cd player for couple hundred cheaper, but can I still use the steering wheel controls if I went that route? Thanks in advance for any advice!
jcsmith22 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-15-2009, 10:58 AM
Super Moderator
Points: 59,482, Level: 100 Points: 59,482, Level: 100 Points: 59,482, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 86% Activity: 86% Activity: 86%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,899
What year and model is your Commander ?

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is online now  
post #3 of 8 (permalink) Old 07-15-2009, 11:00 AM Thread Starter
Junior Member
Points: 791, Level: 14 Points: 791, Level: 14 Points: 791, Level: 14
Level up: 91% Level up: 91% Level up: 91%
Activity: 0% Activity: 0% Activity: 0%
 
jcsmith22's Avatar
 
Join Date: Jun 2009
Location: Greenville, SC
Posts: 20
its a 06 Limited, and i forgot to mention it has the factory rear DVD sytem
jcsmith22 is offline  
 
post #4 of 8 (permalink) Old 07-15-2009, 08:05 PM
Senior Member
Points: 12,498, Level: 73 Points: 12,498, Level: 73 Points: 12,498, Level: 73
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
rwmorrisonjr's Avatar
 
Join Date: Mar 2007
Location: Alexandria, VA
Posts: 2,337
Send a message via AIM to rwmorrisonjr Send a message via MSN to rwmorrisonjr Send a message via Yahoo to rwmorrisonjr
You have to get the MyGig adapter from Coastal Electronics for the 06-07 models, and make sure that the MyGIG unit is a LOW-Speed bus. The high speed units won't work in the XK, and its not a direct plug in since the bus wiring was changed in 2008.

2006 XK Sport, 4.7l, QTII- many mods
----------------------------------------------------
'An armed society is a polite society. Manners are good when one may have to back up his acts with his life."- Robert A. Heinlein

"Men sleep peacefully in their beds at night because rough men stand ready to do violence on their behalf."- George Orwell



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rwmorrisonjr is offline  
post #5 of 8 (permalink) Old 07-15-2009, 09:06 PM
Member
Points: 1,382, Level: 20 Points: 1,382, Level: 20 Points: 1,382, Level: 20
Level up: 82% Level up: 82% Level up: 82%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2009
Location: Seattle
Posts: 67
I have the MyGIG in my 07 XK. It's plug and play and everything works with the MyGIG, except you have to do some wiring for the *rear VES and factory rear camera. You also have to update the unit to fix the clock.

*06-07 rear VES doesn't work with MyGIG.

07 Silver XK Overland

Last edited by Ichiban; 07-15-2009 at 09:12 PM.
Ichiban is offline  
post #6 of 8 (permalink) Old 07-19-2009, 03:12 PM Thread Starter
Junior Member
Points: 791, Level: 14 Points: 791, Level: 14 Points: 791, Level: 14
Level up: 91% Level up: 91% Level up: 91%
Activity: 0% Activity: 0% Activity: 0%
 
jcsmith22's Avatar
 
Join Date: Jun 2009
Location: Greenville, SC
Posts: 20
so the only draw back of installing a mygig would be i couldnt hear the volume of a dvd played in the back through my car speakers? i would still be able to play dvd's and use the headphones to hear it correct?
jcsmith22 is offline  
post #7 of 8 (permalink) Old 07-19-2009, 05:37 PM
Member
Points: 1,382, Level: 20 Points: 1,382, Level: 20 Points: 1,382, Level: 20
Level up: 82% Level up: 82% Level up: 82%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2009
Location: Seattle
Posts: 67
Quote:
Originally Posted by jcsmith22 View Post
so the only draw back of installing a mygig would be i couldnt hear the volume of a dvd played in the back through my car speakers? i would still be able to play dvd's and use the headphones to hear it correct?
Yup, correct!

And like I said, you also have to update the unit to fix the clock. MyGIG clock receive its source from the canbus for 08/09 models, so it wouldn't work with older vehicles. It will just show --:-- or 12:00 the whole time without the software update.

07 Silver XK Overland

Last edited by Ichiban; 07-19-2009 at 05:43 PM.
Ichiban is offline  
post #8 of 8 (permalink) Old 07-21-2009, 05:17 AM Thread Starter
Junior Member
Points: 791, Level: 14 Points: 791, Level: 14 Points: 791, Level: 14
Level up: 91% Level up: 91% Level up: 91%
Activity: 0% Activity: 0% Activity: 0%
 
jcsmith22's Avatar
 
Join Date: Jun 2009
Location: Greenville, SC
Posts: 20
Quote:
Originally Posted by Ichiban View Post
Yup, correct!

And like I said, you also have to update the unit to fix the clock. MyGIG clock receive its source from the canbus for 08/09 models, so it wouldn't work with older vehicles. It will just show --:-- or 12:00 the whole time without the software update.
Ok, thanks for the help, time to get to work!
jcsmith22 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Electronics / NAV Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome