Thermastat help - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-10-2010, 10:46 PM Thread Starter
Points: 31, Level: 1 Points: 31, Level: 1 Points: 31, Level: 1
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 3
Thermastat help

I have a 2006 Jeep Commander Limited 4.7L with 29k miles on it. Recently I've been smelling radiator fluid so I topped it off with fluid. Then about a week later it now overheats here an there so I'm guessing the thermostat is sticking. Usually start overheating when idling. (The fan works) I have warranty that still covers all that stuff but there is a $150 deductible and I rather not pay that if I don't have to.

Do you think it's the thermostat? if so is the thermostat hard to install, where is it exactly located on my jeep, and is there easy instructions how to do it?

Thank you to all that can help.

Please let me know before I go out and buy it

Last edited by mrjaydee6882; 01-11-2010 at 06:08 AM.
mrjaydee6882 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-12-2010, 08:38 PM Thread Starter
Points: 31, Level: 1 Points: 31, Level: 1 Points: 31, Level: 1
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 3
Well I went ahead and put the new thermostat in but I noticed right away that there was a lot of radiator fluid dried up all around the water pump and battery so my guess is it's the water pump lol. Water will not circulate through the engine so I'm guessing that's the problem. Tomorrow I'll just take it to the dealer to have them fix it since it is covered under warranty, I just have to pay a $150 deductible.
mrjaydee6882 is offline  
post #3 of 4 (permalink) Old 01-12-2010, 09:07 PM
Senior Member
Points: 11,816, Level: 71 Points: 11,816, Level: 71 Points: 11,816, Level: 71
Level up: 42% Level up: 42% Level up: 42%
Activity: 0% Activity: 0% Activity: 0%
 
robby's Avatar
 
Join Date: Jun 2008
Location: Desplaines IL.
Posts: 3,262
Looks like you found the culprit.

Good luck,
Rob


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
robby is offline  
 
post #4 of 4 (permalink) Old 01-15-2010, 11:57 PM Thread Starter
Points: 31, Level: 1 Points: 31, Level: 1 Points: 31, Level: 1
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2010
Posts: 3
It was it, Chrysler fixed the water pump for me under the warranty so it only cost me $150 bucks so that is not too bad. Well I got a new thermostat and a water pump so hopefully I'll be good for a long while hehe
mrjaydee6882 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome