Failed Water Pump - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 04-19-2010, 01:12 AM Thread Starter
Member
Points: 6,185, Level: 51 Points: 6,185, Level: 51 Points: 6,185, Level: 51
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Andre's Avatar
 
Join Date: Dec 2006
Location: El Paso, Texas
Posts: 59
Failed Water Pump

On Thursday after driving to work, i noticed a nice orange puddle under the front of my Jeep. I was in a suit so I couldn't get on the ground, but after some looking around, I saw coolant leaking from the water pump area. Called the local dealer and limped her over to them for a look. On Friday, dealer confirmed they'd ordered a new water pump and the Jeep would be back together by Monday (assuming part comes in Monday morning).

I thought a water pump failure at 46,000 miles seemed a bit soon. I am curious if anyone else has had a water pump fail on the 5.7L motor with less than 50,000 miles on it?

2008 XK Limited 5.7L. 93,500 miles. 3.5"/2" Heavy Metal Leveling Lift. Spider Trax Spacers. Bilsteins. JK rims w/ 255/75 /17.
Andre is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 04-19-2010, 01:30 AM
Senior Member
Points: 7,410, Level: 57 Points: 7,410, Level: 57 Points: 7,410, Level: 57
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
powerslave1966's Avatar
 
Join Date: Sep 2009
Location: McAllen, TX.
Posts: 1,124
I'm at about 39000 miles and water pump no.3

2007 3.7 Liter Sport 4X4, Jeep Green, RC 2.5" lift, 265/70/17 Mickey Tompson Baja MTZ, Optima Red Top battery, drop-in K&N air filter.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
powerslave1966 is offline  
post #3 of 20 (permalink) Old 04-19-2010, 08:34 AM
Senior Member
Points: 63,765, Level: 100 Points: 63,765, Level: 100 Points: 63,765, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 0% Activity: 0% Activity: 0%
 
a49erFan's Avatar
 
Join Date: Jan 2007
Location: Sunny Arizona
Posts: 12,582
Send a message via Yahoo to a49erFan
No failure here! 16,000 miles and three years.





To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2006 XK, Steel Armadillo Front Bumper w/Warn Powermate winch, Rear Bumper w/tire carrier & Super Sliders, Rhino Rack Roof Rack and Foxwing Awning, KC Lights on Steel Armadillo Light Bar, 4xGuard Rear Differential Cover, Steel Armadillo Plates.
a49erFan is offline  
 
post #4 of 20 (permalink) Old 04-19-2010, 08:50 AM
Senior Member
Points: 5,068, Level: 45 Points: 5,068, Level: 45 Points: 5,068, Level: 45
Level up: 59% Level up: 59% Level up: 59%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2009
Location: wisconsin
Posts: 230
I had to replace mine at just over 40K. 4.7L

06 65th anniversary

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cqbennett is offline  
post #5 of 20 (permalink) Old 04-19-2010, 09:05 AM
Senior Member
Points: 27,950, Level: 98 Points: 27,950, Level: 98 Points: 27,950, Level: 98
Level up: 60% Level up: 60% Level up: 60%
Activity: 0% Activity: 0% Activity: 0%
 
07JeepXK's Avatar
 
Join Date: Sep 2007
Location: Orchard Park, NY
Posts: 6,311
I have a 2007 with over 60,000 miles and I'm still on water pump #1.




2007 4.7 Liter XK | Front OME MD Springs w/Superlift Preload Spacer | Rear 4" Superlift Springs | Bilstein 5125 Rear Shocks | JBA UCA's | Rusty's Rear Adjustable Track Bar | Black Rock 997 Wheels | Fred Goeske 1/4 Inch Wheel Spacers | 305/70R17 Goodyear Wrangler MT/R w/Kevlar | Airflow Snorkel | Flowmaster 40 Series Muffler | Superchips Flashpaq | Mopar Skids | 4xGuard Belly Guard | American Rebel Rear Diff Cover | Rear Powertrax No-Slip | Front E-Locker | Rear Heat/AC Delete
07JeepXK is offline  
post #6 of 20 (permalink) Old 04-19-2010, 10:03 AM
Senior Member
Points: 11,274, Level: 70 Points: 11,274, Level: 70 Points: 11,274, Level: 70
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
XKJeep06's Avatar
 
Join Date: Nov 2007
Location: Houston, TX
Posts: 452
Quote:
Originally Posted by 07JeepXK View Post
I have a 2007 with over 60,000 miles and I'm still on water pump #1.
I have over 57K on my 2006 HEMI, and still on original water pump as well. Actually, almost everything under the hood is original still, aside from spark plugs and air filters.

Join us on Facebook @
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2007 BMW 335i Sedan
2006 Jeep Commander Limited HEMI



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
XKJeep06 is offline  
post #7 of 20 (permalink) Old 04-19-2010, 11:10 AM
Junior Member
Points: 2, Level: 1 Points: 2, Level: 1 Points: 2, Level: 1
Level up: 3% Level up: 3% Level up: 3%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2010
Posts: 1
lost mine on my 2006 v6 a little over 40,000 miles. driving home from a florida vacation. It locked up and burned through the belt after hearing a squealing noise first.Luckily there was a hotel at the nearest exit..I noticed the pulley was very loose and some roller bearings were laying on top of the pump.
bereal is offline  
post #8 of 20 (permalink) Old 04-21-2010, 12:40 PM Thread Starter
Member
Points: 6,185, Level: 51 Points: 6,185, Level: 51 Points: 6,185, Level: 51
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Andre's Avatar
 
Join Date: Dec 2006
Location: El Paso, Texas
Posts: 59
Well, I got my Jeep back on Monday and no leaks since then. I popped the hood this morning to check fluid level and the reservoir was empty. Oops! I checked my receipt from the dealer and it shows they added fluid, but I guess it wasn't enough. I'm going to add (Zerex G-05 if I can find it) some and see how the level does. Otherwise, very happy to have my Jeep back. So, to anyone who has work done on the radiator/waterpump - make sure you check your fluid level.

2008 XK Limited 5.7L. 93,500 miles. 3.5"/2" Heavy Metal Leveling Lift. Spider Trax Spacers. Bilsteins. JK rims w/ 255/75 /17.

Last edited by Andre; 04-22-2010 at 01:17 AM.
Andre is offline  
post #9 of 20 (permalink) Old 04-21-2010, 06:03 PM
Senior Member
Points: 4,007, Level: 40 Points: 4,007, Level: 40 Points: 4,007, Level: 40
Level up: 29% Level up: 29% Level up: 29%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Sep 2008
Location: Madison, WI
Posts: 282
Mine failed at about 30k.

Brendon

07 Limited, Hemi, factory skid plates (dented and scratched
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
), 4XGuard rock rails, OME HD springs and shocks, Spidertrax, Goodyear Dura Trac 245/70-17
brendon is offline  
post #10 of 20 (permalink) Old 04-23-2010, 03:06 PM Thread Starter
Member
Points: 6,185, Level: 51 Points: 6,185, Level: 51 Points: 6,185, Level: 51
Level up: 18% Level up: 18% Level up: 18%
Activity: 0% Activity: 0% Activity: 0%
 
Andre's Avatar
 
Join Date: Dec 2006
Location: El Paso, Texas
Posts: 59
I finally found some Zerex G-05 fluid at NAPA Autoparts. Price wasn't too bad either, only about $8.80 for a gallon of 50/50 mix. I was surprised that Autozone, Pep Boys, and O'Reilly's only carry the universal fluids for all manufacturers.

2008 XK Limited 5.7L. 93,500 miles. 3.5"/2" Heavy Metal Leveling Lift. Spider Trax Spacers. Bilsteins. JK rims w/ 255/75 /17.
Andre is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome