start and stop squeak - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 07-10-2010, 08:44 PM Thread Starter
Senior Member
Points: 2,121, Level: 27 Points: 2,121, Level: 27 Points: 2,121, Level: 27
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
ER NURSE's Avatar
 
Join Date: Mar 2010
Location: Orlando FL
Posts: 299
Question start and stop squeak

I have a squeaking noise after the jeep warms up when i start from a stop or come to a stop. It's not when i shift from left to right, just forwards and backwards. I went around and sprayed some liquid grease and it stopped for a bit, but it's back now.

any thoughts on how to fix?

07, 4.7 V8, QDII, Limited, Rough Country 2" lift, Flowmaster 50, LED license plate lights, complete EURO driving lights, M/T BF Goodrich 245/75/17, Complete 4XGuard with 2" receiver and loop, 4XGuard front skid plate, 10,000lbs promark winch.
ER NURSE is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 07-10-2010, 09:50 PM
Senior Member
Points: 11,816, Level: 71 Points: 11,816, Level: 71 Points: 11,816, Level: 71
Level up: 42% Level up: 42% Level up: 42%
Activity: 0% Activity: 0% Activity: 0%
 
robby's Avatar
 
Join Date: Jun 2008
Location: Desplaines IL.
Posts: 3,262
Quote:
Originally Posted by ER NURSE View Post
I have a squeaking noise after the jeep warms up when i start from a stop or come to a stop. It's not when i shift from left to right, just forwards and backwards. I went around and sprayed some liquid grease and it stopped for a bit, but it's back now.

any thoughts on how to fix?
First place I would be retightening things would be the rear control arm bolts and the panard rod.
These are often found loosening after some miles are put on after a lift.

Rob


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
robby is offline  
post #3 of 3 (permalink) Old 07-11-2010, 02:34 PM Thread Starter
Senior Member
Points: 2,121, Level: 27 Points: 2,121, Level: 27 Points: 2,121, Level: 27
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
ER NURSE's Avatar
 
Join Date: Mar 2010
Location: Orlando FL
Posts: 299
Good point, will do tonight.

07, 4.7 V8, QDII, Limited, Rough Country 2" lift, Flowmaster 50, LED license plate lights, complete EURO driving lights, M/T BF Goodrich 245/75/17, Complete 4XGuard with 2" receiver and loop, 4XGuard front skid plate, 10,000lbs promark winch.
ER NURSE is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome