Looking for way to install mechanical oil pressure gauge on my '08 - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-21-2011, 04:03 PM Thread Starter
Banned
Points: 1,104, Level: 18 Points: 1,104, Level: 18 Points: 1,104, Level: 18
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2011
Posts: 389
Looking for way to install mechanical oil pressure gauge on my '08

I've looked around a little online and I'm not really 100% sure coming up with the info. I am looking for. So I am appealing you all of you here to help me with this. Every vehicle I've ever owned (before the Commander) has had an mechanical oil pressure gauge in it. Short of your fuel gauge I find monitoring oil pressure to be just as important as anything else on your vehicle, especially, as JeepJorge pointed out to me earlier today, during the start up period where you hold your breath after an oil change (hoping for nothing to have gone wrong after the change). I'd like to know if there is a place to tap into for the sensor for a mechanical gauge. If not (I'm asking for my engine specific 2008 4.7 L sohc 305 hp. engine) where could I safely tap into to get an accurate/safe read? JeepJorge also pointed out that he thought that pillar post mounts could be adapted to the interior space of a Commander so a nice professional looking mount could also be had (which would also make your interior really unique too). Any 100% sure factual help would be greatly appreciated gang.

Last edited by CommandSystemsGo!; 03-21-2011 at 04:20 PM.
CommandSystemsGo! is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-21-2011, 04:15 PM
Banned
Points: 6,103, Level: 50 Points: 6,103, Level: 50 Points: 6,103, Level: 50
Level up: 77% Level up: 77% Level up: 77%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Location: Ft. Wayne, Indiana
Posts: 1,406
I think the idiot light sending unit is by the filter. You should be able to tap in there. Mongo added a set of gauges - they sit on top of his dash, to the left of the steering wheel. Search "Mongo" and you can find his thread. He did a great job doing this. Also, you can remove one of your dash vents and install the gauge in the vent hole. BTW, your 4.7 is a SOHC, not a DOHC. The major changes to your version, called Power Tech Corsair, were 2 plugs/cyl. and new heads for better air flow. HP went to 305, from 235.
dhh3 is offline  
post #3 of 12 (permalink) Old 03-21-2011, 04:19 PM Thread Starter
Banned
Points: 1,104, Level: 18 Points: 1,104, Level: 18 Points: 1,104, Level: 18
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2011
Posts: 389
Thanks dhh3. My bad on DOHC over SOHC I actually mistyped, glad you caught that, I will go back and edit so I don't further confuse anyone. Great idea on the idiot light sender, I will begin to look into that....makes sense (why the heck didn't I think of that?). I'll also contact Mongo about his project ask his advice too.
CommandSystemsGo! is offline  
 
post #4 of 12 (permalink) Old 03-21-2011, 04:39 PM Thread Starter
Banned
Points: 1,104, Level: 18 Points: 1,104, Level: 18 Points: 1,104, Level: 18
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2011
Posts: 389
I just found a nice looking universal pillar mount, Sunpro, comes in single, dual and triple mounts. This may provide for a nice clean, professional install look. What do you think?

Single Gauge Pod, Single a-Pillar Gauge Pod
CommandSystemsGo! is offline  
post #5 of 12 (permalink) Old 03-21-2011, 07:52 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
https://www.jeepcommander.com/forums/...ad.php?t=14330

I've had a mechanical oil pressure gauge capillary tube burst, what a mess, and I was stuck because the engine lost oil pressure. If it breaks in the passenger compartment, can you imagine the mess?

I've never had a problem with electric oil pressure gauges, the Autometer Electric work great, responsive, accurate and come in a variety styles. The worse I have ever had, was a slow leak at the sensors threads that made a little bit of mess, never left me stranded.

I have the gauge pod on my Neon R/T, they really need one that is designed to fit the "A" pillar trim piece or they can look like it crap.

You can find a few threads where guys have fit the 2&1/16th" gauges in the circular vents in the dash.

For mine I used the gauge cups and and mounted them on the dash, as you can see in the link above.

Where I got my gauges and accessories:
http://www.summitracing.com/search/b...e/?Ns=Rank|Asc
http://www.summitracing.com/search/b...ew=ProductName
http://www.summitracing.com/search/b...s/?Ns=Rank|Asc
http://www.jegs.com/vpt/Auto-Meter/O...sure-Gauge/105
http://www.jegs.com/webapp/wcs/stores/servlet/KeywordSearchCmd?vendor=105&Ntk=Brand|PartType_x&l angId=-1&Jnar=0&catalogId=10002&Nty=1&I=p&Ne=1%202%203%20 2500000%201147708&Ntt=Auto+Meter|^Gauge+Pod^&store Id=10001&Ntx=mode%20matchall|mode%20matchall&N=0&r edirect=false&itemPerPage=60
http://www.jegs.com/p/Auto-Meter/Aut...45207/10002/-1


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Mongo; 03-21-2011 at 08:05 PM.
Mongo is offline  
post #6 of 12 (permalink) Old 03-23-2011, 02:12 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Quote:
Originally Posted by dhh3 View Post
I think the idiot light sending unit is by the filter.
I wanted to keep the idiot light working, my wife drives the Commander more than I do, so I didn't swap sensors.

My How-To I posted is about installing the sending unit in another port and keeping the sending unit for idiot light where it was at. If you don't want the idiot light, you can just swap the sensor, that will likely make things much easier to install. The Autometer Sending unit has 1/8" NPT threads, don't know what threads the stock sensor is, so you may need an adapter.

Another option is to remove the stock sender and mount both on a plumbing "T" that connects to the stock port. BUT, there is NOT a lot of room to work in there and its close to the accessory belt, so you may have to go to my approach, fitting an adapter to the one journal plug by the oil filter. It really wasn't hard at all, after I figured out what pieces I need, which I posted in the How-To, you can get them at most hardware stores for a few bucks.

Keep in mind, the FSM talks about the sensor being more than just an low oil pressure idiot light switch. I don't know, but maybe the vehicle electronics monitor it and react to it (although guys have posted they have erroronous low oil pressure light and the vehicle drives just fine).


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
post #7 of 12 (permalink) Old 03-23-2011, 02:23 PM Thread Starter
Banned
Points: 1,104, Level: 18 Points: 1,104, Level: 18 Points: 1,104, Level: 18
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2011
Posts: 389
Thanks for the updated info Mongo, I ordered in a universal a-pillar post mount for a 2 1/16 gauge and it would not have fit to the pillar the way I wished (I'm picky so I'm looking for a professional looking install). I did see on YouTube some guy in an asian nation (chinese or japanese lettering, not sure which) had mounted a vacuum gauge in the top middle vent in his Commander....I emailed him but have not heard back (he may not understand what I asked him). I think I am going to try an electrical sending unit model (Autometer) to keep from running the 1/8 oil line to the cockpit, also think that is smart to do because when I do go offroad its down long lanes into woods, I'd hate to snag the line and slowly leak my oil out that way, yet along have it burst (like you described) especially into the cabin, gosh that would be a mess! Thanks for the help on the sending unit location, both you and dhh3 have steered me in the right directions. Now its a matter of figuring out if its just the 8 allen head bolts to take the dash insert piece out in my cabin to access behind the vent openings...if it is then i should easily be able to mount inside with a cup mount then snake the wire down to somewhere where I can find it a way thru the firewall to the engine bay to wire. When I get all this done I'll post up pics...now I just need to find the time to do all this.
CommandSystemsGo! is offline  
post #8 of 12 (permalink) Old 03-23-2011, 02:46 PM
Senior Member
Points: 15,906, Level: 81 Points: 15,906, Level: 81 Points: 15,906, Level: 81
Level up: 12% Level up: 12% Level up: 12%
Activity: 0% Activity: 0% Activity: 0%
 
Mongo's Avatar
 
Join Date: Oct 2010
Location: Lusby, MD
Posts: 3,037
Quote:
Originally Posted by CommandSystemsGo! View Post
Now its a matter of figuring out if its just the 8 allen head bolts to take the dash insert piece out in my cabin to access behind the vent openings...if it is then i should easily be able to mount inside with a cup mount then snake the wire down to somewhere where I can find it a way thru the firewall to the engine bay to wire. When I get all this done I'll post up pics...now I just need to find the time to do all this.
Its more than that, but you're on the right track.
IIRC:
  • You have to pull up the trim piece off the shifter first (1 or 2?)
  • Then pull up the center console trim panel that goes around the shifter.
  • Then remove the trim panel that goes up the center from the center console (the one that covers the radio and has the heat knobs in it).
  • Then you remove all 8 allen screws to pull away the dash.
Actually, one of the 8 allen screws is a dummy screw, it just screws into the plastic dash piece and NOT the support underneath it. They must have added the extra just for symmetry to make it look cool. BUT, pull all 8, don't want to mix them up and break something.

Thats from memory, I probably forgot something, so if something isn't giving, don't force it, look for what else needs to be removed.

Grounds are a no brainer to find.

You have to pull the instrument cluster to get to wiring behind it and splice into the few circuits you need.

The Switched source and lights are harder to find, I have them listed in the how too, hopefully they did NOT change the pin-outs and wire colors over the model years. Mine was a 2010.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Mongo is offline  
post #9 of 12 (permalink) Old 03-23-2011, 02:52 PM Thread Starter
Banned
Points: 1,104, Level: 18 Points: 1,104, Level: 18 Points: 1,104, Level: 18
Level up: 4% Level up: 4% Level up: 4%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2011
Posts: 389
Thanks for the extra info. on the dash piece removal. Ha Ha...I guess in the back of my head I just knew it wouldn't be as simple as 8 (&) allen bolts. I'll follow your directions to the tee and go easy and smart on it. A friend of mine who is a mechanic for a living will be helping me with the wiring in part, I'll just be doing the mounting....Thanks!
CommandSystemsGo! is offline  
post #10 of 12 (permalink) Old 03-23-2011, 03:52 PM
Banned
Points: 6,103, Level: 50 Points: 6,103, Level: 50 Points: 6,103, Level: 50
Level up: 77% Level up: 77% Level up: 77%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jan 2008
Location: Ft. Wayne, Indiana
Posts: 1,406
Quote:
Originally Posted by Mongo View Post
Its more than that, but you're on the right track.
IIRC:
  • You have to pull up the trim piece off the shifter first (1 or 2?)
  • Then pull up the center console trim panel that goes around the shifter.
  • Then remove the trim panel that goes up the center from the center console (the one that covers the radio and has the heat knobs in it).
  • Then you remove all 8 allen screws to pull away the dash.
Actually, one of the 8 allen screws is a dummy screw, it just screws into the plastic dash piece and NOT the support underneath it. They must have added the extra just for symmetry to make it look cool. BUT, pull all 8, don't want to mix them up and break something.

Thats from memory, I probably forgot something, so if something isn't giving, don't force it, look for what else needs to be removed.

Grounds are a no brainer to find.

You have to pull the instrument cluster to get to wiring behind it and splice into the few circuits you need.

The Switched source and lights are harder to find, I have them listed in the how too, hopefully they did NOT change the pin-outs and wire colors over the model years. Mine was a 2010.
Boy, that is a PITA for 08's and above. 06 and 07, just remove the face plate. 5 of the 16 allen head bolts are fake, but it doesn't matter if you remove all 16!

CommandSystemsGo!, I think cico7 installed gauges in his dash vents. You can PM him, and if I am wrong, he can say I don't know what I'm talking about! Won't be the first time!!!!!!!!!!!!!!
dhh3 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome