Amp reading when all off - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-08-2012, 12:14 PM Thread Starter
Senior Member
Points: 32,999, Level: 100 Points: 32,999, Level: 100 Points: 32,999, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 23% Activity: 23% Activity: 23%
 
rblapham's Avatar
 
Join Date: May 2009
Location: Cleveland TN
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 103,000
Posts: 623
Garage
Amp reading when all off

I have a 06 XK limited and an 05 Grand Cherokee Limited. My GC battery went dead and I found that the liftgate wasn't completely closed and light stayed on. 2 days later the battery was dead again (lights off this time after jump starting) - the battery store (Batteries +) had tested the 4 year old (85 month) Interstate battery and all tested good. Must have a drain somewhere. Checking the + wire on the battery I was seeing 2.5 amp usage with all off - a little high. Played with ALL electrical devices and think the liftgate might have been it again although I had closed it good after the first time, now the amps read .20amps. Alternator checks good 13.5 volts. I put the meter on the Commander and it also reads .20amps with all off.
Does .2 amps sound like a normal reading with all off?

06 Commander Limited Hemi - QDII,
Past -89 Comanche, 98 Grand Cherokee (2WD), 2000 Cherokee, 05 Grand Cherokee Limited 4.7
Had to replace the brakes - they opened more gas stations in town
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rblapham is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome