'09 3.7 Waterpump - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 (permalink) Old 02-02-2013, 08:03 PM Thread Starter
Junior Member
Points: 1,881, Level: 25 Points: 1,881, Level: 25 Points: 1,881, Level: 25
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Sioux Falls,SD
Posts: 12
'09 3.7 Waterpump

I was servicing my XK today and noticed that the waterpump is dripping. It looks to be pretty easy to get to it to change it. It almost looks too easy. Am I missing something? Any suggestions or preferences for the waterpump?
flexyxj is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 02-02-2013, 09:21 PM Thread Starter
Junior Member
Points: 1,881, Level: 25 Points: 1,881, Level: 25 Points: 1,881, Level: 25
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Sioux Falls,SD
Posts: 12
Anybody??????
flexyxj is offline  
post #3 of 14 (permalink) Old 02-02-2013, 09:43 PM
Senior Member
Points: 4,967, Level: 45 Points: 4,967, Level: 45 Points: 4,967, Level: 45
Level up: 9% Level up: 9% Level up: 9%
Activity: 0% Activity: 0% Activity: 0%
 
rjhj's Avatar
 
Join Date: Oct 2011
Location: Toronto, Ontario.
Posts: 471
Someone was talking water pump not too long ago. I think it's a common crappy part. Up there with drain tubes and centre dash lights lol


Sent from AutoGuide.com App
rjhj is offline  
 
post #4 of 14 (permalink) Old 02-02-2013, 09:48 PM
Super Moderator
Points: 59,028, Level: 100 Points: 59,028, Level: 100 Points: 59,028, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,852
I used the forum's search feature and found this for you. You know, the search feature comes in really handy when you want to know something about the Commander. See post #6 in this thread---> https://www.jeepcommander.com/forums/...er+pump&page=3

.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #5 of 14 (permalink) Old 02-02-2013, 09:59 PM Thread Starter
Junior Member
Points: 1,881, Level: 25 Points: 1,881, Level: 25 Points: 1,881, Level: 25
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Sioux Falls,SD
Posts: 12
Quote:
Originally Posted by jeep5253 View Post
I used the forum's search feature and found this for you. You know, the search feature comes in really handy when you want to know something about the Commander. See post #6 in this thread---> https://www.jeepcommander.com/forums/...er+pump&page=3

.
Sorry, I missed the search box. Thanks for the link.
flexyxj is offline  
post #6 of 14 (permalink) Old 02-02-2013, 10:13 PM
Super Moderator
Points: 59,028, Level: 100 Points: 59,028, Level: 100 Points: 59,028, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 100% Activity: 100% Activity: 100%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,852

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S

Last edited by jeep5253; 02-02-2013 at 10:16 PM.
jeep5253 is offline  
post #7 of 14 (permalink) Old 02-02-2013, 10:46 PM Thread Starter
Junior Member
Points: 1,881, Level: 25 Points: 1,881, Level: 25 Points: 1,881, Level: 25
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Sioux Falls,SD
Posts: 12
I found a 5 part video on Youtube replacing a waterpump on a Liberty 3.7 that was very informative and I'll be changing mine soon. When I looked it over,it seemed too good to be true and I just wanted to make sure I wasn't missing something. Hopefully, the weather will warm up a bit and I can get it done in the next week or so.

Last edited by flexyxj; 02-02-2013 at 11:03 PM.
flexyxj is offline  
post #8 of 14 (permalink) Old 02-03-2013, 07:52 AM Thread Starter
Junior Member
Points: 1,881, Level: 25 Points: 1,881, Level: 25 Points: 1,881, Level: 25
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Sioux Falls,SD
Posts: 12
I got up early this morning and decided I needed to get this done and here's what I found. The waterpump is fine. It was weeping around the o-ring even though everything was tight. Now,replace the waterpump or clean everything up and apply some RTV and re-assemble? Has anyone else found this issue? It only has 50K on it....
flexyxj is offline  
post #9 of 14 (permalink) Old 02-03-2013, 09:25 AM
Senior Member
Points: 4,239, Level: 41 Points: 4,239, Level: 41 Points: 4,239, Level: 41
Level up: 45% Level up: 45% Level up: 45%
Activity: 0% Activity: 0% Activity: 0%
 
GeeEssFore's Avatar
 
Join Date: Dec 2010
Posts: 226
Id replace it. My truck has 47k and noticed same thing you did. I let it go a week and then replaced. The waterpump was loose as hell. For as cheap as it is might as well do it and save yourself a headache.

-06 Silver Commander

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

GeeEssFore is offline  
post #10 of 14 (permalink) Old 02-03-2013, 10:00 AM Thread Starter
Junior Member
Points: 1,881, Level: 25 Points: 1,881, Level: 25 Points: 1,881, Level: 25
Level up: 81% Level up: 81% Level up: 81%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2012
Location: Sioux Falls,SD
Posts: 12
Quote:
Originally Posted by GeeEssFore View Post
Id replace it. My truck has 47k and noticed same thing you did. I let it go a week and then replaced. The waterpump was loose as hell. For as cheap as it is might as well do it and save yourself a headache.
That's what i've decided to do - replace it and be done - hopefully. I am concerned that it was the o-ring leaking and not the pump itself. It would only leave a spot on the garage floor about the size of a fifty cent piece occasionally but after searching on the net and some Youtube videos I was afraid I would find that the bearings were shot.It will take longer to go get parts than the R&R. It's super easy and simple on the 3.7 without the towing package(no fan/fanclutch) to change the waterpump.
flexyxj is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome