RPMs Surging - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 12-23-2013, 07:09 PM Thread Starter
Member
Points: 1,805, Level: 25 Points: 1,805, Level: 25 Points: 1,805, Level: 25
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 48
RPMs Surging

I tried posting a vid but I couldn't get it to work. I have the 3.7L 2007 commander.

Anyways, the problem I'm talking about is my RPMs surge. They'll drop while in idle to below 500 RPMs and jump up to around 2000 RPMs. Sometimes it stalls sometimes it doesn't.

Any advice in the matter??? I'm thinking I gota clean out the throttle body but want to make sure. Thx in advance for the help.
kingkong1836 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 12-23-2013, 07:23 PM
Senior Member
Points: 7,833, Level: 59 Points: 7,833, Level: 59 Points: 7,833, Level: 59
Level up: 42% Level up: 42% Level up: 42%
Activity: 5% Activity: 5% Activity: 5%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 125K
Posts: 535
I'd remove and clean the idle air control valve (IAC) while spraying and cleaning the TB. I'd also put a can of chevron fuel system cleaner in the tank. It's supposed to be the only fuel additive that has a chemical to clean the fuel injecters and pump. The iac is attached to the side of the tb by torx screws, and has a electrical connector.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
post #3 of 8 (permalink) Old 12-23-2013, 07:57 PM Thread Starter
Member
Points: 1,805, Level: 25 Points: 1,805, Level: 25 Points: 1,805, Level: 25
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 48
Thx for the advice. I thought it could be the IAC also but read somewhere that they stopped the IAC in the 2007 model and everything was controlled in the throttle body. Ill check it out though and hopefully the problem gets resolved.

Thx again!
kingkong1836 is offline  
 
post #4 of 8 (permalink) Old 12-23-2013, 08:01 PM Thread Starter
Member
Points: 1,805, Level: 25 Points: 1,805, Level: 25 Points: 1,805, Level: 25
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 48
I believe they call it drive-by-wire.
kingkong1836 is offline  
post #5 of 8 (permalink) Old 01-02-2014, 08:15 PM
Member
Points: 5,448, Level: 47 Points: 5,448, Level: 47 Points: 5,448, Level: 47
Level up: 49% Level up: 49% Level up: 49%
Activity: 0% Activity: 0% Activity: 0%
 
Grand Poobah's Avatar
 
Join Date: Oct 2008
Location: Milwaukee, WI
Posts: 81
I believe drive by wire started in 2008. Replace the TPS. Cheap and easy, solved the problem for me when I had it.

2007 White 4.7 XK Sport / OME HD lift / AEV Pintler wheels Argent / 265-70-17 Duratracs
Grand Poobah is offline  
post #6 of 8 (permalink) Old 01-02-2014, 09:45 PM
Super Moderator
Points: 58,829, Level: 100 Points: 58,829, Level: 100 Points: 58,829, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 38% Activity: 38% Activity: 38%
 
jeep5253's Avatar
 
Join Date: Jun 2006
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Posts: 14,826
Quote:
Originally Posted by Grand Poobah View Post
I believe drive by wire started in 2008. Replace the TPS. Cheap and easy, solved the problem for me when I had it.
Nope, 2006.

2006 Steel Blue 5.7L HEMI Limited 4x4 Build Date: June 9, 2006 Hour 14
Interior: Dark Slate/Light Graystone with Saddle Brown Leather Seats
Quadra-Drive II, NAV, DVD, Trailer Tow Group IV, Off-Road Group II, Remote Start, UConnect, Rear Backup Camera, Chrome Wheels,
Magnaflow cat-back exhaust, Daytime Running Lights enabled, 2" Rough Country Lift with 265/70R17 Goodyear Wrangler AT/S
jeep5253 is offline  
post #7 of 8 (permalink) Old 01-03-2014, 10:26 AM
Member
Points: 5,448, Level: 47 Points: 5,448, Level: 47 Points: 5,448, Level: 47
Level up: 49% Level up: 49% Level up: 49%
Activity: 0% Activity: 0% Activity: 0%
 
Grand Poobah's Avatar
 
Join Date: Oct 2008
Location: Milwaukee, WI
Posts: 81
I was thinking from my personal experience with the 4.7, which did change in 2008. Hemi was the only one in 2006.

For the OP, the 3.7 went DBW in 2007.

Sorry for my mixup.

2007 White 4.7 XK Sport / OME HD lift / AEV Pintler wheels Argent / 265-70-17 Duratracs
Grand Poobah is offline  
post #8 of 8 (permalink) Old 01-04-2014, 02:28 AM Thread Starter
Member
Points: 1,805, Level: 25 Points: 1,805, Level: 25 Points: 1,805, Level: 25
Level up: 5% Level up: 5% Level up: 5%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Mar 2013
Posts: 48
Update: cleaned the throttle body and threw in some fuel injector cleaner into the gas tank an the problem still persist.

Because it is a drive by wire and I can't simply replace the TPS I'm guessing replacing the throttle body itself is what I have to do??? I'm considering replacing the throttle body because from what ive read and the research I've done whenever there is a problem like this people/information suggests that the TPS is faulty. That piece will get replaced and the problem will be fixed.

Any suggestions??? I feel like I'm on te right path here to fix the problem but if anyone has anymore input I'd like to hear it even just for educational services.

Thx.
kingkong1836 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome