Front wheel hub question - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 11-18-2014, 08:00 PM Thread Starter
Senior Member
Points: 6,422, Level: 52 Points: 6,422, Level: 52 Points: 6,422, Level: 52
Level up: 36% Level up: 36% Level up: 36%
Activity: 5% Activity: 5% Activity: 5%
 
chaotic's Avatar
 
Join Date: Jul 2013
Location: NY
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 160000
Posts: 181
Question Front wheel hub question

Found another broken part on the jeep today!
Looks like my front left hub assembly needs replaced. This is the second mechanic to look at it while looking into my Power steering issues (another story) and they both said there is a ton of play in that wheel when they had it on the lift. It's also probably the culprit to the clunking noise i'm hearing up there..
I was quoted $500 for them to fix it, (most of the cost is the part itself) But from what I read on here it seems like an easy fix. And by not getting the part from Chrysler I can save about $350!!

So hear is are my questions for anyone that's up for it,
-Is this the right part and only thing I should need to fix it?
http://www.rockauto.com/catalog/more...164&cc=1441538
-Is this something you guys would do yourself instead of letting a shop do?
-Any chance one of you have the instructions from the FSM for this fix?


Thanks again for taking the time to read about my ongoing issues. Can't wait to be back up to 100% and driving on the road less traveled!!

2008 Commander, 4.7 QTII
chaotic is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 11-18-2014, 08:14 PM Thread Starter
Senior Member
Points: 6,422, Level: 52 Points: 6,422, Level: 52 Points: 6,422, Level: 52
Level up: 36% Level up: 36% Level up: 36%
Activity: 5% Activity: 5% Activity: 5%
 
chaotic's Avatar
 
Join Date: Jul 2013
Location: NY
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 160000
Posts: 181
Also, considering I'm just over 100K on the jeep, would you guys recommend I do the other front hubs while i'm at it?

Thanks Again!

2008 Commander, 4.7 QTII
chaotic is offline  
post #3 of 10 (permalink) Old 11-24-2014, 12:27 PM Thread Starter
Senior Member
Points: 6,422, Level: 52 Points: 6,422, Level: 52 Points: 6,422, Level: 52
Level up: 36% Level up: 36% Level up: 36%
Activity: 5% Activity: 5% Activity: 5%
 
chaotic's Avatar
 
Join Date: Jul 2013
Location: NY
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 160000
Posts: 181
Got the Part ordered. hopefully it does not take to long to get here. Today while driving the ABS, ESP/BAS, and traction control light came on. and Now when I apply the breaks I can hear grinding on that tire :/
I wonder if the sensor on the hub assembly finally gave out? and if the brake lines are being affected?

Either way i'm not going to drive it until the part gets in and I can take it to the auto hobby shop on base to fix it.

2008 Commander, 4.7 QTII
chaotic is offline  
 
post #4 of 10 (permalink) Old 11-24-2014, 12:38 PM
Senior Member
Points: 2,779, Level: 32 Points: 2,779, Level: 32 Points: 2,779, Level: 32
Level up: 20% Level up: 20% Level up: 20%
Activity: 0% Activity: 0% Activity: 0%
 
ARJeeper's Avatar
 
Join Date: Oct 2014
Location: Bella Vista, AR
Posts: 167
Front wheel hub question

Cool. Keep us updated.

Think I'm going to be replacing one on a friend's XK soon.

2006 XK Limited 5.7l. Inferno Red. QDII.
Gone: '12 JKR, '06 LJ Rubi, '06 WK, '04 TJ, '97 ZJ, '95 YJ
ARJeeper is offline  
post #5 of 10 (permalink) Old 11-24-2014, 06:05 PM
Senior Member
Points: 7,833, Level: 59 Points: 7,833, Level: 59 Points: 7,833, Level: 59
Level up: 42% Level up: 42% Level up: 42%
Activity: 5% Activity: 5% Activity: 5%
 
rhobll's Avatar
 
Join Date: Feb 2011
Location: pittsburgh pa
Own a Commander?: Yes
Model year: 2006
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 125K
Posts: 535
You did good. Timkens the one. I did this repair several years ago, just the drivers side....This isn't a terribly difficult repair. It will test your patience though... once you get the caliper and bracket off, soak the three bolts on the hub with blaster, wd40, etc. Breaking these bolts were difficult. Tapping them lightly can make it easier to remove. Get a new brake dust shield while your at it. They fall apart. After removing the bolts, the piece does not come right out like you think it should. Its pressed into the steering knuckle, well maybe not pressed, but a tight fit. Corrosion sets in there. You will have to lightly tap all around the hub while prying with a bar to loosen up. its only in there about 3/8 to 1/2in. But its IN there. a beast to remove... stick with it keeping in mind the rest of your front end... eventually it'll come out. Once removed, clean out the aluminum opening with light sand cloth, spray with wd40 and wipe clean. Apply anti seize to the back side of the hub to be installed back into the knuckle. I also put anti seize on the bolts. Crank the bolts to their specified tightness with the new shield in place...the rest is easy...don't forget to connect the plug and wire. Use dielectric grease on the plugs.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2006 3.7l Silver black and crome Sport W QT1
K&N cai. Aridium 1X plugs. 1.5" Spider Trax...
Tinted windows gone. Got ticketed for 137.50!! Full Synthetic motor oil and many more mods...
rhobll is offline  
post #6 of 10 (permalink) Old 11-24-2014, 08:04 PM Thread Starter
Senior Member
Points: 6,422, Level: 52 Points: 6,422, Level: 52 Points: 6,422, Level: 52
Level up: 36% Level up: 36% Level up: 36%
Activity: 5% Activity: 5% Activity: 5%
 
chaotic's Avatar
 
Join Date: Jul 2013
Location: NY
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 160000
Posts: 181
Quote:
Originally Posted by rhobll View Post
You did good. Timkens the one. I did this repair several years ago, just the drivers side....This isn't a terribly difficult repair. It will test your patience though... once you get the caliper and bracket off, soak the three bolts on the hub with blaster, wd40, etc. Breaking these bolts were difficult. Tapping them lightly can make it easier to remove. Get a new brake dust shield while your at it. They fall apart. After removing the bolts, the piece does not come right out like you think it should. Its pressed into the steering knuckle, well maybe not pressed, but a tight fit. Corrosion sets in there. You will have to lightly tap all around the hub while prying with a bar to loosen up. its only in there about 3/8 to 1/2in. But its IN there. a beast to remove... stick with it keeping in mind the rest of your front end... eventually it'll come out. Once removed, clean out the aluminum opening with light sand cloth, spray with wd40 and wipe clean. Apply anti seize to the back side of the hub to be installed back into the knuckle. I also put anti seize on the bolts. Crank the bolts to their specified tightness with the new shield in place...the rest is easy...don't forget to connect the plug and wire. Use dielectric grease on the plugs.
WOW! thank you so much for the tips!!! I appreciate it!!! I'll make sure to take those steps this weekend while I got the jeep on the lift

2008 Commander, 4.7 QTII
chaotic is offline  
post #7 of 10 (permalink) Old 11-24-2014, 09:19 PM
Junior Member
Points: 314, Level: 6 Points: 314, Level: 6 Points: 314, Level: 6
Level up: 28% Level up: 28% Level up: 28%
Activity: 0% Activity: 0% Activity: 0%
 
skip2014's Avatar
 
Join Date: Aug 2014
Location: Sturgeon Bay,
Posts: 17
Well my Commander with 90,888 miles on it had the right rear hub-bearing-and improbable wheel assembly replaced. The code U1814 [or U1418 ?] displayed on the dash. The improbable wheel was cracked.

$635.00 for the job to R&R the hub at Jim Olson Jeep, Sturgeon Bay, WI. [The hub cost $280.00 ... the rest was labor, tax, a '%' to throw away a dirty rag or two. ]

Jim Olson also wanted to R&R my two rear discs and pads for $300.00 more.
I put the best pads I could buy from CARQUEST for $54.00. No need to turn the discs. You turn the discs a tiny bit every time the brakes are applied. That was stated when I attended the Bendex Brake School 30+ years ago.

No pedal pulsations ... the discs are running true. Just pads.

skip.

Last edited by skip2014; 11-24-2014 at 09:22 PM.
skip2014 is offline  
post #8 of 10 (permalink) Old 11-29-2014, 05:13 PM Thread Starter
Senior Member
Points: 6,422, Level: 52 Points: 6,422, Level: 52 Points: 6,422, Level: 52
Level up: 36% Level up: 36% Level up: 36%
Activity: 5% Activity: 5% Activity: 5%
 
chaotic's Avatar
 
Join Date: Jul 2013
Location: NY
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 160000
Posts: 181
Quote:
Originally Posted by rhobll View Post
After removing the bolts, the piece does not come right out like you think it should. Its pressed into the steering knuckle, well maybe not pressed, but a tight fit. Corrosion sets in there. You will have to lightly tap all around the hub while prying with a bar to loosen up. its only in there about 3/8 to 1/2in. But its IN there. a beast to remove... stick with it keeping in mind the rest of your front end... eventually it'll come out.
You were not joking about it being stuck in there! spent over 3 hours alone just trying to get the old assembly out! I ended up just ripping the dust shield off to give me more room to work with. I got the top corner separated a good bit but the bottom two are a lot harder to chisel at. That thing is really corroded! I'll take another shot at it tmrw and let you guys know how I make out.

2008 Commander, 4.7 QTII
chaotic is offline  
post #9 of 10 (permalink) Old 11-30-2014, 02:40 PM Thread Starter
Senior Member
Points: 6,422, Level: 52 Points: 6,422, Level: 52 Points: 6,422, Level: 52
Level up: 36% Level up: 36% Level up: 36%
Activity: 5% Activity: 5% Activity: 5%
 
chaotic's Avatar
 
Join Date: Jul 2013
Location: NY
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 160000
Posts: 181
Well, 7 hours over 2 days and the job is done! That was a complete PITA to get out haha. Now I just need to get an alignment done and I'm off to next broke part on the Jeep!

2008 Commander, 4.7 QTII
chaotic is offline  
post #10 of 10 (permalink) Old 01-14-2015, 04:08 AM
Senior Member
Points: 7,788, Level: 59 Points: 7,788, Level: 59 Points: 7,788, Level: 59
Level up: 19% Level up: 19% Level up: 19%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2009
Location: Brisbane
Posts: 162
Send a message via Skype™ to multihull
I'm on my second set of front wheel bearings. The first set were replaced at about 130,000km but I bought Chinese ones. 50,000 km later the L/H one was making a noise on the Expressway. I changes them for Mopar ones as I do a hell of a lot of off roading. They take about 2 hours to change including cleaning up and packing the tools away. No wheel alignment is needed.
And I've just done the rear ones 10,000km ago as one of them was starting to be noisey on the highway and just a bit of play.

They're an easy job to do and for me a lot of fun and satisfaction.

XH V6 3 liter diesel Commander: R/H steer, 2 1/2"OME rear lift, 3" front lift - Murchinson coils with steel spacers on top of struts, JeepinByAl upper control arms, Bilsien shocks, GDE chip, Custom low profile transmission cross member, Black alloys, 32 1/2" rubber , Provent crank case filter, custom rockrails, Custom rear bar, Custom front bar with driving lights, custom front bash plate, 12000lb recovery winch, aftermarket CD/Nav/DVD/Rear Cam system, Interior LEDs, HID lights
multihull is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome