Rear Window Washer Hose Broke - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 02-13-2015, 08:06 PM Thread Starter
Member
Points: 2,360, Level: 29 Points: 2,360, Level: 29 Points: 2,360, Level: 29
Level up: 40% Level up: 40% Level up: 40%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2013
Posts: 32
Rear Window Washer Hose Broke

Need some help, my rear window washer hose broke off where it goes into the tail-light/spray nozzle. I got about a foot of replacement hose from Advance Auto Parts, but don't want to tear anything up putting it in.

I am assuming the "rubber boot" type deal attached to the body where the other end of the hose connects will come out, I can take out the broke hose and plug in the new hose as it should be a simple hose connector inside of it?

Has this happened to anyone, i've tried googling for a video/walkthrough but it seems the problem is not really wide-spread enough .

Any help appreciated, thank you!!
Hawkeyes is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-14-2015, 08:25 PM
Senior Member
Points: 1,884, Level: 25 Points: 1,884, Level: 25 Points: 1,884, Level: 25
Level up: 84% Level up: 84% Level up: 84%
Activity: 0% Activity: 0% Activity: 0%
 
Schlotzky's Avatar
 
Join Date: Aug 2014
Location: Auburn, WA
Posts: 180
I would venture to guess that it's a simple barbed fitting on the tail light itself, and I'm guessing there are no splices from that point all the way to the pump. You should be able to get a male to male barbed fitting and cut the old hose off after the break and splice in from there to the nozzle in the tail light.

2007 Red Rock Crystal Pearl Overland
- 2" Daystar lift - 245/75/17 Revo 2s - 1.5" Spidertrax Spacers -
Schlotzky is offline  
post #3 of 3 (permalink) Old 02-15-2015, 12:03 AM Thread Starter
Member
Points: 2,360, Level: 29 Points: 2,360, Level: 29 Points: 2,360, Level: 29
Level up: 40% Level up: 40% Level up: 40%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Apr 2013
Posts: 32
Thanks!! I took off the plastic molding under where it fits in the back-side and found it is indeed one long hose from the front to the rear...I cut off the dry unusable hose, put in the fitting and connected a new hose from advance auto parts that they just gave me for free.

Glad that was a simple fix, if the hose went bad elsewhere I would have a real problem .
Hawkeyes is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome