50,000... does this sound about right? - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-06-2008, 12:12 PM Thread Starter
Points: 81, Level: 1 Points: 81, Level: 1 Points: 81, Level: 1
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2008
Posts: 9
50,000... does this sound about right?

I bought my JC with 44,xxx mi. on it and although it didn't have any service records with it when I bought it, believe you me it seems like it was very well taken care of!

I've had the oil changed every 3K mi. since I've had it and now that its at 50,000 mi. I think it's time for a little TLC... here' s my list, tell me what you think:

Lube Oil Filter (still using conventional oil, not synthetic yet - probably next change)
Rotate the tires
Replace Air Filter with K&N Filter
Replace spark plugs with Champion Single Platinum plugs
Drain and fill Transfer Case
Check PCV Valve
Coolant Flush Service
Transmission Flush Service

After the dealership does that, I'm having the following done the week after as well:

Factory recall on Powertrain Control Module
Replacing rear spring Isolators (TSB 02-003-07)
Drain and fill Front & Rear Differentals (Axles)

Anyone else have any other suggestions to keep my baby in Tip-Top shape?

Please comment....
aross6 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-06-2008, 04:12 PM
Senior Member
Points: 15,238, Level: 79 Points: 15,238, Level: 79 Points: 15,238, Level: 79
Level up: 78% Level up: 78% Level up: 78%
Activity: 0% Activity: 0% Activity: 0%
 
adamag25's Avatar
 
Join Date: Jul 2008
Location: Northwest Central Jersey
Posts: 2,629
Sounds like you know what you need to do. My only suggestion is to use a different sparkplug, I have never had any luck with champion. NGK or Bosch is your best bet, I use them in everything that takes a sparkplug and even some things that don't...thats how good they are. LOL

Bright Silver 4.7L 2.25 RR/OME lift, Kumho KL71 265/70/17, Flashpaq, Lights, rack, intake, Super44, mopar skids, 4x belly guard, rear fog lights, MM9500 winch, GetLost4x4 winch mount

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HILLBILLY DELUXE
adamag25 is offline  
post #3 of 3 (permalink) Old 11-06-2008, 04:14 PM Thread Starter
Points: 81, Level: 1 Points: 81, Level: 1 Points: 81, Level: 1
Level up: 62% Level up: 62% Level up: 62%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Nov 2008
Posts: 9
You know usually I would follow that advice to a T except when it comes to Chrysler/Jeep products... it's been my experience that Champion plugs perform very well in Mopars but are absolute crap in everything else.... not sure why tho!
aross6 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome