Broken coil pack boots - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 1Likes
  • 1 Post By Burns134
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 09-21-2017, 11:12 AM Thread Starter
Member
Points: 603, Level: 12 Points: 603, Level: 12 Points: 603, Level: 12
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
Burns134's Avatar
 
Join Date: Apr 2017
Location: NW PA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 170,000
Posts: 70
Garage
Broken coil pack boots

Changing spark plugs on my 2010 3.7. I did the passenger side plugs first and then started on the coil packs, the first one's boot broke off. As did the third one.
Is there any way I can get these things to work until I can get new ones.




Also anyone use coils from Amazon? They are 1/3 of the price as the local auto parts stores.
Burns134 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-21-2017, 12:26 PM Thread Starter
Member
Points: 603, Level: 12 Points: 603, Level: 12 Points: 603, Level: 12
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
Burns134's Avatar
 
Join Date: Apr 2017
Location: NW PA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 170,000
Posts: 70
Garage
So in order to remove the boots from where they were stuck onto the plugs I had to use needle nose pliers and just grab chunk by chunk. So reusing them is out.
Dealer wants $140 each -that's not happening. Amazon is $70 for all three, but I can't get them until Saturday. Local parts stores here are $60 each. Guess I'll be grabbing them locally.

The old plugs were horrible. These things may have never been changed. 148,000 miles. The plugs w the coils even have corrosion on the metal bases. All of them have the electrodes worn at least in half.
This should at least fix the hesitation and rough idle issues.
Everything i do to this XK just leads to more issues. I should have just left it stock and drove it until something broke. I am getting tired of nothing going right w this thing. I never had issues w my old TJ.
LSanchez likes this.
Burns134 is offline  
post #3 of 6 (permalink) Old 09-21-2017, 04:24 PM
Senior Member
Points: 3,844, Level: 39 Points: 3,844, Level: 39 Points: 3,844, Level: 39
Level up: 30% Level up: 30% Level up: 30%
Activity: 0% Activity: 0% Activity: 0%
 
2010 inferno's Avatar
 
Join Date: Feb 2016
Location: Cement City, Mi.
Own a Commander?: Yes
Model year: 2010
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 99,000
Posts: 294
Garage
Thumbs up Slowly

But slowly you will have gotten rid of the old owners problems and you will know where you stand for future problems.


Swanny
2010 inferno is offline  
 
post #4 of 6 (permalink) Old 09-21-2017, 06:24 PM Thread Starter
Member
Points: 603, Level: 12 Points: 603, Level: 12 Points: 603, Level: 12
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
Burns134's Avatar
 
Join Date: Apr 2017
Location: NW PA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 170,000
Posts: 70
Garage
I know. Thanks. I was very frustrated earlier. As I have been on everything I do to this thing. Ha.
Here are those horrible plugs....

Burns134 is offline  
post #5 of 6 (permalink) Old 09-23-2017, 06:30 PM
Senior Member
Points: 31,128, Level: 100 Points: 31,128, Level: 100 Points: 31,128, Level: 100
Level up: 0% Level up: 0% Level up: 0%
Activity: 27% Activity: 27% Activity: 27%
 
rblapham's Avatar
 
Join Date: May 2009
Location: Cleveland TN
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 103,000
Posts: 606
Garage
Six should be a snap, my Hemi has 16 - takes me 3 hours to change them if no problems. Don't forget to put dielectric grease on the new boots.

06 Commander Limited Hemi - QDII,
Past -89 Comanche, 98 Grand Cherokee (2WD), 2000 Cherokee, 05 Grand Cherokee Limited 4.7
Had to replace the brakes - they opened more gas stations in town
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rblapham is offline  
post #6 of 6 (permalink) Old 09-23-2017, 08:14 PM Thread Starter
Member
Points: 603, Level: 12 Points: 603, Level: 12 Points: 603, Level: 12
Level up: 6% Level up: 6% Level up: 6%
Activity: 0% Activity: 0% Activity: 0%
 
Burns134's Avatar
 
Join Date: Apr 2017
Location: NW PA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
4WD
If 4WD - system: QT-I
Current Mileage: 170,000
Posts: 70
Garage
It took me a lot longer than 3 hours to get my six out. If I had 16 to do like you guys do, I would have really been frustrated.

Dielectric grease, crap; forgot that. Well next time I change the plugs, I guess I'll be changing coils again.
I would take them off and add it now, but I'm afraid that something else will mess up. As of now, all is ok. -at least with the rough idle issue.

Next is more fluid changes or these stupid clunks that are driving me crazy.
Burns134 is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome