Battery Light on dash.....? - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-10-2017, 06:41 PM Thread Starter
Junior Member
Points: 35, Level: 1 Points: 35, Level: 1 Points: 35, Level: 1
Level up: 70% Level up: 70% Level up: 70%
Activity: 0% Activity: 0% Activity: 0%
 
DerrtyD's Avatar
 
Join Date: Apr 2017
Location: Austin
Posts: 8
Garage
Battery Light on dash.....?

so about 2 weeks ago my battery light popped up on my dash on my way home from work. very short drive i didnt notice a difference in driving but when i popped the hood i saw a little smoke come from under the hood and i could tell the alternator was cooked(plus this happened to my parents Trailblazer years ago and it was the alternator). next day i take my alternator to AZ and of course its bad, i get a new one and throw it in and everything was fine for 2 weeks.

yesterday i was doing some Xmas shopping and it pops back on for some reason. got to my parents place not far from where the light came and noticed none of the symptoms from weeks back. i turned it on again and it was off.

later that night i went to Batteries Plus where i got my new battery during the summer to test it and it was fine.

why does this light keep chasing me? i have a new battery and alternator, is it the Battery Temperature Sensor i keep reading about? thanks in advance guys

Silver Surfer
2008 XK Sport
4x4 full time system
3.6L V6
W5A580
DerrtyD is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 02-12-2018, 08:27 PM
Senior Member
Points: 5,042, Level: 45 Points: 5,042, Level: 45 Points: 5,042, Level: 45
Level up: 46% Level up: 46% Level up: 46%
Activity: 50% Activity: 50% Activity: 50%
 
Join Date: Mar 2014
Location: NorthAmerica
Own a Commander?: Yes
Model year: 2008
Trim Package: Overland
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 150000
Posts: 224
Did you ever get this fixed?

08, Commander, Overland, 5.7L HEMI, QD-II, Stock.
vjsimone is offline  
post #3 of 3 (permalink) Old 02-12-2018, 08:28 PM
Senior Member
Points: 7,991, Level: 60 Points: 7,991, Level: 60 Points: 7,991, Level: 60
Level up: 21% Level up: 21% Level up: 21%
Activity: 0% Activity: 0% Activity: 0%
 
luckyse7ens's Avatar
 
Join Date: Apr 2014
Location: CA
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
Power-Train: 3.7L V-6
2WD
If 4WD - system: QT-I
Current Mileage: 140000
Posts: 1,585
I would check connections and grounds.
luckyse7ens is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome