Cooling system flushed, now have leak... - Jeep Commander Forums: Jeep Commander Forum
Regular Service / Maintenance This section contains discussion about regular service and maintenance (upkeep) of your Jeep Commander

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-26-2009, 08:36 AM Thread Starter
TPS
Senior Member
Points: 8,524, Level: 62 Points: 8,524, Level: 62 Points: 8,524, Level: 62
Level up: 25% Level up: 25% Level up: 25%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Feb 2006
Posts: 213
Cooling system flushed, now have leak...

had the cooling system flush service done about 4 weeks ago. I noticed a slight smell of coolant vapor a few times since after driving. Checked the coolant level and it's at the "ADD COOLANT" line. Definitely didn't have an issue before the service. I'll have to go back to the shop, but does anyone have any insight as to how I might check for a pressure leak? I don't see any obvious signs of leaking - Probably just a small leak allowing vapor to escape.

2006 XK Sport, Midnight Blue
4.7L, 4x4, tow package
TPS is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Regular Service / Maintenance

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome