LED lights staying on - Jeep Commander Forums: Jeep Commander Forum
Interior Appearance Modifications Discuss interior appearance mods here

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 08-06-2016, 10:14 AM Thread Starter
Junior Member
Points: 2,583, Level: 30 Points: 2,583, Level: 30 Points: 2,583, Level: 30
Level up: 89% Level up: 89% Level up: 89%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2014
Location: Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-I
Current Mileage: 139973
Posts: 24
LED lights staying on

I just recently put in all new LED's for all my interior lights, only problem is all the map lights above the door and rear hatch stay on but are dime, floor lights on dome light all go off though. Any ideas whats causing them to stay on?
JeepDude24 is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 08-06-2016, 01:20 PM
Super Moderator
Points: 24,033, Level: 94 Points: 24,033, Level: 94 Points: 24,033, Level: 94
Level up: 69% Level up: 69% Level up: 69%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,509
Garage
Quote:
Originally Posted by JeepDude24 View Post
I just recently put in all new LED's for all my interior lights
I'm curious - what made you decide to do that?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #3 of 21 (permalink) Old 08-06-2016, 08:58 PM Thread Starter
Junior Member
Points: 2,583, Level: 30 Points: 2,583, Level: 30 Points: 2,583, Level: 30
Level up: 89% Level up: 89% Level up: 89%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2014
Location: Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-I
Current Mileage: 139973
Posts: 24
I wanted a different and brighter look to it. It looks great when they're on but after the doors are shut and your driving they stay lit but are just dimmer.
JeepDude24 is offline  
 
post #4 of 21 (permalink) Old 08-06-2016, 09:35 PM
Super Moderator
Points: 24,033, Level: 94 Points: 24,033, Level: 94 Points: 24,033, Level: 94
Level up: 69% Level up: 69% Level up: 69%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida; Proud to have served.
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 101,200
Posts: 5,509
Garage
Quote:
Originally Posted by JeepDude24 View Post
I wanted a different and brighter look to it. It looks great when they're on but after the doors are shut and your driving they stay lit but are just dimmer.
I see.....can't imagine what would be causing that.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Big Blue is offline  
post #5 of 21 (permalink) Old 08-07-2016, 12:41 AM
Senior Member
Points: 6,842, Level: 54 Points: 6,842, Level: 54 Points: 6,842, Level: 54
Level up: 46% Level up: 46% Level up: 46%
Activity: 0% Activity: 0% Activity: 0%
 
consumedbywater's Avatar
 
Join Date: Jun 2013
Location: California
Own a Commander?: Yes
Model year: 2006
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QD-II
Current Mileage: 175,000
Posts: 479
Garage
Since LEDs require significantly less power than the OEM bulbs, the current flow even when off is great enough to light them up. You'll need to add a resistor to the circuit to dissipate the excess power.
JeepDude24 likes this.
consumedbywater is offline  
post #6 of 21 (permalink) Old 08-07-2016, 11:19 AM Thread Starter
Junior Member
Points: 2,583, Level: 30 Points: 2,583, Level: 30 Points: 2,583, Level: 30
Level up: 89% Level up: 89% Level up: 89%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2014
Location: Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-I
Current Mileage: 139973
Posts: 24
Quote:
Originally Posted by consumedbywater View Post
Since LEDs require significantly less power than the OEM bulbs, the current flow even when off is great enough to light them up. You'll need to add a resistor to the circuit to dissipate the excess power.

How do I go about doing that? Has anyone else had this problem with putting LED's bulbs in? I've seen some other posts on here where people have changed theirs out but haven't said they've had problems. I thought maybe it was the type of bulb I'm using.
JeepDude24 is offline  
post #7 of 21 (permalink) Old 08-07-2016, 11:34 AM
Senior Member
Points: 7,337, Level: 56 Points: 7,337, Level: 56 Points: 7,337, Level: 56
Level up: 94% Level up: 94% Level up: 94%
Activity: 0% Activity: 0% Activity: 0%
 
SkulhunterM42's Avatar
 
Join Date: Jan 2016
Location: Port Orchard, Washington
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
2WD
If 4WD - system: QT-I
Current Mileage: 3500
Posts: 359
Garage
I've definitely been having this problem for a couple years now. It really bothered me for the first few months, but I don't really care anymore, so I haven't bothered to fix it. consumedbywater is right, you just need to install a resistor in parallel i believe to one of the led's you installed, or i think keeping one bulb stock might solve the problem too, not sure.

But here's a fix.

https://www.youtube.com/watch?v=JbP-pt4aczs
SkulhunterM42 is offline  
post #8 of 21 (permalink) Old 08-07-2016, 11:35 AM
Senior Member
Points: 7,139, Level: 55 Points: 7,139, Level: 55 Points: 7,139, Level: 55
Level up: 95% Level up: 95% Level up: 95%
Activity: 0% Activity: 0% Activity: 0%
 
Core's Avatar
 
Join Date: Jun 2012
Location: Sicklerville, NJ
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
4WD
If 4WD - system: QT-II
Current Mileage: 88750
Posts: 370
Garage
I replaced all of my interior lights with LED. They look great and I have no issues.

Sent from my SM-N910V using Tapatalk

2010 Hemi XK
Core is offline  
post #9 of 21 (permalink) Old 08-08-2016, 09:15 AM Thread Starter
Junior Member
Points: 2,583, Level: 30 Points: 2,583, Level: 30 Points: 2,583, Level: 30
Level up: 89% Level up: 89% Level up: 89%
Activity: 0% Activity: 0% Activity: 0%
 
Join Date: Jun 2014
Location: Ohio
Own a Commander?: Yes
Model year: 2008
Trim Package: Limited
Power-Train: 5.7L V-8 Hemi
4WD
If 4WD - system: QT-I
Current Mileage: 139973
Posts: 24
Quote:
Originally Posted by Core View Post
I replaced all of my interior lights with LED. They look great and I have no issues.

Sent from my SM-N910V using Tapatalk

Core, if you don't mind me asking what brand of lights did you purchase? Looks great by the way.
JeepDude24 is offline  
post #10 of 21 (permalink) Old 08-08-2016, 06:52 PM
Senior Member
Points: 7,139, Level: 55 Points: 7,139, Level: 55 Points: 7,139, Level: 55
Level up: 95% Level up: 95% Level up: 95%
Activity: 0% Activity: 0% Activity: 0%
 
Core's Avatar
 
Join Date: Jun 2012
Location: Sicklerville, NJ
Own a Commander?: Yes
Model year: 2010
Trim Package: Sport
4WD
If 4WD - system: QT-II
Current Mileage: 88750
Posts: 370
Garage


Sent from my SM-N910V using Tapatalk

2010 Hemi XK
Core is offline  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Jeep Commander Discussion > Appearance Modifications > Interior Appearance Modifications

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome