WAM Custom Bumpers....A follow up review 1 year later. - Jeep Commander Forums: Jeep Commander Forum
Buyer/Seller/Vendor Reviews If you have had dealings with a member or supporting vendor on this site and want to post a review of the transaction, positive or negative, you may do so here -OR- via iTrader feedback. Please do not do BOTH. **NOTE: Please read and follow the rules for this section found in the "Sticky" thread

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-04-2018, 06:00 PM Thread Starter
Super Moderator
Points: 20,980, Level: 91 Points: 20,980, Level: 91 Points: 20,980, Level: 91
Level up: 26% Level up: 26% Level up: 26%
Activity: 100% Activity: 100% Activity: 100%
 
Big Blue's Avatar
 
Join Date: Oct 2015
Location: East Coast of Florida
Own a Commander?: Yes
Model year: 2008
Trim Package: Sport
Power-Train: 4.7L V-8
4WD
If 4WD - system: QT-II
Current Mileage: 102,100
Posts: 5,076
Garage
WAM Custom Bumpers....A follow up review 1 year later.

Here is a link to the thread I posted when I visited WAM's shop 1 year ago and had my custom front bumper installed which has all of WAM's contact info in the very first post:

https://www.jeepcommander.com/forums...pers-shop.html

Here's a link to their website: https://wambumpers.com/

This is a review and some follow up info, 1 year after the install:

I had the installation done at WAM's shop & they did an alright job - they did not do a great job.

Negatives:

Some things to bare in mind for anybody that is considering this upgrade, this is not a flawless, perfect process, there is tweaking that needs to be done post install; IE securing the forward, bottom part of the front wheel tubs in place and securing the bottom of the grille in place; Cutting away the front fascia from the factory bumper cover does away with the factory clips/mounting points that normally holds everything neatly in place - and I'm sure there will be similar issues with the rear bumper as well if anybody chooses to get a WAM rear bumper/tire carrier installed. These are the kind of details people don't give any thought to - until they are staring you in the face. At least that's what happened to me.

They had to remount the motor for the winch because where they mounted it initially, the connector for the handheld winch control would not fit; (there was not enough room between the Whammy Commander bar and the winch motor and the connector is somewhat long) WAM bought the patent/design for this Commander front bumper from the original designer which was Tactical Armor Group.....when I went to their shop, I found out that the Tactical Armor Group founder (whose name I do not remember) was actually there working for them - which I found a little ironic but unfortunately, he was not around during this part of the install, as it's one of the final steps towards the very end of the job - otherwise I'm sure he would have caught it. The folks at WAM (Natalie in particular) asked me not to mention the TAG founders name and did not want him to be mentioned as an employee of theirs, in my initial write up about my visit to their shop (which I found somewhat odd) and that's why I don't remember his name - but here is a pic of him:



Tactical Armor Group Founder

So they had to drill a second hole for the winch mounting bracket and spray paint over the old hole - during this process, they managed to get some over spray on my headlights - which I caught right away and was able to clean off; they also got some over spray on one of the large PIAA fog lights that I could not clean off, fortunately they a spare on-hand that they replaced it with on the spot.

My smaller PIAA fog lights were actually mounted upside down (which I didn't notice until after I got home) I disconnected them, pulled them out and flipped them over while I was home on leave back in January, took me maybe a half an hour.

I had to paint the mounting bracket for the winch motor, as it was just a bare piece of steel that would have been good & rusted by now, had I not done that shortly after the install.

The paint job - particularly on the lower half of the bumper and where the cuts were made, was what I would call sub-standard; I have already sanded down the edges and repainted the entire lower half of the bumper (with a paint brush instead of spraying it) last month to keep it from rusting - some minor surface rust & discoloration was already starting to show, in areas where there was little - to almost no paint at all, in some of the crevices where there were tight angles and on a lot of the underneath flat surfaces as well.

Fortunately, because I'm very meticulous and routinely crawl around underneath my XK, I caught it early enough to where it was repairable and didn't cause any permanent rust damage.

Considering this bumper/install cost me $2,300.00 these are things I don't think I should have had to deal with post install, as well as things I don't think I should have seen in just 1 year's time, with a very limited amount of driving & outdoor exposure.

Positives:

Now I will say that WAM only charged me for 4 hrs of labor - but the job wound up taking them a full 8 hours from start to finish, so they gave me 4 hours of labor at no charge. I will also add that because of my work schedule, I could only give them 30 days advanced notice and they went out of their way to squeeze me in - which I did greatly appreciate. I'll say that from a communication & customer service aspect, WAM was exceptional.

But at the same time, I paid them in full - well in advance of the job being done - and the quality of some of the install work was definitely a little sloppy, now that I've had some time to look back on it & reflect. I'm not trying to rip WAM by any means, I just want anybody that is considering going there to know & see the Big Picture.

But at the end of the day, I'm still quite happy with it and have no regrets about the purchase.






To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Big Blue; 05-13-2019 at 04:01 PM.
Big Blue is online now  
Sponsored Links
Advertisement
 
Reply

  Jeep Commander Forums: Jeep Commander Forum > Buy/Sell Forums > Buyer/Seller/Vendor Reviews

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Jeep Commander Forums: Jeep Commander Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome